CoreELEC 20.0-Nexus_rc1 Discussion

It will be available for everybody in a few days. And I hope more users will be happier :slight_smile:

1 Like

I am not using default skin, but that has nothing to do with it, because the Live TV tab is missing most of the time (but NOT always!), sometimes it does appear

Would like to dl the new update, but confused about the .tar with N2 and N2L what’s the difference between them?! Thanks for explanation in advance. Greetz, J.


I mentioned it because on estuary the tab doesn’t disappear, it’s always there and it would be easier to debug the problem. If you don’t want to try it so we can check if it’s a skin problem, that’s ok. Provide logs following this coreelec:ce_support [CoreELEC Wiki]

I tried to compile the latest CoreELEC version (coreelec-20), but this attempt failed with

GET      u-boot-Odroid_N2L (archive)
http://: Invalid host name.
--2022-12-17 14:45:53--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-12-17 14:45:53 ERROR 404: Not Found.

The repository u-boot-private either does not exists or it is a private repository and not available for common use.


Missed that - fixed. Update repo and try again.

The coreelec-20 build is successful. Many thanks.


After updating to Nexus rc1, InputStream-Adaptive is not installed/working? Therefore apps that depend on it are not working, ex. Netflix. This is confirmed by @retroluv.

It’s a problem that’s already detected and we’re working on it. In some cases it goes away if you do check for updates in the addon menu (left side submenu).

Thanks for this information.

To you and all having this problem please redownload the corresponding release (Nexus rc1 or Matrix) and try the addons again. It should now be solved.

Pardon my confusion, I am running the NE version, but the downloads for the NG version. Can I download and install the NG version.

Edit: to answer my own question, I downloaded the NG version and tried to install it. It says it was incompatible with my NE version, so it would not install.

Ah, no, not for ne. Wait for the auto update

I did find out that it would not install, which is good.

I suppose it is a FAQ and I apologize …

Do none, some, many, most, or all Matrix add-ons work for Nexus or does one better wait for Nexus specific ones (I ask because several add-on zips have ‘matrix’ in their name, so maybe we now shall need to look and wait for add-on zips having ‘nexus’ in their name?

Can someone test network speeds on the ODROID N2 or N2+?
Im getting a 1Gbit/s link rate but i can realistically only get 100mbit/s from the device.

Of course there will be issues with addons not being ported to Nexus.
And there Dependencies.

I read somewhere that as of January 2023
Kodi drops support for Matrix.

It is Progress New Kernel 5.4.125 !!!

Developers will move addons to Nexus as Time allows.

Also Matrix will still work for quite awhile !!

Happy Testing

*** Update
Just finished reading article from 4 days ago
All Addons for Nexus are written in Python 3
As was same requirement for Matrix Python 3

So will be little /to No issues with Addons.

1 Like

Closed, please continue here