CoreELEC 20.0-Nexus_rc2 Discussion

That fixed it. Thanks.

The Kodi log is full of errors about not supported repository.zachmorris format. It comes from the built-in Kodi game repository which cannot be removed or disabled. Not sure if this should be reported here or to Kodi.

Try nightly where repo was removed.

Hi !
I updated 19.5 rc3 to Nexus rc1.
Odroid N2+
When I start a video I have “100% cached” which stays in the middle of the screen.
Has anyone had this problem?
Thank you :wink:

Start with fresh install when switch major versions. Or at least try first with separate sd card/usb stick.

1 Like

On my Ugoos AM6B PLUS, there is no Analog (Av OUT socket) PCM audio. All other Audio outputs work fine.

The same issue was there in CE 19:

IS this something that can be fixed in the next CE release?
Thanks so much :slight_smile:

2 posts were merged into an existing topic: Nightly builds (NEW)

Beelink GT-King in Audio settings - Keep audio device alive - “Always” not working anymore (however 1-10 Minutes setting works)

Screenshots 4k not working since a while ago, probably never worked, any hope on ss with nexus ?

no, for screenshots you will need to enable double buffer in kernel. for h265, vp9 and av1.

On a semi-related note, the Kodi xbmc.RenderCapture interface no longer works in CE20, was largely working fine in CE19, including latest nightlies, with double write enabled.

Not sure if it has anything to do with this?

Playback stalls and stops after sometime as cache runs out. Odroid N2+ with LAN (1gb connection), same thing happens with wifi albeit faster.

Dmesg log:
http://ix.io/4kYO

Debug log

Anyone got addon Speed Tester working from Kodi repo?

VIM3 Pro works, thanks to the Сoreleс team!
Don’t forget us…


Hi,

Problem

I want to step from CoreELEC 9.28 non-ng to CoreELEC 20.0-Nexus_rc2-ng. My DVB-T2-HD is not fully supported natively. Other drivers had to be installed. The workaround for that (1 2), that worked with 9.28 and 19.5-ng is not working. DVB driver module switcher (CoreELEC Module Drivers) crashes.

The log .kodi/temp/kodi.log reads

2023-01-14 20:11:16.695 T:3696     info <general>: CActiveAESink::OpenSink - initialize sink                                                                   
2023-01-14 20:11:16.695 T:3696     info <general>: CAESinkALSA::Initialize - Attempting to open device "default"                                               
2023-01-14 20:11:16.702 T:3696     info <general>: CAESinkALSA::Initialize - Opened device "default"                                                           
2023-01-14 20:11:16.703 T:3696     info <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats               
2023-01-14 20:11:16.703 T:3696     info <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4                                                 
2023-01-14 20:11:56.792 T:3696     info <general>: CActiveAESink::OpenSink - initialize sink                                                                   
2023-01-14 20:11:56.792 T:3696     info <general>: CAESinkALSA::Initialize - Attempting to open device "default"                                               
2023-01-14 20:11:56.798 T:3696     info <general>: CAESinkALSA::Initialize - Opened device "default"                                                           
2023-01-14 20:11:56.799 T:3696     info <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats               
2023-01-14 20:11:56.799 T:3696     info <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4                                                 
2023-01-14 20:12:12.876 T:4254    error <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--         
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!                                                            
                                                   Error Type: <class 'AttributeError'>                                                                        
                                                   Error Contents: module 'xbmc' has no attribute 'translatePath'                                              
                                                   Traceback (most recent call last):                                                                          
                                                     File "/storage/.kodi/addons/script.program.driverselect/default.py", line 1, in <module>                  
                                                       from resources.lib.tools import *                                                                       
                                                     File "/storage/.kodi/addons/script.program.driverselect/resources/lib/tools.py", line 10, in <module>     
                                                       PROFILE = Blockquotexbmc.translatePath(xbmcaddon.Addon().getAddonInfo('profile'))                                 
                                                                 ^^^^^^^^^^^^^^^^^^                                                                            
                                                   AttributeError: module 'xbmc' has no attribute 'translatePath'                                              
                                                   -->End of Python script error report<--

Full log can be found here.

This is a Z69 S905X 3GB/32GB box with a HanfTek Astrometa DVB-T/T2/C FM & DAB receiver [RTL2832P]. When using DVB drivers from latest kernel, the DVB-T2-HD device was functional with tvheadend in 9.2.8 and 19.5-ng. However with 20 the Module drivers selector seems to be broken.

Steps to Reproduce

  1. Fresh Install of CoreElec 20.0-Nexus_rc-ng on SD Card (copy gxl_p212_3g.dts as device tree)
  2. add remote.conf to .config/
  3. Finish installation
  4. Install Addons
    CoreELEC Add-ons > Dienste/Services > DVB drivers for TBS
    CoreELEC Add-ons > Dienste/Services > DVB from the latest kernel
    CoreELEC Add-ons > Program-Addons > CoreELEC Module Drivers
  5. Run CoreELEC Module Drivers to select drivers via GUI
    Addons > CoreELEC Module Drivers
  6. Result: CoreELEC Module Drivers Error, see picture above.
  7. Expected Result: Selection Dialogue appearing as in previous versions

Thank you very much for your time

krelmatrix

Manually update the addon script.program.driverselect to 0.1.6.1.1. There was a old version located confused the update system.

Yes
Only in Matrix though

Have tried in Nexus ng and ne

Just hangs…

Maybe has not migrated to Nexus yet?

CPU Benchmark works in Nexus.

Happy Testing

Hi Portisch,

Thank you for your immediate reply. I tried to install version 0.1.6.1.1 from here over 0.1.6.1.100 from repository and got an error “Dependencies of xbmc.python in Version 2.25.0 could not resolved”:

2023-01-15 08:49:56.654 T:3674     info <general>: Loading skin file: FileBrowser.xml, load type: KEEP_IN_MEMORY                                                                              
2023-01-15 08:50:00.413 T:3940    error <general>: CAddonInstallJob[script.program.driverselect]: Die Abh..ngigkeit auf xbmc.python in Version 2.25.0 konnte nicht aufgel..st werden.        
2023-01-15 08:50:25.187 T:3703     info <general>: CActiveAESink::OpenSink - initialize sink 

See full log

Thank you very much

krelmatrix

Should be fixed tomorrow. It should be 0.1.7.0.0 tomorrow I think

2 Likes

The new addon version 3.0.1… is online now and should automatic update itself.

Hi Portisch,

I installed it an hour ago manually. It works now. I.e. this addon version installs and when selecting the Module Drivers addon the selection dialogue opens up. I can select another driver and it does something. With the main line kernel driver backbport I see all modules of the DVB-T2 stick and a channel scan is successful.

However, when playing channels, the signal appears to be much weaker compared to the 9.2.8 setup: No image and stuttering sound. I cannot use this.

When remove the sd card and booting 9.2.8 from internal kodi can play great tv from this stick via tvheadend. Unfortunately, I have no idea if this is nexus<>leia/ ng<> legacy / or somehting else related. I have no idea how to debug.

I switch back to 9.2.8. Thank you again for speedy reaction. This is fun.

krelmatrix