CoreELEC 20.3-Nexus Amlogic-ne Discussion


Please use this thread for general CoreELEC 20.3-Nexus Amlogic-ne discussion

Before posting an error please follow these troubleshooting steps.

Upgrade NE arm to aarch64 went fine (needed to change to 64bit libwidevine).
I also noticed on NE S905X4 load and temperature dropped.
Great work.

is this the official release? or is this a pre release?

github has it as a pre release, git version is 20.2

I have been running coreELEC 20.2-Nexus on a Tanix X4 since Christmas without issue.

Immediately after updating to 20.3-Nexus using the Available Version found in the Update Channel, the Tanix X4 began displaying a blank screen with no audio whenever it attempted to stream content (regardless of the add-on being used).

I was able to correct this issue by downgrading back to 20.2-Nexus using the Available Version found in the Update Channel.

According to the release notes for 20.3-Nexus, the recent update includes the use of Android libraries for SC2 S905X4 enabled devices and therefore I am going to go out on a limb and presume that may the culprit.

A debugging and recoding may be required for 20.3-Nexus in order to avoid this issue for owners of S905X4 devices who update to 20.3-Nexus.

1 Like

I’ve been using CE20.3-based builds for a longer time now without any issues on my Homatics Box, which also has that SoC.

Links do not exist when I try to download it (ne-version) via CoreELEC:

The proper links are here:

The difference is in “arm” → “aarch64”.

Should be fixed now.

Amlogic-ne does now point to arch aarch64 and Amlogic-ng does point to arm.

1 Like

I also have an S905X4 box. Namely an X96 X4. After updating to 20.3 I had no network access (neither WiFi nor LAN). The network adapters were deactivated and could no longer be activated. Even a manual downgrade (via USB stick) did not solve the problem. The existing backups could not be saved on the USB drive.

I ended up spending many hours searching for a stock firmware version that would make the network adapters available again. Ultimately I was able to repair it with the stock firmware and reinstall and configure CoreELEC.

I’ll ask again. why is this labeled as a pre release?

github has the latest release as 20.2

Screenshot 2024-01-26 at 8.36.59 AM

So much pain for what? :thinking: One spare card for testing? Denomination in Github is just to prevent eager testers to byte the bullet - some hidden bugs could be annoying. A few days before the label ‘stable release’ keeps at bay a lot of annoyances.

not is actually quite annoying and confusing! on the website it is listed as a Stable release. but on github it is a pre-release!

Pre-release = Testing prior to Release
Stable = Production Release

We tend to wait a bit until label as released and trigger the auto update for users.

Had it set to manual update with notification, and today it popped up saying there is an update would I like to download… I click ok and nothing happens. Gave it 10min and rebooted and again, update available and does nothing when clicked. Switch to auto update and basically same thing.

I saw something about if installed before Jan17, reinstall… Does that mean the update won’t work? I have to format my SD card again? Then rescrape the library?

It should just download the update and that’s it. You can downloads it yourself and place it in the update folder.

Well, then I have a problem because it’s not doing anything. Just restarted it now to see and update message pops up again.

I’ll have to Google where the update folder is found.

Ok… Manual update worked.

Went to Media-General and enabled “show hidden files and directories”. Then File Manager-Add Source, browsed to Root filesystem, Storage, and .update was in there, added as a source.

I have the Download Folder on my PC mapped so downloaded the update there and used file manager on Kodi to copy it to the update folder. Reboot and installed fine.

Otherwise, manual or auto update didn’t work. Latest build showing as available was 20.2 so I tried updating to that (same version already on here) and it updated and restarted, said 20.2, and said update available again but wouldn’t update or show 20.3.

Do you not see CoreELEC in your Network all Folders?

On PC i mean in Network.

You will need to access config files folder
If you want to get remote and or you Front Display Working.

@freddy don’t see it under Network on PC, but, my way worked, it shows 20.3 under version.

Still be nice to know why the update not working properly. But it works.