CoreELEC 20.3-Nexus Amlogic-ng Discussion


Please use this thread for general CoreELEC 20.3-Nexus Amlogic-ng discussion

Before posting an error please follow these troubleshooting steps.

Ok, where is the download link? On Github 20.2 is the latest one, except 21 ones.
There is a 20.3 update channel inside Coreelec but when selecting update to 20.3 nothing happens.

1 Like

We currently perform a Hot-Fix update for Amlogic-ng-dv images. It will be available again after finish the upload.

1 Like

Thx Portisch :slightly_smiling_face:

In download section for 20.3 ng, there is a tag “Pre-release”, but is it?

Did the upgrade yesterday, from 20.2-ng-arm, on my x96_x4 v1.3, worked flawlessly.

Mecool Ki pro dvb module isn’t working

Mecool isn’t supported vendor.

1 Like

will this support ugoos am8? if not, when can support it?. thank you.

i tyied 20.3 ng-dv in my am6b+ tonight,some movies playing smoothly but some can’t play,black screen and purpel or green, a big step anyhow,great work!

the same. on version 19.5 everything works

20.2 realize Nexus dvb working fine

If it worked with 20.3 and not anymore on 20.3 you will need provide logs:

1 Like

Hi, @Portish! is taking a break :beers: therefore, I will post the dmesg file where dvb works normally
CoreELEC (official): 20.2-Nexus (Amlogic-ng.arm)
Machine model: Amlogic
CoreELEC dt-id: gxl_p230_k1_pro
Amlogic dt-id: gxl_p230_2g
dmesg.txt (75.7 KB)

I am not sure anymore but you might need to enable “DVB GPIO Support” in CoreELEC settings.

I don’t quite understand how to do this

Can somebody please advise me what the dv version is all about as I have never heard of this before. “Introduced new device Amlogic-ng-dv” What boxes are these for ?? Assume it is not for the Ugoos X4Q or AM7 devices ???

IPTV Simple Client addon broke after the update to 20.3. In case anyone is wondering, the same streams work just fine on my PC (which is hardly a surprise, because these are legal streams). Did anyone experience anything like this after the update? Reinstalling the addon did not solve the issue.

I am seriously embarrassed, just looked at dmesg and the culprit looks like a failing SD card :frowning: