CoreELEC 8.95.4.3


#47

Because 8.95.4.3 didn’t get set for auto updating. It’s manual update only, since it helps some people but has issues for others.


#48

Hi
The 8.95.4.2 for s912 works perfect on my g1 ultimate.
After the manual update to 8.95.4.3 i have again the blackscreen :thinking:.

Please someone can give me the link for arm s912 8.95.4.2.tar download?

Thanks
Rad


#50

#51

2040:0265 Hauppauge (WinTV DualHD) stopped working (disappeared from TVHeadEnd).


#52

Can anyone point me to the link for the earlier version 8.95.4.2

thanks


#53

Other question please is the 8.95.4.3 the Kodi BETA4 or the new BETA5?


#54

It’s the beta 4. If you want to try beta 5, it is included in the latest nightlies.


#55

Will CE 8.95.5 coming soon then?


#56

If you are having display problems with the 8.95.4.x releases. There is an updated release that needs testing before we can move on to a 8.95.5 release.

Note: To make sure we get accurate results when testing you should remove any custom disp_cap file and make sure that you have not added anything like echo 422,10bit > /sys/class/amhdmitx/amhdmitx0/attr to your autoatart.sh file. Writes to /sys/class/amhdmitx/amhdmitx0/attr can break stuff now (If you don’t know what that is you’re probably ok. :slight_smile: )


#57

Do you believe that issues with the remote control are solved, I mean, I don’t see it in the fixes list.
Thanks


#58

I’m not sure why the remote issue popped up in the previous release. Can you try a nightly build to see if the remote issues is solved there. The 8.95.4.42 release is just focused on solving the display issues, and outside of that is actually well behind the current nightly release.


#59

@cdu13a, what do you mean by this? We are still able to run the following if we want, right?

echo “444,10bit”>/sys/class/amhdmitx/amhdmitx0/attr

Cause I’ve noticed that some 10-bit content don’t get recognized as 10 bit. Here is an example from playing 10-bit content.

Mediainfo:

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Commercial name                          : HDR10
Format profile                           : Main 10@L5@Main
Codec ID                                 : V_MPEGH/ISO/HEVC
Duration                                 : 1h 5mn
Bit rate                                 : 17.7 Mbps
Width                                    : 3 840 pixels
Height                                   : 1 920 pixels
Display aspect ratio                     : 2.000
Frame rate mode                          : Constant
Frame rate                               : 23.976 (24000/1001) fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.100
Stream size                              : 8.03 GiB (96%)
Writing library                          : x265 .......
Default                                  : Yes
Forced                                   : No
Color range                              : Limited
Color primaries                          : BT.2020
Transfer characteristics                 : PQ
Matrix coefficients                      : BT.2020 non-constant
Mastering display color primaries        : Display P3
Mastering display luminance              : min: 0.0001 cd/m2, max: 1000 cd/m2
Maximum Content Light Level              : 999 cd/m2
Maximum Frame-Average Light Level        : 228 cd/m2

From running the following during playback

CoreELEC (official): 8.95.4.2 (S905.arm)
CoreELEC:~ # cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 8-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

Running the following command to force 10-bit

CoreELEC:~ # echo “444,10bit”>/sys/class/amhdmitx/amhdmitx0/attr

CoreELEC:~ # cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

I can investigate this more in the following weekend when I have time so you get all logs etc, however, why not force all content to be played at 10-bit? There shouldn’t be any difference in picture quality from playing 8-bit content with 10-bit mode, it’s the other way around that decreases picture quality…


#60

I have just done a fresh install of 8.95.4.3 & the remote now works


#61

After updating to 8.95.4.3, my Wetek Play 2 does not recognize the remote control.


#62

See the post above yours


#63

Thank you for reporting it.
After the problem with the remote I tried a fresh install too, but it didn’t work either.
I downloaded 8.95.4.3 again but I see no differences in the size, date, or contents. Has it changed in the last 3 days?


#64

my avr is reporting everything as playing 8 bit


#65

@Duke Can you ssh into the device and execute the following two commands. This downloads a script that will upload the display debug info from you device and provide you with a link you can post here for us to be able to get a better idea of what is happening.

wget https://discourse.coreelec.org/uploads/default/original/1X/a22d7f0fb8a08caa15a63dc8a5dad51c8befbf43.sh -O dispinfo2.sh
bash dispinfo2.sh

#67

http://ix.io/1rkp


#69

I can’t explain it, my suggestion would be to try an earlier build, but I don’t know where to get them.