CoreELEC 8.95.6


#46

@d-vine I use my Harmony remote to turn on my system and the Minix works with it.


#47

@Vinylity I test the remote and nothing works with the CE rc2 version… beta no problem
the MINIX remote worked.
I understand I could set the MCE but manage to make a new file where all my remote buttons are in.
And it is fun to do so…


#48

Same for me, everything worked until this update. Followed what @adamg said about SSH into the Minix and the Harmony worked.


#49

Hi, updated no problem on my S905 Minix and S912 H96Pro+.
Image quality is fantastic.

Question: how do I know colourspace autoswitching is actually working for my HDR videos?


#50

I use my AV receiver to check it. I have a Denon receiver, so i go to General > Information > Video and it shows me everything.


#51

@Spinecho, ssh into your box and run the following:

wget https://discourse.coreelec.org/uploads/default/original/1X/a22d7f0fb8a08caa15a63dc8a5dad51c8befbf43.sh -O dispinfo2.sh
bash dispinfo2.sh


#53

Thanks…what does this do?


#54

@Spinecho the dispinfo2.sh is a script I made to collect graphics debug info and make it easy to post online.

If you just want to see info about the current display settings such as bit depth it is easier to just use the following.

cat /sys/devices/virtual/amhdmitx/amhdmitx0/config

Which will show just the current display configuration.


#55

Thanks.
Do I do this when I’m playing a video?
Also, what results would I expect to see?

Sorry for the questions.


#56

@Spinecho, Yeah. If you run the command before you’ll see this result

------------ /sys/devices/virtual/amhdmitx/amhdmitx0/config ------------
cur_VIC: 16
VIC: 16 1920x1080p60hz
Colour depth: 8-bit
Colourspace: YUV444
Colour range: limited
EOTF: SDR
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

If you run the command during playback of 10-bit HDR10 content you’ll see

------------ /sys/devices/virtual/amhdmitx/amhdmitx0/config ------------
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off


#57

@CI6N0Z…wow! Fantastic. Works perfectly and shows me autoswitching is functioning.

One question…why is colour range limited? Is this normal?


#58

@Spinecho, If you read about how TVs and PCs handle video signals, you’ll find that they handle it differently. TVs have a smaller colour space which means that they have a smaller range (“limited”), 16-235 as an example for 8-bit signal vs 0-255 (“full”) - the range PCs use. This is nothing to worry about as the loss from “full” to limited" in range is minor compared to the difference between example 8-bit and 10-bit. The important factors regarding best possible quality are resolution, colour depth (range), which is 10-bit for HDR10, and the colourspace, YUY444 or YUY442.


#59

Thank you for another informative post.


#60

Tried this version on my wetek hub.
But the remote stopt working so i went back libreelec is it possible to fix this


#61

I’m also using the Wetek Hub and the remote is working flawless.
Did you copy the right device tree?


#62

I used wetek hub dtb from the folder isnt this the right one?


#63

It is the right one.
Did you copy it to the root of your sd card and renamed it to dtb.img?
What exactly isn’t working?


#64

I’m having sound issues with this build. Sound interrupts for fraction of a second when watching videos. It’s totally random. Sometimes there’s only one or two interruptions and sometimes plenty of them.
There are also some cache issues that didn’t happen before. Changes in cache in advancedsettings did help but that didn’t resolve the sound interruptions.
Can’t say if it was present in previous builds because this one is first that I’m using so extensively.
I’m sure it’s not settings thing. Everything is set to default. Looks like a bug to me.


#65

You didn’t post any details of your setup, which device you are using, how your media files are connected to your device, a debug log or anything else.
If it was a general bug, many other users would have the same problem, which isn’t the case.


#66

I will try it again after x-mas… glad to hear its working for you.