CoreELEC 8.95.7


@Kovacic.janez I have a Philips TV and CEC works perfectly fine, your Odroid is viewing the IR code from the Philips remote as well as your TV, so 2 commands and being sent to Kodi.

You need to create an empty IR map file, it’s already explained in the forums.


FYI I had to reinstall MySQL and start again from scratch, it’s now working OK. I can only assume the db upgrade corrupted something.


I don’t think, that this would be a problem as long as it’s deactivated.
But you could try to uninstall this skin to see, if your problems are gone afterwards.
If it still crashes, we would need a full debug log.
The crash log alone isn’t detailed enough.


The next release will be the final so there will be no more db upgrades or api bumps so hopefully you never see an issue like that again, I’m rather perplexed as to how it happened though.


Thank you :slight_smile:


No worries, it’s sometimes good to have a fresh clean start anyways!


Hello first of all thanks for this great OS.
My experience with this version 8.95.7 with both of my MINIX U9-H Amlogic S912 is that now most of the Movies or TV Shows Play correctly without the cracking interference like Audio Noise thru HDMI but in some movies like some older TV Shows in aac 2.0 and some ac3 5.1 audio format that loud like static interference cracking noise is still present.
It is a big improvement from 8.95.6 because on that version the Audio Noise thru HDMI was present in ALL videos.
Don’t know if there is any configuration that I have to change to solve this issue but in the meantime I downgraded to version 8.95.3 that is working very well on both my MINIX U9-H.
Thanks for all Your Help and Thanks for this great OS.


Nothing has changes between the versions that would affect this, this is not the place for bug reports, if your having issues then please open up a thread where your issue can be dealt with properly.


Installed today kodi-20190111-baff0a18-master-armeabi-v7a.apk
and lost the connection to MySQL DB with Movies/Serials information…
Funny thing is that other android devices, with older nightlies installed on them, do not exhibit this issue…:woozy_face:
So, beware!


Looks like they are trying to fix now that they broke before :slight_smile:


Two new crash logs with full debug enabled:


Can you send some more?


@daxue @ynnsn the issue is fixed in the nightly.

Issue was change in coherent dma pool size, the change has been reverted now.


Will there be another CoreELEC release based on RC5.2 or do you wait for the Final 18?

Eager as I was I installed RC5 on 2 other systems (Android and Windows) and now the SQL bug mentioned above hit me.


I’ve solved (for now) MySQL issue generally: upgraded the server and DBs to 8.x
The other way would be to downgrade respective Kodi versions to such, below the abovementioned nightly… :slight_smile:


Yeah, I know… but I was clever enough to delete the old database before I noticed the bug :roll_eyes:


As @ChimeyJimmey already suggested, upgrading your database solves the issue.
These are the database versions suffering from this problem:

  • mySQL <= 5.7
  • MariaDB <= 10.1


I tried the latest nightly 20190114 but there is another problem starting kodi:

Jan 15 19:17:01 CoreELEC systemd[1]: Starting Kodi Media Center…
Jan 15 19:17:01 CoreELEC systemd[1]: Started Kodi Media Center.
Jan 15 19:17:01 CoreELEC[3705]: /usr/lib/kodi/kodi.bin: error while loading shared libraries: /usr/lib/pulseaudio/ unexpected PLT reloc type 0xd2
Jan 15 19:17:01 CoreELEC systemd[1]: kodi.service: Main process exited, code=exited, status=127/n/a
Jan 15 19:17:01 CoreELEC systemd[1]: kodi.service: Failed with result ‘exit-code’.
Jan 15 19:17:04 CoreELEC systemd[1]: kodi.service: Service RestartSec=2s expired, scheduling restart.
Jan 15 19:17:04 CoreELEC systemd[1]: kodi.service: Scheduled restart job, restart counter is at 69.


ynnsn: Can you run sha256sum and post the result?
sha256sum /usr/lib/kodi/kodi.bin /usr/lib/pulseaudio/

You can try run this and see if kodi starts.
echo 3 >/proc/sys/vm/drop_caches

Also which image you are using?
Does it happen after reboot too?


I reinstalled the nighty and now kodi starts and crashes again like with the update to 8.95,7.