Coreelec does not boot in X96 mini

the dt-id is gxl_p281_1g then follows the bash prompt wich is p281:/ $

dtb.img (40.2 KB)

The box has 2Gb ram. for sure. Now I am confused which is the the proper dtb. gxl_p281_1g or gxl_p281_2g?

Have you tried the gxl_p281_1g dtb?
Edit: You tried, I see…

I meant dtb from the Android, not from CE

How can I do this?

Yesterday I extracted X96mini 2g original Android FW, this includes (as it should be) a multi-DTB file gxl_p281_1g and gxl_281_2g. In your case the gxl_p281_g1.dtb will be loaded by the uboot, which corresponds to a device with only 1g RAM memory (more was not initialized). I have exactly the same x96mini box, but with real 2g RAM memory. Booting to the CE only worked with the console command “reboot update”. In an attempt to make a SD card upgrade to another Android FW, the box was suddenly put into a boot loop, so I had to flash a new bootloader by changing the boot sequence (from eMMC to SD card). Download the latest Android FW for your box and try for the time being to upgrade using the AML-Burning-Tool and write short about results

I’m thinking to flash an other custom rom like Tanix T3 mini or ATV via sd burning tool maker. I don’t know if it is better to delete the bootloader and erase flash via instalation or this gona brick my device. Then I will try to install coreelec. What is your opinion?
Thanks you very much for your help.

Try to find and install the latest original Android FW. The purpose of this action is to bring the old bootloader up to date and to check if the update is even possible. For BL Update you have to check the option “erase Bootloader”. If necessary, we can also replace the bootloader by hand.

Hi my brother just got one of these supposed 2G/16G x96mini from amazon. It would not boot with gxl_p281_2g but did work with gxl_p281_1g maybe if has fake RAM will check when I there again. It had [ZBFYZQ] in the top as well as x96mini.

Thanks all of you for your help. I change x96 mini with H96 pro+ and everything is OK with Openelec from the first boot.

This is CoreELEC, not Openelec. But I’m glad you got it working.


Sorry to butt in,I’m having the same probs with my X96 Mini 2Gb 16Gb.
Aida64 reports numerous sd devices as blocked in \system\blocked.
Could erasing these would that allow booting from sd cards??

1 Like

Wow CoreElec worked out of the box for my X96 Mini 2gb/16gb.
Everything works so smooth including the Wifi.
Great work CoreElec Team. Thanks for supporting so many devices.


I installed 9.2 stable on a X96 Mini with suggested dtb (gxl_p281_2g.dtb), the box booted and resized the SD partition correctly, but then it went in a reboot loop after the Coreelec splash screen.
I tried the nightly then, and with the new dtb the device booted fine, so I tried the stable release with the dtb from nightly and the device also booted fine (no loops).
Currently I run 9.2 stable with dtb file from nightly.
I also noticed a (maybe) incorrect load average: uptime reports an average load >7, but with top I see all cpus >80% idle. Iostat reports low iowait (<0.5%). Temperature is critically high though, >60°C in idle with the case open, 85°C when playing movies.
Any ideas?
I’ll help, if necessary, by providing additional details to debug this issue.
Thank you

Can you please do a fresh install of Nightly.
Run it and report how it runs ?
Not sure what’s going on with the stable 9.2 on your box.
Just to compare if the fresh nightly works before trying 9.2 again.

I had the same problem: I tried to run 9.2 stable on my X96 mini (2GB ram).
It boots, it resize the partition then reboots. Until then, no problem. But after that it goes into an endless reboot loop. It boots up to the Coreelec splash screen, display Coreelec version then reboot… in loop.

I’ve tested with different dtb : gxl_p281_2g.dtb, gxl_p281_1g.dtb, 212, etc…
From readings on forum I started suspecting a bad SD Card, a fake X96 mini with Rockhip CPU, etc… But I tried an old community version of LibreElec (LibreELEC-S905.arm-8.2- with gxl_p281_2g.dtb and it just runs fine.
So I gave a try to CoreElec nightly (CoreELEC-Amlogic.arm-9.2-nightly_20191003-Generic) with gxl_p281_2g.dtb and it also runs fine.

So there is something problematic with the stable version on X96 mini that has problaby been corrected on the nighly version…
Note: the Nightly version of CoreElec with gxl_p281_2g.dtb extracted from the Stable version does also works…

1 Like

I had the same problem. Forever booting in the Coreelec menu. I had to download the nightly version. The stable version does not work.

update: 9.2 stable (with its dtb file) on x96 mini 2g boots fine after the first full boot with the nightly version, no more loops. weird.
after taking care of the cooling problem with heatsinks, a fan and some pain, cpu and gpu are both under 50°C, no more offline cores.
the problem with the undiagnosticable high load ( >6 ), despite high cpu idle time and low iowait remains. I tried blacklisting unnecessary modules and the best progress was made getting rid of ssv6051 (after this load dropped 50%, with an usb wifi interface running) but of course that means no integrated wireless.
another thing I noticed is that 90% of interrupts (no balancing here: most interrupts are on cpu0, maybe this is improvable) are by sd_emmc, with zero i/o load.

Hi. I had the same problem in two x96 mini 2gb/16gb. After one month testing all the dtb img of the device tree I´ve got boot coreelec from a miniSD with the coreelec 9.2.1 version using a TV model LG ( 19LD320-ZA) .But If I conect this tv box in others TV I can´t see anything, the screen stay with the image in black, but if i test with the app Fing detect coreelec conected to the network. Anyway I couldn´t install coreelec in the internal memory using the only TV that allow me boot coreelec from the miniSD.