Coreelec does not boot in X96 mini

I will try this obe thanks, i hope it will boot i Will give you info uf its done

it stucks on x96 logo

You tried different device tree ??

No my friend i only tried the one you suggested me , it seems it is trying to boot without success

Try the gxl_p281_1g

Ok i hopr itnwill work, but my box has 2 gigs of ram as Aida 64 says

Aida can lie easily, it tells you what Android reports, and Android reports whatever manufacturer told it to report :wink:
So you can have a box with true 1GB physical memory, and can “adjust” Aida to tell you that you have 2, 4, 8 or whatever amount manufacturer lied about…

again it stuck on x96 logo :frowning:

For those who might still be interested in getting Coreelec working on their X96 mini, here my experience (I spoiled that I succeed). I own a bunch of Android boxes (2 Zidoo x9s for movie recording, 3 Tanix Tx3 mini 2/16 with AliceUX old and new HW, 1 A95X F1 2/16 with Coreelec and now 3 X96 mini 2/16 I purchased for less than 18€/each)

The standard Android 7.1 was horribly working with a lot of problems (mainly heating that I want to solve by installing a CPU heat spreader and fan in a near future).

Anyway, there was no way I could install on X96 mini 2/16 Coreelec 9.2.3 stable with either gxl_p281_1g / gxl_p281_2g or with gxl_p212_1g / gxl_p212_2g (this was the one I already used on the A95X F1 2/16).

Cpu-z and AIDA-64 app installed in Android kept telling me I had a 2GB version with board p282. That board was not present in CE list. I than installed Terminal Emulator for Android and after opening it I type the command suggested by a BRUMERC on April 19 i.e.

cat /proc/device-tree/amlogic-dt-id

The result was shocking! gxl_p212_1g282 . That means that what Cpu-z and AIDA64 show is false and that my system has only 1 GB of memory.

I than saw that somebody else was successful in installing LE and in fact I succeeded in installing LE using standard version with gxl_p212_1g device tree and it booted! The problem was that version is old with kodi 17.6 but showed that installation was possible.

I then thought that the culprit was the CE version and I downloaded an old version of CE: i.e.

CoreELEC-Amlogic.arm-9.0.1-Generic.img.gz with gxl_p212_1g tree and IT WORKED. After setting up the Wi-Fi the system showed that an update was present and it downloaded CE 9.2.3 and on next reboot it installed it.

Well I than discovered that the board was hosting a S905L and not a S905W as advertised when I purchased it or at leas that Is what CE is showing.

CE 9.2.3 on X96mini

I still had a problem. The remote was useless but for turning on/off the unit. I reverted to a small wireless keyboard and the system responded OK. I than found a remote configuration for the X96 mini using the Repository for Amlogic & Meson Infrared Remote Controllers ( and I choose the VONTAR that I attached. For the installation of the remote.conf into .config I followed the guide

HOW-TO Copy remote controller files in Kodi using a USB Mouse and USB Flash Drive

in a google search box that leads to a Coreelec PDF file with the proper instructions.

NOW I FINALLY HAVE A PERFECTLY WORKING X96 mini (but for the 1GB memory and heat problems).

Hope this serves for others too!

remote.conf (766 Bytes)


Well this was an interesting read.

After blowing up one of my X96 Max :sob:, i purchased 2 of these cheap, one for the kids bedroom and one for the kitchen, so i can watch tv.

They are both S905W Versions 1gb ram.

Installed latest build onto 2x 8gb cards and restored setup from old device, and they are both working like a dream.

They do run a bit hot though wich i think is normal, i put a 60mm 5v fan on the bottom of each unit, soldered to the usb port pins inside, gone from an average temp of 60-65c to 47c. Cool :cold_face:

Couple of questions…

Im not worried about the remotes as i am running a G30 on both, which works perfect, but would be nice to maybe config the originals, forgot where to put the file.

2: Has anyone managed to instal to internal emmc on this device yet, ?

“remote.xml” goes to storage/.kodi/userdata/keymaps

Oh i have a remote.conf ?

Put it to /flash or /storage/.config

FFS its asking for that username and password thing again, last time i just left it blank but wont let me in.

Ignore i just entered anything, copied over and working great :).

So anyone manage to flash to internal on this yet? i have a S905W Revd

Hello Experts,
I also have an issue with x96Mini - 905W 16/2GB. I can not launch the Coreelec with many dtb. Please guide me what to do!
I was trying Coreelec 9.2 and 9.0 and as well dtb gxl_p281_2g, gxl_p281_2g_a95xr2, gxl_p212_2g. I also tried most 2Gb dtb’s from the device tree but did not manage

After that I read the post above and took CPU-z and have this details

What I am missing? Which dtb to use to be able to install and load Coreelec?

Thanks in advance for your support!

You need to push the reset button or use the toothpick method until you see the CE logo.
Search the forum for your hardware.

I have the same box and it works with gxl_p281_2g.dtb without any problems.

Exactly this is my issue - I read that this is the dtb BUT … not starting… wondering why?
Whic version of Coreelec did you install?

So, you have downloaded an image, burnt it to a microsd card using etcher or rufus. You have then copied the device tree to the root renaming it to dtb.img.

You then inserted it, while plugging in the power lead, you pushed the reset button in, & released it, as the logo showed up. ?

Exactly!!! it is not my first installation.
I took the latest version of CE, burn it on a mircoSD with rufus, even change the sd cards to exclude the risk from SD card. Copy, paste the file from the device tree and change the name to dtb with the extension .img. Reboot update and it is freezing with the logo of x96mini. Can not start the first initial installation on the CE and respectively can not launch Kodi