Coreelec support for Amiko A4?

Considering that this STB is a well known brand among satellite enthusiasts, and that is has an AML S905 CPU, would it be possible to add support also for this device ?

I’ve found the device tree on a different forum, I’ll also upload it here. (9.7 KB)

Main CPU: AMlogic S905 quad core Cortex A53 64bit 2.0GHz
Main GPU: Octo-core Mali 450MP GPU (600MHz)
Flash Memory: 8GB

Have you tried it?

Not yet, because I have the combo version (dvb-s2, dvb-t and dvb-c tuners) and I am not sure if it will fit.

You can try it on an SD, without touching the internal memory. This way you will know if everything works or not.

If your looking for a satellite box then you would be better to buy one we do support rather than one nobody has, adding drivers blindly without hardware to test on is near impossible.

Have a look at the MeCool devices.

I’m not looking for it, as I unfortunately already have it.
It runs android but is very sluggish.
I saw that it has AML 905 CPU, therfore I started wondering whether it might work or not…

As others have stated, you can test by burning to sdcard/usb flash drive without altering your device.

Hi friends
i have an amiko a4k and i tried all the dtb. img and dvb adaptrs still empty. I really need help

Hello, @evan801001,

were you successful to install CoreELEC to Amiko A4? I also tried every dtb file, I found and still nothing.


Hello, everyone,

I have installed CoreELEC to my Amiko A4, successfully:

But, I have got still one unsolved issue:

In short, have you got any idea, why one of my Amiko A4’s boxes can’t boot from SD card without pushing of reset button? Thank you.

Hello, @Pelican, @kostaman, @Vasco, @Blakey,

gentlemen, could you be so kind to help me to find right person in your team, who is able to help me with above mentioned?

Thank you very much and have a good day. :smiley:

Guys, does anyone have anything to do with this? I received a message via SC that it could be an SD card. So I picked a card from set-top-box where it works and inserted it into set-top-box where it doesn’t work. She did not. So it won’t be an SD card. I thought of configuring the boot, but how? I haven’t found anything applicable for CoreELEC on the net yet, but I’ll keep looking.

So you have 2 identical Amiko A4’s ?
Are they both on the same Android Version ?

You are saying both boot correctly using the MeCool KI Plus dtb.img

Are you telling us that the problem Amiko A4 boots first time to CE SD Card performing the initial install pressing the reset switch .?

But it does not boot to sd card after it is powered off ??

Or it doesn’t boot from Android .if choosing restart ??

Hello, @kostaman,

thank you very much for your fast response.

These Amiko A4 boxes were bought in the same year (quarter), so I assume, they are identical. The Kodi shows the same CPU. But, if do you need me to double-check it by CPU-Z, I could do so.

They also have got the same (latest) Amiko’s image installed. (I assume it means, they are on the same release of Android installed.)

Yes, both of them use the same MeCool KI Plus dtb.img. (I wasn’t able to use backup from 1st Amiko installed to 2nd one. I had to install it from the scratch.)

2nd one doesn’t boot from SD card after power off or restart. I need to push reset for approximately four seconds, then it boots from SD card, every time.

@anon88919003 explained how the aml_autoscript works HERE

To explain it better the contents of aml_autoscript are saved to the env partition when pressing the reset button.

This partition is read by the bootloader at every boot up and contains the boot commands, that is why it is only needed once because once our modifications are saved then they are there forever unless you do a factory reset.

aml_autoscript contains some basic commands to tell the bootloader to try booting from USB/SD first before the eMMC.

Not sure what’s happening on that one box of yours

Hmm, where is this aml_autoscript located, exactly? Am I able to check on it from CoreELEC? I would compare them on both boxes…

I have got it:

A4KMichal:~ # find / -name aml_autoscript

@kostaman, do you know, which one is original and which one is a copy? (They are identical in both locations, but I need to know, which one do I need to edit, if necessary?) Thanks.

EDIT: It is the one located in /flash/aml_autoscript, because of it is executable.

Don’t mess with anything in trying to fix this.
You can either Reset Android and try again or just wait for a reply from Devs.
Are you using a Samsung Evo or Sandisk SD Card ?
Let us know what you’re using.
If you have a spare USB Flash Drive give that a shot.

Ok, I will wait for your developers.
It is Samsung in both cases according to:

A4Ninka:~ # cat /sys/devices/\:0001/manfid