Couldn't initialise the CEC adapter


This started happening a few days and now my remote doesn’t work. Nothing changed in my setup and I’m pretty sure my tv didnt update either. I’ve enabled/disabled CEC from inside Kodi, unplugged/plugged HDMI cable, tried a different cable but still get that same mesaage when i start Kodi

Here’s a log: kodi.log (211.7 KB)

What box is that? Do you have any other box connected to the tv?

Minix U9, PS4 connected but unplugging that I still have the same problem

I have the same issue with my Samsung TV 6600 on a Clean Build on my N2.

U9-H on 9.0.3?

Very unusual for a stable version to just stop working, either it’s a configuration or hardware issue.

@HPMSGEN8 please enter dmesg|paste on SSH and paste the link.

Also please tell me which version you are using.

I get this - http://ix.io/1QkN

I am running - CoreELEC (official): 9.0.3 (Amlogic-ng.arm)

Yeah U9 on 9.0.3. Nothing changed config wise in months, just double checked and the last update on my tv was June. Here’s dmesg too http://ix.io/1Qmj

@HPMSGEN8 please try the nightly.

@adamg I have done an clean install and connected it to my TV that was it.

I have tried the Nightly ones and Kodi goes into Safe Mode all the time

EDIT:

I just installed a clean version again and used different HDMI Cables and still the same issue

Try a clean install of the nightly please.

Sure will download the latest one now and let you know.

@adamg I am running the latest nightly now for my N2 and here is the info - http://ix.io/1QoH

So any idea what’s causing this?

I can’t help but I get the same error message sometimes. I haven’t counted the exact number of times but it appears to happen about 1 in 3 reboots/power on. I can’t find a pattern as to what is causing it.
I did post a debug log in a previous thread a few days ago when it happened.

Log is here:-
http://ix.io/1Pge

I’ll point out that I’m using a custom Amlogic-ng build which is the same as “coreelec-9.2” branch but with one kodi patch inserted into the build - that patch is mentioned here in a PR I submitted to Kodi a few weeks back. This patch removes one line of code from VideoPlayer.cpp. Link here:- https://github.com/xbmc/xbmc/issues/16390

This patch should have no impact on the CEC initialization error.

To make matters worse this works 100% on my C2 and fails on my N2.

@ukmark62 need dmesg log not Kodi log, this is a kernel related issue.

Here’s the dmesg log when the pulse eight adapter fails to initialise, hope it helps:-
http://ix.io/1QD2

Here’s the dmesg log when the pulse eight adapter initialises correctly.
http://ix.io/1QD5

My situation is that this happens about 1 in 3 times when powering on.

@adamg Is there a new nightly that we can try to see if this is fixed at all please.

@adamg so any word what the problem is or a possible fix?