Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

The problem is, the install option 1-4 are no longer offered now. Ceemmc detects CE already being installed to emmc and only offerers overwrite or backup options. I used 3 on my attempt (like I always do) because I don‘t care about Android and always use 3 to have it just as a CE box.

I will try again but I think the emmc of the box is kind of stuck now. I can‘t even install non-ng now. Installtointernal complains about something missing. My guess there were changes make to the bootloader.

I used gxl_p212_2g from the ng build. Also tried the slowemmc version. The Mecool M8s Pro+ will complete ceemmc -x without any kind of error message but won’t boot from it.

No big deal for me as I only reactivated the box because I was curious about the ng build for it.

Anyway, it boots works fine from sd card. So no big deal.

Rebooting from ce menu won‘t help either btw… I had a box in the past where that helped but unfortunately not so much here.

I think it is amazing that there even is a ng build for those old boxes.

A95X S905X (2+8G) installed successfully, no problems.
X96 S905X (1+16G) originally stuck at Coreelec logo. Following upgrade to Android 7 firmware (I used A95X firmware), Coreelec booted normally, no problems.


Everything work fine on my Khades VIM1 (SD and emmc) and on LePotato (SD card) but not on Mini M8S II box (S905X 2+16Gb).

I can boot Mini M8S II from SD (and USB) using new NG build and everything work fine but ceemmc -x fail to install on emmc.

Previous post from @intelmorino make me think about cross-flashing the box and … eventually today I burn the A95X firmware on my Mini M8S II then ceemmc -x succeeded to install to emmc and the NG build boot normally from emmc.
Everything work fine now on my Mini M8S II (after the cross-flash and CE install on emmc).

Working fine on an MXQ pro+ 4k (s905x). I use it with ceemmc without problem.

I’ve been using the latest ng build on my X96 Mini for a couple months now.
All was well until earlier this week when I encountered 2 separate media files that would not play smoothly, in differing ways.
One of the media files was a 1080i film, it was unwatchable, 80% of the frames were getting dropped. I tried another 1080i film and the problem was the same… so there appears to be an issue with 1080i media for some reason.

The other problematic file was not as severe. stuttering audio and occasionally dropping a bunch of frames every 10 seconds.
The codecs were nothing unusual though, blu-ray quality 1080p avc and stereo pcm s16le audio, the same format as 90% of my media files but for some reason this particular file had issues.

I’ll try the latest non-ng build to see if these issues present themselves.


1080p VC1 content does not play correctly either. Loads of skipped frames, but they’re not counted by Kodi’s debug overlay.

More details in this thread: No Disable Deinterlacing option on ng builds?

TX95, while NG loads & seems operational, no playback is possible for mp4 with 6 channel AAC

In NG you should use HDMI Milti Ch PCM in audio settings

Absolutely what I am using since ever. I mean it does not play, it means does not play (not just no sound, it hangs on video playback after 5 seconds)

The mecool K1 Pro is reported as working, but does the dvb tuner work with kernel 4.9?

Yes it does.
DVB-T Free to air tested on my device.

1 Like

Thank you. I just use it with dvb-s, does that work too?
Edit and what about oscam+pcsc?

Tanix TX5Pro often crashes when playing torrents online no matter what torrent engine is used.

No commits on github as of July.
Is project still maintained?

GXL devices are already in NG builds. You could use stable or nightly.

1 Like

The NG build GXL support has been in the main repo for a while now.

1 Like

Once again recorded microsd night version of ng, does not load beyond the splash screen, x96 s905x 1Gb - gxl_p 212_1g. dtb.

One more question: I’m currently running libreelec from an usb stick. If I try this version (on a different usb stick), can I go back to the old one? (I’m asking because of the different aml_autoscript).

Yes you can, just use the toothpick method to get the usb with LE back booting.

1 Like

Ok, today I finally tried the ng version. What I did

  1. Cloned the usb stick with the working libreelec (9.0.something, the last one supporting the mecool k1 pro).
  2. Booted it to confirm the clone worked and upgraded to coreelec (“normal” version) by putting the tar file in the .upgrade folder and then changing the label of the boot partition (from LIBREELEC to COREELEC).
  3. Upgraded the plugins and installed the missing one (oscam) taking it from libreelec (I need it to read a legit card with an usb reader, AFAIK tvheadend doesn’t do it by itself). I also found that coreelec uninstalled webgrab+ (why, oh, why?) but I least I could install it again from the thoradia repo.
  4. Used it for a couple of days then upgraded to the ng version with the tar file and the .nocompat flag. It rebooted fine, no toothpick needed :sweat_smile:
  5. The dvb wasn’t working, I had to select the media_build drivers and then it worked.

@olivluca glad that worked for you. The CoreELEC NG build should be the best currently available build for the mecool k1 pro.