Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

Spot on! ~53°C


3 posts were split to a new topic: Nexbox A95X B7N Failed update to NG Nightly


Backed up my previous setup… installed CoreELEC-Amlogic-ng.arm-9.2-nightly_20200718-Generic. Restored backup, booting from USB

The following work
2.4G & 5G wireless
Bluetooth mouse and key board
TVheadend using Xbox USB TV adapter
Streaming movies/tv series via a disk connected to my router
Updates to new nightly

I notice that remote.conf auto repeat key does not work (it did not work that well before)
Changing the following, it now works
#repeat_delay = 250 # Changed from 40 to 250
#repeat_peroid = 230 # Changed from 39 to 170
#release_delay = 60 # changed from 121 to 60

Standby/power on LED stopped working from nightly - CoreELEC-Amlogic-ng.arm-9.2-nightly_20200723-Generic.img.gz

When you press power on key, initial goes from red to blue (approx. 6 seconds) then back red
(Normally the led is blue when the box is running)

Its worked okay on


Thank you for the builds they seem to work great apart from one minor issue

Another attempt result is bootloop.
CoreELEC-Amlogic-ng.arm-9.2-nightly_20200731-Generic - kernel panic.
CoreELEC-Amlogic-ng.arm- - bootloop.
CoreELEC-Amlogic-ng.arm- - bootloop.

Successfully installed on a Mini M8S II (S905X, 2 Gb / 8 Gb). IR wakeup works fine, using Android’s remote.conf, and ceemmc also. Thanks to the devs :slight_smile:

Work amlogic-ng well on HK1 ( 905w 1G/16G) gxl281_1g (also flashed to Tanix t3mini)
installed to emmc ( use ceemmc tool)
inject_bl301 works ok with remote - on/off
wifi OK
lan (100Mb) OK

1 Like

Hello, I have a khadas vim 1 and had coreelec with the old kernel installed to emmc.
A installation of Ng build on SD card worked fine… I had only to change the remote.conf…

But I am unable to use cemmc tool. It copy everything but is not able to boot. The screen stays forever on Khadas

Did I miss something (I thought that if it runs from SD, it should also from internal storage)

Hi @Portisch I understand the need for logs, but the OS is not booting and therefore there are no logs.
Booting from SD card is fine, everything works.

Move to emmc via tool gives no errors.
Powering down the khadas box and removing the SD card.
Then try to power on. System stops on bootloader screen of khadas. I never see the coreelec logo nor is there access to kodi, SSH oder smb.
Unfortunately I don’t have a serial connection yet.

Use UART or SDIO board: CoreELEC Team SDIO Debug Board
Again, if no log is provided no help can be provided.
Then as GXL is still experimental please do not request support without the needed logs.

I own a vim1 and tested different firmware versions and had never any issue with ceemmc nor inject_bl301. And especial vims are really easy to make UART logs as no adapter is needed as well.

1 Like

Hi @Portisch I finally managed to get logs from my Khadas not booting from emmc and logs from the process with the SD card.khadas_emmc.txt (11.9 KB) khadas_sd.txt (217.2 KB)

Does this help?

Do you use VIM1_Pie_V200317? I have seen the same error on my VIM1 with this firmware:

00000000:"Synchronous Abort" handler, esr 0x96000210

Please try again with VIM1_Pie_V190823!

W95 (S905W) Box
I mainly us my box as a Tvheadend client on a bedroom TV. I was having problems playing 1080i streams. The box would lock up, do video loops, etc. after an hour or so of playing 1080i streams.
I upgraded to the -ng version and it seems to have resolved my problem (time will tell).
It played 1080i streams for several hours yesterday and several hours this morning without problems.

Edit: I found a couple of small bugs that may or may not be related to the -ng build.

When trying to change the number of days of guide data to load in PVR settings the device will freeze. If I slowly change a few days at a time and then back out of the menu, re-enter the menu, and slowly change a few more days, and repeat until I have the desired number of days, the device won’t freeze. This may be related to trying to get the data from the Tvheadend server in real time. I don’t know if this worked correctly with the non -ng build.

The device immediately re-awakens when I use the Suspend mode. But power off/on works fine with the remote. Suspend worked as expected with the non -ng build.

Mecool M8S Pro+:

Boots from sd card
No wifi/bt (non-ng build didn‘t have it either)
Works good on playback, immediately saw some issues resolved from the old build

But won‘t boot from mmc after ceemmc -x without sd card. Never gets past box logo.

No big issue for me, it is actually my third box and was unused for quite some time. Should be good with a nice fast sd card, the emmc of this box is hellish bad anyway

FYI - For my NEXBOX A95X-B7N box, suspend never worked in previous non -ng build and did the same as yours
Adding inject_bl301 & updating config for the power key - it works great on ng builds

Perhaps I don’t understand how to use inject_bl301 but I don’t have that option in my menu.
But I probably wouldn’t use Suspend anyway. I use a HDMI switch and my box didn’t like devices being switched behind it’s back. It would awake to a black screen if things were different. I was just going to check if things were better with the -ng version.

I have been testing the -ng version extensively on a NexBox A95-B7N and besides the suspend option from the power menu rebooting the device (which can be fixed by injecting the bl301 blob), the unit works just fine and even can be installed on eMMC and dual boot with Android…

Hope that helps.

Could someone point me to how I get to the point that inject_bl301 is available in my Settings>CoreELEC>Hardware menu?

Never mind, I think I found it.

We have a guide: