Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

Hi all, I’m happy to report successful installs of CoreELEC 19.1-Matrix_rc2 over legacy CoreELEC 9.2.7 on my two S905X boxes with 1/8 GB, an X96 and a Trongle X4. I first flashed Aidan’s Android TV rom v7.5 to upgrade the bootloaders.

They’re running great, noticeably smoother than before. The USB ports work fine on both.

Thank you for your work guys, it is very much appreciated.

I’m having problems with some HEVC encodes.

The symptoms are always the same: no sound, then stuttering of the video, then freezing of the video - all happens after only a few seconds from the start.

The bug is present in 9.27 and the 19.x builds.

Log here: http://ix.io/3sH8

A sample would go a long way

Apologies.

Here are three short samples that trigger the bug zipped together

https://mega.nz/file/QckxjIRC#m1-zolwwS6DbeaAgeXtB6tgewOougWv6RdGy6oMA1CM

Hmm…, all 3 samples play on my Mecool KM8-S905X (CE ng.9.2.7_Linux v.4.9.113) flawlessly without any problems…

Thanks for testing them. Good to know that it seems solvable. I wonder what the difference is for me?

I’m using a Bqeel 2GB M9C MAX upgraded with Aidan’s ROM [S905X] [v7.5] (UNIVERSAL)

What ROM did you use to install the later Android version?

My KM8 runs on original Rom the box came with; it’s Android 7.1 version and I never upgraded it to newer versions because they had all locked Bootloader.

Ah, okay. Thank you.

Ok. Here’s an update to my problem:

It seems to be related to the audio channels. 2.0 works fine, 4.0 seems to work, but all the other options either have no sound, or cause the stuttering and crash. I was using the 5.0 setting before.

Select HDMI Multi-Channel audio device and set channels to 7.1 - That is useful for non-passthrough.
And obviously, enable the Passthrough toggle at the bottom of the audio menu (make sure you’re in Expert mode first)

Thanks for the suggestion, but I’ve tried both of those things including most other combinations in the audio settings!

The number of channels you set in Kodi doesn’t affect passthrough in any way.

I normally use passthrough because my amplifier is capable of decoding most formats.

Remember, not every video is affected with the glitch on my setup, some play fine whatever audio channels are used.

It seems to be an issue with certain encodes. In the image below, the three files on the left I have issues with when audio channels are set to anything other than 2.0, those on the right work fine whatever number of channels are selected.

The only pattern I can see is that multichannel AAC is causing the problem. What other files should I test to narrow it down?

Yes, you can’t passthrough AAC. That will play in LPCM mode.
You need to select the Multichannel HDMI audio device and set channels to 7.1 to have a chance of it working.

Yep, tried that, doesn’t work.

Audio output device ALSA: AML-MESONAUDIO, HDMI
Number of channels 7.1

Things were fine in the previous kernel.

That’s not the correct audio device.
You are not even using Amlogic-ng build…

I put on 20.0 today to see if that solved the problem, it hasn’t.

Now select the Multichannel HDMI device and set channels to 7.1

Still the same problem, but I haven’t changed anything since you suggested that before

Does the MESONAUDIO audio device mean that I’m not on the 4.9 kernel? Is that why you thought I was not on ng?

I’m installed to internel, but the Android 7.1 version I flashed (HQYG-TX7-nikodi-20180104) still has the 3.14 kernel. Does a dual boot install to internal use any resources from the Android partition that might cause a conflict?

Sorry, MESONAUDIO exists on GXL devices, and AUGEAUDIO is on newer chips.
I think that you probably don’t even have the Multichannel HDMI option, as it’s only available on newer devices.
That said, I’m not sure whether there’s a solution for this issue for GXL.

You may want to try enable passthrough and AC3 transcoding, set channel count to 2.0 and you will have a new setting in the passthrough options. Maybe that will provide an acceptable workaround.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice