Dolby Vision for Minix U22X-J (Max) and Ugoos AM6+

Recently got AM6 plus (thats what the box says and serial number begins with AM6plus…). Though the latest androind firmware says just “am6”.
Literally followed the guide with copying dovi.ko to the storage root folder of the latest ng nighty.
But i dont get DV! No options in system-coreelec menu and dv video shows purple.
What am i doing wrong?

That’s an OSD problem, try rebooting the box and then playing it again.

What does Kodi show as HDR Capabilities under System Information → Video?

Also, did you set the HDMI port on your TV or receiver that the box is connected to to the correct settings? Usually something like “Ultra” or “Enhanced” or something similar.

Kodi shows only hdr, hdr10. No DV
Hdmi port on samsung “the frame” tv is “enhanced”. No problems with hdr content.
Dovi.ko is at the right place.
My main doubt is that my am6 isnt really “plus” version. How could i ensure the exact model? Android says just “am6”




None of the samsung TVs support DV

2 Likes

@patkino if you are feeling adventurous and have some basic tech level skills you can try out the LLDV build I have created for non-DV displays on the below thread.

note: would need some Dolby VSVDB settings aligned with your display to get the most out of it.

Thanks for clarification
How can i make coreelec decode DV to HDR?

Your answer is just post above yours… :roll_eyes:

Already did. It keeps coming.

I tried the 2160p remux DV+HDR version of this movie and I don’t see any issues with the OSD.

I tried with the default Estuary skin and the Arctic Zephyr 2: Resurrection skin.

Which skin are you using?

Can you post a picture maybe?

The OSD is black for all DV videos, not just a couple?

The black OSD problem was present when using the dovi.ko from the 2nd gen Cube. Where did you download your dovi.ko from? If you aren’t sure, download and replace it with the one from here.

And what CE version number are you on (stable, nightly, special build)?

I’m using the standard skin. The picture:

Is this just applicable for P5 DV?

Has anyone noticed problems with DT-DL bdmv UHD, problems start when rewinding or after switching to a new chapter, after that there is lipsync issue and video slows down after that, until you restart the file again, it goes jerkily, also sometimes some releases start just with black screen. At the same time, if DV is disabled in the menu, the same videos are played normally in HDR, mkv ST-DL without problems, the problem is only with m2ts with DV.
We are still collecting statistics, but already two users from my chat have written to me and found problems on these videos “The Wolf of Wall Street”, “Nobody”, “Boss Level”.

Hi mate did this get added to the nightly?

I have 2 or 5 times per movie a very short sound loss / interruption of the thd atmos track. 50-70gig remux dv movies. captain America winter and Civil War both.

maybe cache? I’ve tried several settings, currently running adaptive, 512. it’s often 5 to 10m after play / resume. it’s not in the files.

There is no problem if you disable DV support and play only HDR layer. So buffer does not affect here, and already checked, it’s not because of that.
Who has these movies in m2ts, check if there is a problem

it happens on different positions so it cannot be the file?

i def cannot turn off dv support. cannot risk it. im so happy that besides that little thing everything is running so perfectly.
picture is absolutely great. no lipsync issue for me. no framerate drops. I will not change anything here :slight_smile: I know me, after a change nothing will work…

I remember facing stutters with No time to Die.I remember the file being a m2ts file.

Can confirm that my BDMV copy of The Wolf of Wall Street is acting up.

With caching enabled, video playback is not smooth at all, but goes in “jumps”.

With caching disabled, video playback starts smooth, but skipping to a next chapter makes the audio go out of sync and also shows hickups in the video. Jumping back a chapter or jumping back like 10 or 30 seconds does not fix the issue.

EDIT: Switching DV from Lossless to Profile 8.1 conversion seems to fix it, but then the PGS subtitles start to sort of flicker? Turning off DV completely and switching to HDR fixes both the video issue and the subtitle flickering.