Dolby Vision for Minix U22X-J (Max) and Ugoos AM6+

I had video stuttering problems at first and the fix for me was fiddling with the buffer/cache and chunk size settings. I forget what exactly I use but I remember raising the chunk size for sure. Several people have reported a similar issue/resolution in this thread so search for those keywords and have a read.

1 Like

I see there is a new firmware for the minix not sure what it would bring to coreelec ?

Also thinking of getting a 2nd one do you think it’s worth it for a backup as it seems no other devices are getting the support. Even the new chipset that’s just been released ? Thanks

Thank you for answering me. Unfortunately, however, I had already changed those settings (cache menu) and I was unable to resolve the issue. The only way is cable. I still don’t understand why, as soon as I start a film, the transmission speed of the device drops and therefore the film stutters…

I’ll see if I can figure out why later.

Another question…
I have the latest nightly… Can I play Bluray folder (BDMV) or Bluray .iso file? I tried with the folder but it only plays some files (the warnings) and that’s it, as if it doesn’t find the main file. I haven’t tried the iso file yet.

Would check your antennas are screwed in. I’ve read several posts here where the user didn’t bother with those and saw horrible BT/wifi performance.

1 Like

anyone? please.

The update shouldn’t bring problems to CE unless you used ceemmc. If so, you need to run the tool, backup, update android and run ceemmc again. If you don’t care abou android, don’t update.
For the second part, we don’t know what we’ll have in the future, S928X is stalled.

Thanks. For getting back to me. Might buy another one just in case the one I have goes faulty.

Absolutely, I made this mistake earlier, so screw these antennas ! (pun intendend) and your remote will perfectly work

Also, if your receiver is an Android TV, make sure that no bluetooth audio stuff (speaker or headphone) is paired (yes, even only paired) → on my projector this mistake induced lags on several things : TV remote lagging and foremost: audio sync lagging (randomly), so please verify this and you can even do a full androidTV factory reset to make sure.

Does anyone else have a white banding issue with saving private ryan @ 2h35m?

using 6/13 nightly


I’m running CoreElect 21-Omega Nightly (Amlogic-ng Generic) 20240613, and then it updated to 20240616. The device is Ugoos AM6B+. The system runs on a micro SD card.

The major issue is at opening a media (usually BDMV folder, or Blu-Ray ISO, usually with custom subtitles included), it randomly crashes. Not very often, but not hard to reproduce. Last night the system crashed for three times in a row.

After crash, HDMI signal is off, TV displays “no signal” screen. Then if I press the red power button on the remote, the TV screen receives a black screen signal for a while, and then it goes to “no signal” again. In this state, the device power LED is also off. Pressing the red power button on remote again, the system will do a cold boot.

The logs:



kodi-logs-20240614.tar.gz (51.9 KB)

I found more log files at: /storage/.kodi/temp, hope they can help.

Hello everyone. New to the forum. I just finished setting up CoreELEC on the AM6b+ last night. Watched an mkv 4k Dolby Vision movie and everything was fine so far. Did an AB testing versus the Sony X700 bluray player (my previous media device) and the picture quality seemed similar. I’m ready to sell the X700 if the Ugoos proves to be a better device. A few questions:

-How do I get the movie poster/description to show up? Most of my movies are currently in bluray folder format and I plan to convert them all to mkv.

-How do I play the movie in bluray folder format instead of mkv? If I click on the folder then it will just go to the subfolders.

-I’m using CoreELEC 21.0 (the most recent stable build). Should I update to the latest nightly as recommended in the guide or should I stick with 21.0 to avoid bugs?

-The remote that comes with the Ugoos is pretty bare-bones. Luckily the tv remote works so I’m using that. However, there’s no STOP button, only Play/Pause. Any workaround?

-I see this in the recommended setting post:


** Buffer mode - cache settings to all methods: smb, local, remote, etc (default ignores local playback)*
** Read factor - Set 'Adaptive’ readfactor (default is 4x). This is a multiplier for the bandwidth allocation based on video bitrate. Eg if video bitrate is 50Mbps and multiplier is set to 4x, then Kodi allocates 200Mbps of bandwidth to fill the cache faster. Adaptive is recommended*
** Memory size - Set 64mb cache size (default is only 20mb). If unchanged from 20Mb, I found it gives the ‘low-speed connection’ warning when playing high-bitrate 4K. Set a bit higher to prevent warning. Potentially this could be as high as 25% of RAM, but generally doesn’t need to even on high-bitrate 4K*

Is this necessary to follow if I play my films on an external hdd connected to the Ugoos?

Hi, I can give you some advice thanks to my experience gained so far.

To use the BDMV and/or ISO folder, in the Coreelec installation instructions post on Ugoos, there is a FAQ section where it is explained that you have to install a Java add-on (very easy procedure) and in the Player–>Discs menu → Show blu ray menu. However, I noticed that it doesn’t always work as it should so instead of “Show bluray menu” I set “Show simplified menu”. It’s up to you to try. Go to the BDMV (or ISO) folder and hold down the “enter” button to show the context menu and click on the “Play” item

For the remote control: search for “keymap Editor” addon which allows you to pair a command to a remote control button. Very helpful.

For posters: I have an Emby server installed on my PC and I let it do all the work of identifying the films. Then from Kodi I use one of the Emby addons to interface with the server. You can also do this using Plex.

For other questions I would let someone more experienced answer.


1 Like

thanks for the help. May I ask what version of CoreELEC you are using? Is it stable or nightly? Any bugs?
I’m using the 21.0 stable build (flashed on a usb plugged in the Ugoos) and trying to update to the latest nightly build, but can’t figure out how to. Do I need to reformat the usb with the nightly build and go through all the installation steps again?

I recommend to check our Wiki
Settings should be kept, but it’s always recommended to have a Backup, esp. with Nightly

I went to that CoreELEC Configuration update section, but there are no nightly builds under Available Versions, only stable builds.

To switch from stable to nightly channel, you need to do the described manual update once.
Same procedure to switch back from nightly to stable.

Yes I was doing manual update. I followed the steps:

-navigate to the Updates section of the CoreELEC Configuration Addon
-select Update Channel (CoreELEC major version)
-select Available Versions

Under Available Versions there are no nightly buiilds, only stable builds.

Download and drop in .update over smb or use ssh to download directly to box.

1 Like

more Specifically,

ssh into box:

cd .update

then type


then type


1 Like