Dolby Vision for Minix U22X-J (Max) and Ugoos AM6+

TV-Led mode is fake on Amlogic, don’t use it.

Thanks, im now using player led (lldv) as there is no banding and image looks much better with it.

Thanks, good to know how to safely backup my partitions before moving forward.
But I am more interested whether there is a procedure how to convert/upgrade existing CE installation from ARM to DV.ARM.
Not sure if some changes needed in devicetree/kernel can be done manually before .tar upload.
Would like my CE installation to remain on the fast eMMC.
Latest dualboot firmware from Ugoos is very old so continue upgrading CE seems to be the only way…


As Android base you are still using old firmware from 2021/2022???
Ugoos/CoreELEC dualboot

Is there not other firmware you can test on this cpu?

Slimboxtv maybe.???

Do you not have to remove CoreELEC from internal to flash Firmware upgrade/change in firmware

There are other options for Android base.

Yes I’m at original Ugoos DualBoot f/w where after installation the Android and CE have independent partitions and OTG upgrades.
When booted CE I can upgrade it online within the same architecture without removing anything.

1 Like

That is excellent
And Dolby Vision in Ugoos Android is working?

Then go for it in CoreELEC!!!
Place Tar file in update folder
See if success

You will get an error if not compatible

Reads like you have skill to recover if something goes wrong!!!

Happy Testing

1 Like

I have tried to upgrade via copying the DV.ARM .tar file to CE /update folder.
After CE restart the update has started as usual but finished with error message that the current system is incompatible with the provided .tar file.

1 Like

If not compatible
System will abort install/ update

Have placed wrong tar file in update folder
More than once

Cant really break anything

So you must test latest nightly ng dolby vision
CoreELEC version.

Clean install

Next build will fix this. Make sure that you set DoVi conversion to Lossless in Player → Videos options.

1 Like

OK, decided to test DV on my AM6B+ again with 20.3 version.
First online update to “normal ng” 20.3 - OK.
Then based on error message I have uploaded empty “.nocompat” file with the new “CoreELEC-Amlogic-ng-dv.arm-20.3-Nexus.tar” file to /storage/update folder and restart.
Update went OK as usual, CE loaded fine.
Only issue was that my Sony TV input has changed to another active source (VU+ receiver) so I had to turn off the receiver to get back to CE.

CE is reporting the AML-NG-DV.arm architecture + all plugins are working, good.
Compared the boot files (kernel,system,dtb) size/dates via putty with .tar files and all is the same.
Checked DV related settings - needed to activate “Player-Led” because my Sony TV doesn’t support TV-Led (LL-only model).

Then started to play LG DV videos - DV logo on the TV activated but colors are garbled (green-violet tint).
Changes of "/Player/Videos/“Convert DV…” to any available option haven’t helped to fix the DV color problem.
The same videos play with correct colors when played via Android/Kodinerds version (but choppy). Ugoos is on the latest firmware and with DV-LL Enabled(YUV) + Adaptive HDR mode. TV ColorSpace/HDR mode on Auto.

Anyone else out there with Player-Led TV having color problem with DV videos?
Any CE options to check/change?

i tyied 20.3 ng-dv in my am6b+ tonight,some movies playing smoothly but some can’t play,black screen and purpel or green, a big step anyhow,great work!

It appears that we missed something, I noticed the same last night.
We’ll investigate.

1 Like

Make sure that a. you set dovi conversion to Lossless and b. grab the new build from today.

1:I set lossless already
2:is the GitHub pre-release 20.3 ng-dv?

Yes, it should be the most up-to-date build.
Make sure that you disable the player-led option if you have it enabled. It seems to be broken right now in ng-dv :frowning:

yes,i used tv-led mode, dv lossless

Tested this last build in Ugoos Am6b plus. Dolby Vision set at Lossless and player led disabled.
Played profile 7 MKV and TS movies ST-DL.
Some files play perfectly and some do not start to play on start and then have a red screen or studder or stop and go.
By the way a much improved version compared to the first Nexus 20.3 ng dv of some some months ago.
Thanks men.

Thanks for the info, good to know the problem is not on my side.
I’m sure you guys will eventually find a solution how to make Player-Led DV working again. :pray: :crossed_fingers:

Congratulations Dev Team. You have succeded in allowing Ugoos AM6B plus to play DV P7 ST-DL.
I have no words to thank you, I did a clean install with the new build Nexus ng dv 20,3. Excellent. Thank you.

Just to be clear - CoreELEC plays DV HDR profile 7 FEL or does profile 7 still get converted to 8.1?