Gui at 3840 x 2160

<resolution> section
5 messages above:

thank you…

There is another way do it do a Hard Reset for coreelec from the coreelec settings but be warned it puts passthrough audio back to SPDIF and I’m guessing most have hdmi in fact there aint spdif on the N2 is there? Nah :slight_smile:

Doing a hard reset is pretty much equivalent to doing a clean install, this should only be a “last resort”.

Yes agree TheCoolest but if you don’t feel comfortable with command line its the only way but you will LOOSE ALL apps and library data the LOT so start from scratch scenario.

I am running GUI at 1080 as per you’re teams recommendation but as I posted previously my amp is scaling.

Anyways thanks for everyone’s input it is appreciated

Thanks and Regards

That worked thanks!

Although I will probably keep it disable as my Samsung Q9FN has excellent scaling as will my Vertex 2 when I get around to slipping it into the chain.

1 Like

Worked for me too under 9.2.1! Thank you @boot2k3. I have no <resolutions> section at all now and everything is working just fine with GUI @ 3840 x 2160. Woohoo.

1 Like

for me, too. GUI resolution @3840x2160 gives a much more precise image quality (not pixeled) for movie thumbnails (with Confluence, other skins I didn’t try) in the Files-section than with GUI @1920X1080

I used a Beelink GT King but since CoreElec stable V9.2.1 I can’t solve the problem about 4K Video.
“don’t scale GUI option” set or not set is the same.
Disable GUI scaling off = zoomed 4K video
Disable GUI scaling on = Minimised 4K video
What is the good setting for a GT King ?

I reset video parameters in system/video menu
I changed “scalingmethod>1</scalingmethod” by “scalingmethod>0</scalingmethod” but nothing solved and after reboot it comes back to 1

I should like you explain clearly (for no anglophone people) step after step what I have to do to solve that because since more than a day, I read everything about that in the forum but i d’nt find the solution.

In a french gt-King forum we are many to have same problem and I should like to explain to them how to do.


You should delete <resolutions> sections and your scaling changes too

I don’t understand how to stop kodi without stopping CoreElec ?
And if I stop CoreElec, I am not able to go guisettings.xml to modify it

You need to execute commands via ssh client, for example putty.
After first command it just stops kodi and will be available via ssh and samba
How to connect you can find in pdf document from this post


You can find a file here(where IP is IP of your box): \IP\Userdata\guisettings.xml

OK thanks, I know putty.
I am going to try that.
What Gui setting for GT King ?
Disable GUI Scaling : Off or On ?
Must I set this option first to go to putty or it doesn’t matter ?
In my system video resolution, can I stay to 1080 or must I set to 4K ?

What Gui setting for GT King ?

The settings are the same for all boxes

Disable GUI Scaling : Off or On ?

set it off (as it was by default). Or you can read an description of this function to decide what you need

Must I set this option first to go to putty or it doesn’t matter ?

I don’t understand that you mean, but change options in GUI before you execute 1st command(to stop kodi)

In my system video resolution, can I stay to 1080 or must I set to 4K ?

As you wish

Thanks a lot, video 4K problem solved !
I am going to make a tuto on french forum.

1 Like

That worked for me too. Thanks so much.

ssh to the Odroid, and remove “resolution” lines in the guitsettings.xml file did the trick for me as well.

ssh root@<Odroid IP Address>
systemctl stop kodi
vi ~/.kodi/userdata/guisettings.xml
systemctl start kodi
exit

*Tip use /resolution to find where it is being called once you VI in to the file.

I had some weird playback issues after this, I believe it wasn’t using variable refresh rate. I tried to start Kodi, but later ended up rebooting the entire box.

Thanks!

GT-King, last nightly. I have resetted all resolution settings.
Nothing in whitelist, no screen calibrated.
My GUI settings 1920*1080p 60 Hz
Coreelec settings all unticked.
When I play HD content all good. When I play 4K content all good, but when I play more one 4K content after 4K content, the movie just seen on 1/4 screen.
Than I play SD, or HD content, than next playing 4K content all good again.
Seems like after 4K content kodi not reset the resolutions properly.
Playing all content to proper resolution, just when I set to GUI at 4K.

See post above.

Confirm this issue.
No resolution lines in guisettings.xml
GUI settings 1920/1080 60Hz