Gui at 3840 x 2160

I have deleted. There is no resolution lines in guisettings xml.

@Tim_Taylor, @frodo19
Please upload link on your logs

I forgot one more command. Please also upload links on your guisettings.xml file
cat /storage/.kodi/userdata/guisettings.xml | paste


Have you see any issues, in my settings?

No, neither your nor Tim…
Could you try different sd/usb card to make clean install and check if it some kodi settings issue or not. We couldn’t repeat the sequence.

On current system you could try to select “Disable GUI scaling” reboot and check if it solves this issue or not… but it could cause some osd glitching on some 4k video

Disable gui scalling cannot helped, I’v tried. Only one thing help, when I set gui resolution to 4K, but I not want that. I will try another usb fresh install CE, and well see what happen. Thanks anyway.

My workaround:
I set GUI resolution to 3840X2160

Hi, I have clean installed for another sd card, and then another usb3 pen. Issue still remain.
Workaround just when I set to gui resoluition to 3840*2160p 60Hz. :disappointed_relieved:

Is there any way to fix the 4k issue w/o wiping my guisettings? My current skin is quite customized and it took hours to set up. Gui reset says I’d lose all of that.

Will a backup and restore be ok?

You need to remove just resolution part of settings:

See the following post. it has simple instructions on how to fix your problem without having to delete your whole guisettings.xml file.

Hello, where is the option to not scale Gui

On the Amlogic-ng builds, yes.
But it’s only supported on S905X2/3 and S922X, not supported on S905X/D/W.

Yes, I have a s905x3, and it tells me that sometimes when I start the movie it is seen in 1/4 of the screen, I solve it by giving back several times, until it goes to full screen but I was able to know why it is due

You need to reset your display calibration settings, it’s in advancedsettings.xml.
Do a search, it’s been discussed multiple times.

I can refresh topic, because I am getting similar problem. I did calibrarion and now it’s full screen. However, many things are now messed up. If I try to play 4k movie I am getting mess on screen. With gui scaling enabled all is fine.

That’s strange why gui rendering in native resolution affects movie playback. For now I am forced to enable gui scaling again. My hardware is s905y2, ng version stable