H96 Max S905X2 working Coreelec

Another noobie here…
Installed CE and it works fine, but…
Can’t install any addon/skin, all it does - failing…
Been 10 times thru all settings can’t find a setting what will cure this stupid error…

Please who is waking me up with the right answer…

Greetings from a sunny but cold Holland


As I cant either.
Not bothering me though.
Post up on the more general area of this site maybe>


Guys, what about swapped blu/red led? Any progress (nightly builds or script)?

Not really. It’s probably a DTB issue, and we currently only have generic DTBs for the S905X2 boxes.

Please help. You write that NG builds doesn´t support installtointernal command in H96 max x2. but I have installed 9.2.0 stable from CE download page. If I run this command it returns:
-sh: installtointernal: not found
I have CoreELEC (official): 9.2.0 (Amlogic-ng.arm) on SD card now. Any idea?

You need to use latest nightly and read ceemmc guide:

Hi, I know the function is not officially supported. But when I try to make a single boot mode. Give this error and do not install it in emmc. Even if you continue corrupting the Android emmc but do not install it.

The error is “Could not find” dtbo “partition”, then I leave some screenshots:

Before installing.

When the installation begins.

P.D: The dual boot mode works without problems.

dtbo partition is part of the system on VIM3(L) so it search for.
Use dual-boot now until it get fixed.

Please boot your device enter SSH console and enter: dmesg | grep mmcblk and paste the output.
Or start the the tool like ceemmc -v and post the output.

@SamWilson, try latest(today) nightly and check if single boot works now.
Also please upload info requested by Portsch

OK, what now? (H96 max x2)

CoreELEC (official): 9.2.0 (Amlogic-ng.arm)
CoreELEC:~ # ceemmc
-sh: ceemmc: not found
CoreELEC:~ # ceemmc -h
-sh: ceemmc: not found
CoreELEC:~ # ceemmc -x
-sh: ceemmc: not found
CoreELEC:~ #

Should I also use latest nightly NG or non ng?

Please could anyone gives correct and straight answer? I have H96 MAX X2. You wrote that NG build does not has installtointernal nor ceemmc. But I can´t use non NG build for this device (there is no DB for this device in non NG build). So it means I just have no possibility to install CE internally on this device? Thank you for explaining.

Answer is the same as in my previous message:

9.2.0 is not nightly

Thank you. https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20191113-Generic.img.gz is the right version for H96 MAX X2 ?

Should be :slight_smile:

GREAT works on H96 MAX X2 without any problems using ceemmc -x command.
Yet another question. There is remote config file in the start of this thread. Where should I put files in it please?

This works:
Many of you will be most familiar with this method, amremote typically gives a much better user experience with the bundled remotes with generic devices.

To use an amremote configuration simply copy your remote.conf file to either the root folder of your SD card / USB flash drive or to /storage/.config/remote.conf .

NOTE: after the first time you boot your device with an amremote configuration it will automatically reboot whilst modifications are made to your dtb to enable amremote.

You can change back to meson-ir at any time by simply removing the remote.conf file and rebooting.

Please run this on a SSH connection of your device and post the output:

CoreELEC:~ # dmesg | grep mmcblk
[ 4.018878@3] mmcblk0: emmc:0001 CKTM4R 58.2 GiB
[ 4.018993@3] mmcblk0boot0: emmc:0001 CKTM4R partition 1 4.00 MiB
[ 4.019115@3] mmcblk0boot1: emmc:0001 CKTM4R partition 2 4.00 MiB
[ 4.019237@3] mmcblk0rpmb: emmc:0001 CKTM4R partition 3 4.00 MiB
[ 4.020937@3] meson-mmc: [mmcblk0p01] bootloader offset 0x000000000000, size 0x000000400000
[ 4.021028@3] meson-mmc: [mmcblk0p02] reserved offset 0x000002400000, size 0x000004000000
[ 4.021041@3] meson-mmc: [mmcblk0p03] cache offset 0x000006c00000, size 0x000046000000
[ 4.021134@3] meson-mmc: [mmcblk0p04] env offset 0x00004d400000, size 0x000000800000
[ 4.021146@3] meson-mmc: [mmcblk0p05] logo offset 0x00004e400000, size 0x000000800000
[ 4.021156@3] meson-mmc: [mmcblk0p06] recovery offset 0x00004f400000, size 0x000001800000
[ 4.021166@3] meson-mmc: [mmcblk0p07] misc offset 0x000051400000, size 0x000000800000
[ 4.021175@3] meson-mmc: [mmcblk0p08] dto offset 0x000052400000, size 0x000000800000
[ 4.021184@3] meson-mmc: [mmcblk0p09] cri_data offset 0x000053400000, size 0x000000800000
[ 4.021194@3] meson-mmc: [mmcblk0p10] param offset 0x000054400000, size 0x000001000000
[ 4.021203@3] meson-mmc: [mmcblk0p11] boot offset 0x000055c00000, size 0x000001000000
[ 4.021212@3] meson-mmc: [mmcblk0p12] rsv offset 0x000057400000, size 0x000001000000
[ 4.021222@3] meson-mmc: [mmcblk0p13] tee offset 0x000058c00000, size 0x000002000000
[ 4.021231@3] meson-mmc: [mmcblk0p14] vendor offset 0x00005b400000, size 0x000010000000
[ 4.021241@3] meson-mmc: [mmcblk0p15] odm offset 0x00006bc00000, size 0x000010000000
[ 4.021325@3] meson-mmc: [mmcblk0p16] system offset 0x00007c400000, size 0x000074000000
[ 4.021336@3] meson-mmc: [mmcblk0p17] data offset 0x0000f0c00000, size 0x000d7ec00000
[ 4.021422@3] meson-mmc: [mmcblk0p18] CE_STORAGE offset 0x0000f0c00000, size 0x000d7ec00000
[ 4.021510@3] meson-mmc: [mmcblk0p19] CE_FLASH offset 0x000e6f800000, size 0x000020000000
[ 11.440431@3] EXT4-fs (mmcblk0p18): couldn’t mount as ext3 due to feature incompatibilities
[ 11.446854@3] EXT4-fs (mmcblk0p18): mounted filesystem with ordered data mode. Opts: (null)

screenshots of “dmesg | grep mmcblk”:

screenshots of “ceemmc -v”

P.D: With the last nightly, it already installs me without problems in single boot