H96 Max S905X2 working Coreelec

Here are the outputs:

fdtget -t s /flash/dtb.img /meson-remote status

fdtget -t s /flash/dtb.img /meson-ir status

Ok, for me it’s the other way. Change it by executing these commands:

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /meson-remote status disabled
fdtput -t s /flash/dtb.img /meson-ir status okay

After reboot try the ir-keytable command again. Afterwards update CoreELEC with a tar file and everything will be reset to default status. Or you do it manually by switching disabled & okay for the fdtput commands above.

So the solution was quite simple and was an oversight on my end. The HDMI port it was plugged into can be set to 1.4, 2.0, or Auto. It was on Auto. Setting it to 2.0 made HDR work flawlessly.

Am I right that these commands will solve the power up problem on H96 MAX X2 4/32GB?
And what about the red/blue diode? Is it still switched? I have installed stable 9.2 - it works, only problem with power up when shutdown from CE (power up with no. 2 button on remote).

No, these commands are only use to enable the meson-ir in linux kernel to be able to use ir-keytable -u to record the correct IR power on code.
If you have button 2 for wake-up you have defined a wrong code in config.ini

OK sir, I have tried the commands you gave EBAL but after reboot still meson-remote status okay and meson-ir status disabled. ir-keytable says no device. Am I doing something wrong?

Hmm, maybe you rename the remote.conf to remote.backup. I don’t remember if it get automatic set every boot or only on update. Just rename it and reboot and set it again with the commands above.

Hi all,

I’ve made the BL301 injection work on this box. If you have already performed the BL301 injection procedure but cannot wake/power up the device with the factory remote, then just follow these steps to update the config.ini. I’ve already extracted the codes needed by config.ini to recognize the power button of the factory remote. These wake/power up codes work with the remote.conf provided here by Bazzle, therefore continue to use that remote.conf file.

SSH to the device and then do these:

mount -o rw,remount /flash
cd /flash
nano config.ini

<add the following line to the bottom of the file>
<save and exit>


Hope this helps!


Do you have this type of remote control? remote.webp (84.9 KB)

Can’t open the file. I’m using the stock factory remote (red power button on left, blue power button on right for TV)

hello Bazzle / all,

please be gentle as I am new here and a novice to all this. I always was able to get my enybox up & running with just the coreelec images and worked right away without having to make any adjustments.
now I wanted to do the same for my h96max x2 and what a headache as I cannot get it working,
read several things and I tried the nightly build, stable version even followed the advice by picking the correct dtb file 4gb and placed in root… nothing
I keep getting a black screen on boot,
can someone please help me?
would love to get my h96 x2 4gb up & running.
or can it be the case I have a fake box?

Assuming you have tried all available dtb files for S905X2 and not having any success with them, suggest you try another SD card. What program are you using to write the image to the SD card? I am using USB Image Writer in Linux Mint.

Hello Ebal,
I only tried two dtb files and those were the ones bazzle confirmed to be working on his h96x2 box. The file g12a_s905x2_4g and he uploaden on in dropbox which i believe was the same file.i used the recommended program rufus 3.8. I dont thinkk the issue is with the de card as it worked perfectly for my enybox woth coreelec without Any issues. Which version CE must i use? Stable one or the one bazzle confirmed nightly one? Can someone point me in the right direction which ce version and dtb file are fully working on the h96 x2 4gb box?

Kind regards,


Try a 2g dtb.

Hello franspokeman,
I have H96 MAX X2 4/32GB. I downloaded stable 9.2 CE (chosen: Skip that and just show me all download options) CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img.gz.
Then I unpacked it and installed with Win32DiskImager.
dtb used g12a_s905x2_4g from SD card and renamed to dtb.img
With this my box boot into CE.
I think remote was not working so I connected MX3 air mouse and chosen samba and ssh and then I copied remote.conf into Configfiles.

This works! Thank you!

Thanks pinkytt i will give it a tryout uttery tomorrow as i am not tired this evening.will let u know right away when done.i also have feeling i have a clone or fake as my remote looks different than then the h96 on aliexpress

ow and pinkytt just to be more specific. which device did you select in the menu? generic devices s905x2 or h96 max with the tv boxes category?


sorry missed this reply from you. and yes indeed that is the remote I have:)

All the Nighties are working for me so far.
Ensure show extensions is working in windows.
Ensure the dtb file has been renamed to dtb.img

Also try the one mentioned by TheCoolest above.
I doubt your box is fake but the memories ? who knows.
If it works as an Android box it should work with Coreelec.
I did get mine working once early on from the 2nd usb port but didn’t try again.
You did find the reset button inside the audio out jack?
I’ve also seen a couple of different remotes as well.