Hardware decoding problem only for amlogic kernel 3.14

I have included 1 minute of HDTV recording (58.8MB - 1920x1080i50hz - H264 video - MP2 audio) of a television channel that I receive with very good signal and without errors.

If I watch this TV channel in CoreELEC using amcodec hardware acceleration (which is usual) the image quality is very bad and full of artifacts and pixels.

If I watch this TV channel from CoreELEC’s tvheadend server on Kodi for Linux x64, Windows 10 or Android for smartphone, or with VLC, the image quality is good.

It also works well on a Smart TV via upnp because hardware decoding is done by Smart TV. If we use for example xupnpd entware and we load a TV_Channels.m3u list in /opt/share/xupnpd/playlists from the file /storage/.config/autostart.sh with the wget -qO /opt/share/xupnpd/playlists/TV-Channels.m3u "http://localhost:9981/playlist" command, then we can watch TV channels on any Smart TV, without problems.

This happens to all the HDTV satellite channels on several mux for several days.

Any solution?

(Tested in CoreELEC 9.2.1 and Nightly 20200203 for Amlogic S912)

2 Likes

Take advantage, you’ve opened the post. To comment that also happens in S905D (ki pro), S912 (H96 pro +), S905x2(T95x2) and s922x (Odroid N2). The only one that hasn’t happened to me has been in an s905x3 (x96 air).

This happens to me, both in the stable and at nightly.

I leave a video of the odroid n2 as a client, so you can see that it fails. And at the end of the video, it is shown that the nvidia shield correctly shows:
https://mega.nz/#!agIziQLb!PE4BUtVFdFoBbkj1KrE-MkrfdB_Lth8NIYEED1DXsn8

Dmesg Odroid N2: https://pastebin.com/kU03ATR8

I also add that another user has reported the same problem and gives more detail: Nightly builds (NEW)

2 Likes

I have read some links where people blame tvheadend about the problems but it is not.

Tvheadend records what it receives, the problem is only in Kodi for CoreELEC, and more exactly the problem is in hardware decoding amcodec. If I disable hardware decoding the problem disappears and the image quality is good, but other problems appear: lack of software decoding power, audio-video delay and poorly flowing frame movement.

@cubimol I have just tried your sample with latest nightly on KVIM3 and it played fine without any of the issues you have described.

I know you have said your device is a S912 which is on an older kernel but there has been no development or changes within the kernel for that device for 6 months now, so if it has started recently then the problem lies somewhere else.

It started 5 days ago so I presume something changed in the way the video stream is encoded making it incompatible with, at least, S905X (my case) and S912 boxes.

I have seen this problem recently from some TV channel changes in a mux. This problem could be very old.

The fact that the amcodec hardware decoder works well in KVIM3, N2, S922X, S905X2, S905X3, … says nothing because they are more modern chipsets and probably the errors in the hardware decoder have already been fixed.

Now the fact is that S912 and S905 probably have defective hardware decoding that is difficult to solve.

I would invite you to try the test 4.9 builds for older hardware by @cdu13a then and see if the issue still exists.

I would love to try 4.9 builds, tell me where to download it.

Not related to CoreELEC, but if you have a FireTV 4K, those channels that now don’t work with CoreELEC, don’t crash the FireTV anymore:

Ok, the problem is solved in s905x2 and s922 (Odroid n2) with the nightly. I leave the video that already works well.
https://mega.nz/#!LtISSKSa!u_bS1BZSLZp7_yGb8JaOx3gE_en8kttvu2uNB5yHKUI

But on S905D and S912, it still fails. Where can you get builds with kernel 4.9, to try?

Link 4.9 for old s905d?

My apologies, there is no link as it’s not been made public yet.

If u need a tester… mp me xD

@SamWilson @mendi @cubimol
There will be a post with links for a public test build soon.

We just discovered a minor issue at the last minute where it seems the update system wasn’t ready to properly handle an s905x/s905d/s905w device asking for an update if it was running an amlogic-ng build with the 4.9 kernel. So once that is fixed I will be uploading the builds and making a post.

1 Like

@adamg @cdu13a Where link test for 905x? Thank for you hard work always

1 Like

Swaped commentary to another topic

If this is related to the funhouse build please post in that topic.

Ok, i swap them, srry

Thats strange, considering more like rigid practice in TV streams, and h264i still used… Any technical news / note on the provider site?