Help usb ports not working on cube x2 coreelec

Hi I have the cube x2
I installed coreelec onto a micro sd
It booted up fine but I have a problem

Basically my default remote which came with the cube x2 stopped working
I had also bought a minix neo a2 lite remote
and I can’t seem to use the minix remote in coreelec
(works fine in android but im guessing i need to do some configuration) but not sure how to go about it and also that i am at the initial setup of coreelec.

Unfortunately when I got the cube x2 pre Christmas I never had the chance to set it fully up and now when i discovered my default remote isnt working not sure what to do.

so if there is any easy way to get the minix neo a2 lite remote to work with coreelec that would be great.

Many thanks :slight_smile:

The Minix remote does not require any configuration.

I have tried before but it does not respond at all on coreelec but in android works perfectly
this is one that I have:
minix neo a2 lite
this is the cube x2:
cube x2

I tried installing coreelec again on the micro sd and made sure i done everything correctly but its unresponsive on the initial setup screen of coreelec can’t do anything.

Maybe your USB port ?

Although works perfectly on android I have 0 issues with the usb for my hard drive or the remote
but in coreelec its unresponsive.

Strange…

Anyways thanks for your replies

I’ll try the suggestions in that thread and hopefully this can be solved
Thanks :slight_smile:

updated the cube x2 to ver 0.2.5 from 0.2.3 and now the remote works perfectly in coreelec
Thanks

Hi
Updating the cube x2 seems to only fix the issue temporary
It stopped working then worked again once i updated to 0.2.8 and now currently the usb ports do not work

I want to try the solution post in

with the autostart but i havent made an autostart before bit confused a how to would be appreciated
many thanks

Connect via ssh, execute this commands from instruction and usb should work…
You could also make autorun.sh via ssh or smb without step about


Here you can find a link on instruction in the end of topic.

Thanks I will try that