HTTPS Server - No connection

Hi,

first of all Thank You for all your hard work. CoreELEC is amazing and also the support of the forum as it helped me many times in the past to solve little problems but this time I really can’t find a proper solution to my problem.

I have CoreELEC 9.2.5 running on a Minix NEO U1 and it works perfectly.

I built my own HTTPS server with a Mac Mini and WebDAVNav Server and it works perfectly with HTTPS Clients on various machines and through Browsers (4K streaming as I have FTTH).

I installed a SSL For Free certificate and no one of the Browsers ask me anymore about certificates.

Unfortunately I can’t say the same about CoreELEC. Once I setup the HTTPS Server as a source CoreELEC doesn’t find any connection and reading around on this and other forums looks like it is the typical problem created by certificates.

I have even tried |verifypeer=false but without success.

I really need to get over this problem as I have the Minix in a separate house from the Server and if I don’t solve this it will become useless.

Thank You guys for your help.

First enable Kodi debug log in settings, restart kodi and try to play one item (if share even visible). And then post debug log.

Hi vpeter,

finally I managed to do what you asked me.

Unfortunately I can’t play any items as when I add my HTTPS server as a Source it says that it is impossible to establish a connection to it.
To give you a proper debug log with all my steps I switched on my Minix, then added my server as a source (even if it says that it is not possible to create a connection) and as last posted the debug log as your instructions.

Just to be sure I checked more than once Username PW IP address etc. and everything is absolutely correct about my HTTPS server.

Here is the link to the Log : http://ix.io/2Ef7

Thank You very much for your help

You didn’t enabled DEBUG mode in Kodi.
But from what I see here

ERROR: CCurlFile::FillBuffer - Failed: SSL peer certificate or SSH remote key was not OK(60)

there is an issue with certificate. Try adding

|verifypeer=false

to sources.xml as shown here: https://github.com/xbmc/xbmc/pull/13909

Hi vpeter,

I apologize as I am not familiar at all with these procedures and I never had to do it in the past.

I enabled Debug Mode in Kodi and here is the link to the Log : http://ix.io/2ErD

I will try now to add |verifypeer=false in the way you suggested.

Thank You very much once again for your help

About | FAQ | Terms of Service | Privacy Policy | Legal Notice