Install issues x96 max plus S905X3 4GB/64gb

Hi shabaocaiji

From my research and experience I would bet that your X96 Max+ box is a clone. It will likely have by default the Andorid build ID 1719 and almost certainly will not have the FOTO Update app installed by factory default for obvious reasons being almost certainly a clone.

If you look at my photographs I posted earlier in this thread one of a good box motherboard which works fine with CoreELEC and the oither the problem motherboard box which is I feel almost certainly a clone box. You will see the one marked a later V4 is a really badly designed and kludgy motherboard with a terrible daugher board too not present on the neat genuine board, and also the CPU is in a slightly different position than the geniine motherboard and as such you will see on the heat sink that the heat transfer pad is not where it should be and is partly not fixed to the the metal heatsink as the genuine boardd cpu heatsink pad is. So to me these kludgy V4 motherboards clearly appear not to be genuine but likely a bad clone.

So anyone ordering this box ensure they tell the supplier that it must not have pre-installed by default Android build ID1719 ( there maybe other clone box Android version ID numbers by now too) and that it certainly DOES have the FOTO Update app preinstalled by the factory. If not or the supplier refuses to confirm those points then do not buy it and if you still after that get such a clone box then return it for a full refund.

The S905X2 boxes are I understand not an altrernative as they are an older slower and inferior cpu and system.

I’ll managed to install coreelax!! I used the 2gb dtb device tree.

When I used the 4gb dtb device tree it won’t boot into core elac install

The only way to confirm Ram amount specs of your box is to open it and take photos.

I was considering buying one of these, but I would certainly hope to avoid getting the clone one. Is there any chance you could send photos of the outside of the boxes that show any differences without needing to open the box or turn it on.

Edit: I mean essentially the way the connectors look (or are spaced etc) form the outside of the box (not the plastic casing itself as this can easily change between patches).

Many thanks.

Looks like I have one of these v4.0 boards that can’t boot either from an sd card or emmc. While booting from an sd card I just get to the Android recovery menu, and boot from emmc (after CE installation there, of course) stucks on the X96+ logo. However, usb boot to CE works just fine.
The only problem for me is that I don’t have a fast enough USB storage to run CE from it.

Will be happy to help you fix the issue with double boot from emmc. Let me know if I can do anything.

If I need to provide an uart log, will this uart-to-usb converter be good enough?

And many thanks for your hard work, CE is great!!

Look at how to order

As noted HERE

Thanks, I’ve seen it. My understanding is that the SDIO board is a more convenient alternative for uart reading, isn’t it? 15 EUR is a bit expensive for me, so I’d prefer to stick to the cheapest solution.

Is is possible to read uart without the board?

just to chip in, i also have a problem x96 Max + box i am struggling with - see below post i put on XDA asking for some help with a custom rom…

Hi ISlakar

having some odd issues with my x96max+ also. i have been unable to get CE on it at all. the box simply will not boot from the SD, in fact it wouldn’t even boot in to stock rom with the SD inserted, just got stuck at the x96 splash screen (but if i insert after stock is booted i see the SD and CE partition) my reset button appeared to be either broken, or disabled as it has no effect, does not even restart the box. i figured it may be disabled by firmware intentional or due to a bug so i tried some custom roms. non worked initially and no longer (or so i thought) was recognized by the AMlogic burning tool. the box appeared bricked however i noticed by chance that after around 4 minutes, it would suddenly ’ connect’ in the flash tool on my PC and teh clock would light up, and the box would stay connected in the flash tool. i tried same as you - many ROMS, none of the generic s905x3 roms will boot the box, and neither will the ‘stock’ x96 Max + roms i downloaded (various releases from last year and this). I found i can get the box to boot using slimbox ROMS for x96 AIR p1, p2 and V2. It does not run well with them though and hangs oftern for a few seconds, and still no way to get CE on with re-set button still seemingly broken or disabled. i treid ‘reboot update’ from terminal emulator but still no CE, it just seems to boot in to the boot loader, i dont get any CE splash screen. ive had loads of cheap boxes before and always have been able to get a decent ROM in them, and then get CE going from SD, but this one has me perplexed…

what ROM did you find that worked on you X96 Max+ ?

Thanks!!

Just to chip in, I am running CE on X96 Max + 32/4gb no problems.

why do you need a custom rom, the original works for me.

i cant get the box to boot in to the SD with the original rom, although i am pretty sure i don’t have a true x96 Max+. looks like one but if it was, the stock Roms i downloaded would run on it but they don’t. hoping to find a rom that will run on the box and allow me to boot from SD. already tried toothpick method, running ‘reboot update’ from terminal emulator and attempted to do same command from adp, but cant even get connected using adp on my PC. same behavior with the stock rom it came with and many others i have flashed on…

on my other boxes, i have seen good performance improvements as well as functionally improvement (passthrough actually working!) and more space as bloat ware no long present. i generally only buy a box if there are custom roms reported to run well on it and i can find reference here that folks have CE running on it OK. thought i had done my homework with this one but it seems there are some dodgy verions about that are not what they were advertised as…mine is supposed to be 4/32 but not convinced. the roms i did get to work show 10gb space available…

so i got it working with CE booting from SD card. it looks like i do have a real x96 Max+, however, it is the 2/16 version, not the 4/32 it was sold as and is suggested on the label underneath. pleased i have a box that appears to work quite well on early tests but pretty pi$$3d that it is not the 4/32 version…

Hi All, I’d like to share my experience with X96 Max Plus2 which was bought 12.1.2020.
16GB Toshiba SDCard was bought as well. According to my intention CoreELEC (CE) would have installed on SDCard and applied the ‘toothpick method’. Well … almost done.
Suggested image was downloaded from CE site (CoreELEC-Amlogic-ng.arm-9.2.5-Generic.img) to my X96 Max Plus (S905X3 4G/32G).
I extracted the img file from the tar.gz because Rufus likes it better (according to my experience). The .img file was added to Rufus (version 3.11 (Build 1678).
Rufus finished with the SDCard successfully. Recommended fle from devices_tree was copied to the root and was renamed (sm1_s905x3_4g_1gbit => dtb.img).
SDCard was pushed into the X96; powercord was removed; reset button was pushed and hold by the toothpick; powercord was pushed back … and:

Starting debugging shell for boot step: mount_flash… type exit to quit

*** Error in mount_flash: mount_common: Could not mount LABEL=COREELEC ***

I felt not good.
I came to here read and I saw it is possible that my device is not ‘original’. I thought maybe that causes the issue and CoreELEC will not boot ever. My last resort was changing the SDCard. Unfortunately I had no another one but I had pendrive. I gave a try.

I did the same above with this PHILIPS pendrive and it worked.
X96 Max Plus2 (Boardnumber: Q5X3_141 V4.1 2011) - told to be fake - was boot from pendrive with CoreELEC 9.2.5. Success!

P.S.: New SD will be purchased (but NOT TOSHIBA) and perhaps the boot will work from it as well.

P.S2: I have a TOSHIBA pendrive too and I had issue booting from it in the past. I haven’t made my research in the topic.

Almost always after updating coreelec I have this info:
Could not mount LABEL = COREELEC

But usually it helps to connect a pendrive / sdcard to pc and the label somehow returns (sometimes pc does not see either the card or the pendrive after removing it from the box and connecting it to the pc, you have to do it several times until the files appear in the file manager) < visible>![do not format]< /visible>

Hello all,

I have a similar problem with installing CE. I probably have an authentic box because there is a FOTA update and shows me that i have the latest version 20201209-1630. But when i try to boot from USB and reset button pressed it keeps restarting. If i don’t press the restart button it gets stuck on the logo screen. Any idea what to try except other dtb (have tried already)? i currently don’t have an SD card but will try later.

Just to confirm, as it starts to boot, you need to release the reset button, don’t hold it in.

Which Logo Screen? When it boots from USB and you are holding Reset Button, do you see CoreElec boot logo? If yes, you should release Reset Button when you see CE boot logo…

Don’t know exactly for your box, but usually when Android boxes boot to CE you first see Android boot logo and after some seconds CE boot logo should appear on your screen.

No i meant the x96 logo screen. I don’t see any CE screen/logo. It just gets stuck a couple of seconds in thw x96 logo and then reboots.

I would if i saw the CE anywhere on the screen as the instructions said…

Then maybe you are using wrong dtb.img.

I used the following images so far: sm1_s905x3_4g.dtb / sm1_s905x3_4g_1gbit.dtb / sm1_s905x3_2g_1gbit.dtb. Any other ideas?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice