IPTV: ORF1 stutters

i have some problems with 2 channels (ORF1 and ORF2) on my IPTV. All other channels work like a charm (about 200).
the IPTV stream is provided by my ISP.
When i play the stream from my computer (Fedora 32) with vlc, everything works.
when i play the stream from my odroid n2 (nightly coreelec) then it stutters and lags, its unwatchable.
when i download parts of the stream and watch that on my n2, it works.

@Portisch
they are partial locked to region

kodi.log: https://pastebin.com/fb9uWaY3
dmesg: https://pastebin.com/rQ46S9GG

it is related to: Iptv: one channel is stuttering, all others work / stream stalled in log

this was working last year without problems. but i dont know when exactly it stopped working

sample video of playback:


the playback aborted, i did not stop it!
the second scene (from viva) shows how it should be

if there is any information missing, just tell me what you need and i will try to provide it!
any help is appreciated!

I just tried them shortly here and they are working fine. But I use DVBViewer PVR Client here and the DMS get the stream and forward it to kodi.
Maybe it’s just a higher bitrate?

@someuser, please try this test build:
https://test.coreelec.org/boot2k3/CoreELEC-Amlogic-ng.arm-9.2-devel-1594672824.tar
If it works then we have a chance to find solution faster.

first of all, thanks for the response/help, i really appreciate that

and whatever you did to that build, it works! i tested it just shortly (about 2 minutes) but i have no stutter at ORF1, works like a charm!
also ORF2 works

ok, in that case I need your help for testing to find correct patch again
I will do some builds for you later to find a part of patches
And will send you in PM as it will be ready

Check if your h265 video works too

i did, it did not work

have you been able to investigate in that or should i create another topic for that h265 file?

I have no idea what the issue is. I’m currently looking into this issue. The fix send by @boot2k3 is not good because it enables deinterlace on progressive content. This leads to bad picture quality.

any progress here?

We have a fix for this issue , but it could cause another issue with other video files. That is why it still not included in latest stable.
So your sample still in todo…

1 Like

I think you need to talk to your provider as I live in Austria and can use the official ORF streams without any issue.

this has nothing to do with “official iptv streams provided by the tv station”
this is the stream that is provided by init7 and works like a charm with vlc on my workstation
also, this problematic was not occuring a couple of month ago

edit: not sure if more channels are affected. the others i used until now worked as expected, maybe also other channels are affected… its over 250 but i watch only german ones. no idea whats with french/ital/retero/english channels

It have something to do with the provider as ORF is geo protected. So I don’t know if it can be legal streamed outside of Austria. I can not stream it when I am in Germany as example.
When you are allowed to stream it try the original ORF streams as they work here without any issue.

i am pretty sure that is legal: https://www.init7.net/de/tv/senderuebersicht/
i know that orf is geo protected, but seems like init7 has a contract with them. so i can NOT watch the official stream but the one from init7

one more time: this is working perfectly on my windows and linux workstations, but NOT on coreelec.
dont get me wrong but its a bit annoying to fight for reporting problems and being taken seriously.

The problem is acknowledged. The issue is in the closed sourced AML decoder firmware. It is not possible to fix it for us.

can you give me more information about that?
can the firmware be updated? if so, who may i contact about that?
if its not possible to update the firmware, this sounds like a hardware bug and then at least odroid/hardkernel should be informed about that

It is not a hardware bug. We can only wait for updates from Amlogic.

Only workaround is to deinterlace the video or at least mask each frame as Interlaced so the decoder threats it like half frame. In that case there are always enough frames in the predisplay queue.
I did not find a reason why this specific video has the issue. I have tried test videos with 1920p 50fps and they play without an issue.

Deinterlacing a progressive video has the disadvantages that you suffer from chroma issues. Video quality will be worse. But Amlogic is deinterlacing everything all the time as a default that’s probably why they haven’t noticed additionally to the fact that this video is a rare case.

ok so this is “only” a software problem? but as this is part from Amlogic’s closed firmware, this has do be done by them. got it.

So responsible/contact person for this should be amlogic, right? Because then i will contact them and provide them that video. Guess they even dont know about that problem.

edit: i just informed support@amlogic.com about that firmware problem and this thread. lets see what they say. or if they say anything at all :wink:

just noticed that wetransfer does not store that file anymore.
does anyone still have it and may be able to upload it somewhere?

edit: created it new at https://www6.zippyshare.com/v/gFGYLkhC/file.html

if i ever lose the command to create such a file:
first, stop the firewall with systemd stop firewalld
then:
socat -u UDP4-RECV:5000,ip-add-membership=239.77.0.110:0.0.0.0 CREATE:test.out

About | FAQ | Terms of Service | Privacy Policy | Legal Notice