Mecool KII Pro (S905D) with TBS5520SE USB tuner

Hello guys.

I’ve been using my Mecool KII Pro (S905D) with the original Amlogic build (kernel 3.14) installed in the internal memory without problems, the internal tuners work fine.

Now I want to add a TBS5520SE USB tuner but as soon as I enable the CrazyCat TBS drivers CoreELEC no longer boots. I’ve read on this forum that the newer Amlogic-ng build (kernel 4.9) is required to use these drivers.

The problem is that I can’t install the new CoreELEC with the 4.9 kernel (CoreELEC-Amlogic-ng.arm-9.2.4.2-Generic) with a SD card. It doesn’t boot and I’m using the right DTB (gxl_p231_2g_dvb.dtb).

I also tried LibreELEC builds without success (32 and 64 bit versions).

Is it because I have the old kernel installed in the internal memory? Do I need to reinstall Android to internal memory and then install CoreELEC and keep it on the SD card?

To sum up, what should I do to use the internal and external tuners in the Mecool KII Pro?

Thanks!

18 months ago, when CoreELEC amlogic-ng did not exist, all three groups of multimedia drivers (internal, crazycat and latest-kernel) worked fine. Now crazycat no longer works on old amlogic devices and latest-kernel no longer works on amlogic-ng devices.

1 Like

Certainly your problem and lack of power in the USB port.
I followed this tutorial and it works well on my KI Pro.
With Amlogic-ng, Amlogic.
But I have a KI Pro.
About the version of LIbreelec also works well for me, the tuner without crazycat driver does not work.

Every problem is happening because you don’t have factory firmware.

1 Like

Thanks for the replies guys.

So I can’t use a new CoreELEC (kernel 4.9) installed on a microSD because I have the old one (kernel 3.14) installed in the internal memory?

Do I really have to reinstall stock Android to internal memory to be able to have the new CoreELEC (kernel 4.9) on a microSD?

Thanks!

It is not your fault. Don’t let people tell you otherwise who do not even own the device!

I have the latest android firmware in internal, did a fresh installation to sd, etc. It just shows a black screen on our device. It does boot, however the screen does not get initialized.

1 Like

I just tested my mygica t230 usb tuner in both kernels and I can report that crazycat works fine in 3.14 with this tuner (dvb-c) as it did before. It also works well with dvb latest in this kernel. In -ng it also works with crazycat but not with dvb latest (this was the case before). But now it also works with the default module drivers.
So I guess this depends on which dvb device is used so making that kind of “universal” statement isn’t correct.

2 Likes

I have a Panasonic MN88472 (Microsoft Xbox Tuner) USB tuner and an MT DS3000/TS2020 (Geniatech HD Star). Both need the latest-kernel drivers in amlogic S912 and crazycat drivers in amlogic S905X3, other combinations do not work. I have not done tests for a long time but a few months ago the combinations of drivers that did not work blocked the devices, I suppose that the latter will have been corrected.

1 Like

Thanks again for all the replies.

I realized that CoreELEC with kernel 4.9 definitely doesn’t work on this tvbox right now.
However, with TBS drivers from CrazyCat the TBS5520SE tuner does work, just requires external power supply, otherwise the tvbox doesn’t boot from the lack of power.

I’ve done more tests and this is the conclusion.

CoreELEC default drivers
Internal tuner (Availink avl6862): OK
Xbox tuner (Panasonic MN88472): NOK
TBS5520SE: NOK

DVB drivers for TBS
Internal tuner (Availink avl6862): OK
Xbox tuner (Panasonic MN88472): NOK
TBS5520SE: OK

DVB drivers from the latest kernel
Internal tuner (Availink avl6862): OK
Xbox tuner (Panasonic MN88472): OK
TBS5520SE: NOK

I’ll probably sell the TBS5520SE USB tuner and keep using the DVB drivers from the latest kernel so I can use both the internal tuner and the Xbox tuner.

It’s a shame that the internal tuner (Availink avl6862) can’t tune DVB-C and DVB-S2 frequencies at the same time. If I’m watching a satellite channel, I can’t record a cable channel and vice-versa. That’s why I need the Xbox tuner.

While with the TBS5520SE tuner we can do that.

1 Like

I had a similar problem but mine were all used in dvb-c. I had the Khadas vtv, the mygica T230 and the Xbox tuner. All used different sets of drivers so what I did was use them in different devices and use minisatip to add them to the tvh server. It’s not ideal but it’s a useful workaround.
Right now (and this was stated multiple times) we have some difficulties with dvb because the main developer in that department @afl1 left the scene a year ago. So far some progress was made but as every lead that other devs pursued always end up in afl1’s work, it’s not easy to get help in this department. So, we can’t promise anything regarding dvb.

3 Likes

Obrigado Vasco :slight_smile:

No problem, I’m really happy with my current setup where the KII Pro with CoreELEC + TVHeadend + OSCam + cardreader is streaming cable and satellite channels to my other devices with Kodi (PC, smartphone and Android tvboxes). I was already doing this with a Enigma2 triple tuner receiver, but it died so I got an used KII Pro for 45 euros to do the job… Enigma2 is easier to setup but CoreELEC is a lot better.

WeTek was smart enough to have a partnership with OpenELEC guys to offer great support in the past. Mecool could be the new WeTek and do a partnership with you guys. Both parties should at least talk about this possibility.

Back then OpenELEC was even selling at their website a rebranded WeTek Play, I got one and it was great.

Sorry, the use of oscam is illegal and we can give no support for it. Closed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice