MeCool KIII PRO does not boot

#1

Hi,

it happens often after some time my box does not boot from my SD but many times helps unplug and plug with keeping the power button. But yesterday nothing helped but I tried to copy all the files from another SD installation and it started booting but with an error of course.

So when it happens again (it will) I know that replacing some files on the SD helps but which minimum files should I replace to again enable booting when it happens again?

Please for an advice.

#2

I also have a Mecool KIII Pro device with CoreELEC (installed on a 120 GB SSD hard drive [Amazon Kingston SSD 500/450 MB/s + USB 3.0 case ~ €32] connected to a USB port) for two months and I have not had any booting problems . My CoreELEC flies at full speed even with a 90-minute permanent timeshift on the SSD for three users connected to the tvheadend TV server and the speed of writing to disk exceeds 80 MB/s without any problem. I have never had to reinstall CoreELEC.

Maybe your microSD has a problem. When you get to start CoreELEC do the following:

1.- Backup CoreELEC in an external USB memory.
2.- Format and install CoreELEC again in your microSD memory.
3.- Recover the backup from your external USB memory.

My opinion about the use of microSD memories as CoreELEC base is not good.

1 Like
#3

of course I’ve done everything this to restore but what do you mean “My opinion about the use of microSD memories as CoreELEC base is not good”?
This is the only solution from CE to get support here.

#4

When I bought my KIII Pro I also tried to have CE on SD card but for me the SD card was mounted too late when the system was booting up and the device constantly was loading Android instead of CE.

Even when the Android was loaded I also noticed that I had to eject and insert again my card to be able to access it.

Looks like the device UBOOT would have to get fixed to mount the SD cards way earlier.

After realising that - I moved to the USB drive and never looked back. Works flawlessly and I didn’t had any issues with booting or anything else. This is not a CE issue IMHO.

#5

I don´t think that replacing files on SD card is the solution. I believe some MeCool devices have an issue with internal sd card reader. You can find the posts on this forum with similar booting issues of MeCool boxes, including mine. I would try to use external usb sd card reader or USB stick instead to verify if the issue persists.

#6

The 80 MBps write is a great performance. I sure would like to know what utility did you use to perform such a test. Can you please elaborate?

#7

While copying large files in the ‘File Manager’ of Kodi.

File copy operations have the following sequence: SSD_read -> USB_2.0_port -> RAM_memory -> USB_2.0_port -> SSD_write. Total reading speed + writing = 80 MB/s.

Although the SSD can reach read speeds of 500 MB/s and write speeds of 450 MB/s, the limitation is found in the USB 2.0 port of Mecool KIII Pro.

#8

USB2.0 has a Bitrate of 480Mbit/s (brutto), which will result in max. datarate of 40MB/s (netto).
Weird…:thinking:
But you may be right, 40MB/s for read + 40MB/s for write = 80MB/s :wink:

#9

An issue with SD card? What do you exactly mean?
I’ve never had a problem with a new clean installation. Just like the box changes some files that destroys booting sometimes. I don’t think the SD card is corrupted, tested.

#10

I said SD card reader, not SD card itself.
Edit: Try to use external SD card reader with the same SD card to see if the problem is with INTERNAL sd card reader.

#11

of course, I forgot to write the word “reader” :slight_smile:
but can you please specify it more what you know about?

#12

have a look here:



1 Like
#13

The maximum speeds shown by Kodi exceed 80 MB/s but evidently the average speed can not exceed USB 2.0 speed values of 35 MB/s or maybe a little more. However, SSDs work very well.

Try to do the test of copying a backup inside Kodi (and inside your flash memory) and tell me your speed values.

#14

Installations that boot from either SD or USB devices, as recommended, are fully supported :wink:
Only installs that boot from internal storage (of devices that do not incorporate a manufacturer provided dual boot function) receive no support from the devs

#15

@rho-bot Thx! I have no problems on running with my SD card, just the ability of booting is lost many times and when I rewrite the files on my SD it boots but with an error (taken from another installation, but the error was expected - the reason I’m asking which minimum files to rewrite could fix that). I’ll try an USB SD card reader.

@Poida We know

#16

In my experience since Openelec on RPi it is enough to copy these files from .tar to SD card:
KERNEL -> kernel.img
KERNEL.md5 -> kernel.img.md5
SYSTEM -> SYSTEM
SYSTEM -> SYSTEM.md5

That is enough if there is no problem with data partition. I do it often to update to new versions, or to downgrade if needed…

1 Like
#17

So, your claim of … and the speed of writing to disk exceeds 80 MB/s without any problem is totally a bogus and misleading. AFAIK, a USB2 specification clearly says its read (probably slower in write) performance is @480 Mbps (no more than 60 MBps). In reality, I would be surprised if anyone can get even beyond 35 MBps write performance. Thus, prompted me to ask how you achieve such an 80 MBps write performance.

#18

This definitely sound like a contact problem of the internal SD slot. If contact isn’t proper, there will likely occur read and/or write errors to the SDcard.
I suggest to do a fresh install & put some tape on top of the sdcard, to make it thicker and increase pressure on the contacts.
But if you prefer fixing biterrors, just go ahead

1 Like
#19

Ahh good!. Didn’t want less informed folk being misled by the incorrect statement:

You’ll get support for any installation using approved methods (not just SD) :wink:

#20

@Sholander @rho-bot thx guys, I’ll arrange myself acc to your advices!