My H96 Pro Plus Amlogic box reboots randomly and often

I just upgraded from an X96 Amlogic s905 box to the H96 Pro Plus s912 box. Basically only for the gigabit ethernet port as the 100mbit on the s905x was causing problems with some very high bit rate videos…

Anyway, installed lates CoreElec on the box and did some tests, movies seemed to play alright but now I noticed that the box keeps rebooting. Completely random from what I can tell. If you are browsing menus inside Kodi or watching a movie doesn’t seem to matter, it reboots. all. the. time.

I have tried several different versions of CoreElec and even went back to an old LibreElec - no difference.

What could cause a box to restart/reset like that? Is it faulty? Not enough power? The power adapter says 2000mA on it. Should be enough? I have nothing else connected to the box, wired ethernet and no addons whatsoever, fresh install.

I also enabled debug log and looked at it but when the box crashes it just cuts it off so there are no exceptions or anything like that in the log, so no help there.

I’m currently thinking it could be.

  1. Insufficient amp on the power supply. Is that even likely, the randomness of the crashes seems to suggest no, on the other hand, it never crashes when it’s idle, only when actually doing something, be in browsing titles or playing a movie.

  2. Corrupt memory card, have yet to try another one.

  3. Faulty box in general. Unlikely?

Any suggestions at all? All help is welcome. Thanks!

You steps looks correctly.
1st of all try different power supply.
If it doesn’t solve you problem, than it possible to decrease memory speed (need to update u-boot)

Check your CPU temperature. These cheap boxes very easily and quickly overheat…

Probably wise to rule that one out, before asking for help

Not unlikely at all, considering the cheap (sometimes reject) parts that are used in these 'el cheapo boxes

I’ve had this on a device when powering the device from a TV’s USB port, it didn’t provide enough amps and as soon as I changed to using a PSU it was fine.

Might not be the issue here but it has been known to cause this, I wouldn’t expect it on the supplied PSU though.

Thanks. I am hoping this will solve the issue, but a power supply that delivers that kind of power is pretty expensive, I want to get at least 3A @ 5V, but preferably even more. They cost around as much as the box itself…

The supplied PSU feels very cheap and even if it says 2000mA on it, I kind of doubt it now when I’m looking at prices for PSUs…

Did you also have completely random reboots or only when pushing the box? I have completely random. Can be doing absolutley nothing and it will reboot. Booting into Android on internal seems to work better, have yet to do more testing there…

Temperature - in hardware monitor settings it seems to stay at around 126 F (possible to change to C??) which should not be too high? Seems a bit too stable, 126 F in menus, and 126 F when watching hi bitrate 4K material… But that’s CPU? Not GPU?

I have now tried with a 3A PSU but no difference. I also tried booting into internal Android and same thing there. I have made a ticket through eBay to the seller that the box seems faulty. We shall see what happens…