Netflix Broken

That last update to the Netflix support add-ons broke Netflix on my N2. It stutters and hangs a lot now, pretty much unwatchable. Does anyone know if there’s a fix in the works?. Would rather not have to deal with undoing the update if I can just wait for a new one.

Which last update, to which version ? Version 0.15.1 had big problems which v.0.15.2 supposedly fixed. If you are on 15.2 then take a look at this post.

Thanks, I saw that post before. Want to avoid messing with the installation. Just hoping a new update comes that will resolve things. I should check versions, haven’t looked yet.

If your problem is widevine, no future update will fix it because they will all install newest version.

Pretty sure it was the widevine update that killed it. I guess I could try uninstalling and re-installing to see if that makes a difference.

Did you try with .old version (4.10.1303.0) that works on my N2 perfectly ?

I downloaded those libs you posted and re-linked to the old lib. Seems to have solved the problem, didn’t take too much effort.

Don’t know what’s going to happen the next time Widevine tries to update. Don’t understand why this last one caused such a problem, hope that isn’t a common occurrence.

Interesting thing is that only NF works better with previous widevine version, although it also works (sort of) with new version. None other addon using inputstream.adaptive that I know of can work with old version, only with the new one. So, I guess it’s NF doings, not related to the addon or inpustream.adaptive.

I use Netflix and HBO add-ons and I don’t have problems with any of them. And yesterday widevine was updated.

Try playing "Our Planet” E1 4min-6min scenes in1080p with subtitles. Does it play without frame skipping ?

That’s impossible :smiley:! First of all it didn’t start 1080p in auto stream selection mode. I changed to manual and lost subtitles but even without them those minutes had frame skipping. They’re some tough couple of minutes! I’ve been watching Mindhunter and in that I don’t have any problems. Or rephrasing it, I had problems because after the change in frequency my GT-King started to have high temps when SW decoding. So when it passes well over 70°C I have stuttering. I downclocked it a bit and tested for a while (but not too long) without problems and the temps have fallen, it seems.
Tomorrow I’ll do more testing.

The movie “First Kill” under recently added was the one giving me trouble, seems to have some pretty high rates in it. Didn’t check other stuff though, gave up on the add-on at that point. It was really choking, stutters and hangs. Movie plays fine now after Iinking to the older Widevine lib.

I should probably put the new lib back to verify it was the problem and not some other issue, but it works now and I don’t really want to mess with it anymore. Just wait until the next Widevine update I guess. Right now Netflix is the only add-on I have installed using input streams, but that could always change.

Then just leave the old version and enjoy until it lasts. My situation is different since I have two addons that work only with new version. With new version I can watch some NF streams but for movies/episodes with high bitrate (scenes with 20Mbi/s) I have to switch to old version, otherwise it’s unwatchable…

Only the first minute of episode2 has very high bitrate. The rest of the series works OK with new WV version.
It’s a completely different thing with “Our Planet” documentary episodes that every now and than have scenes with bitrates over 20Mbit/s

Yes, with old widevine version “Our Planet” plays fine. It sucks having to change versions but as I only experienced stuttering in a few scenes I’ll keep the old version for the real hard cases.
I hope this gets worked out in some way.

1 Like

Greetings,

https://drive.google.com/open?id=1aSip5SU1k41L7nVAqRVM0pyp3lBTvYMS .

It gives me such an error, I have searched for a solution but could not find it.
I would be glad if you help.

Best regards…

If you are looking for Netflix help, look at this post

1 Like

Two days ago widevine was updated and now I can log in Netflix, but whatever I choose it doens’t play.
How can I install an old version?

Look at the previous post from Sholander.

The Sholander’s solution is for the frame-skipping problem.
Ny my case the stream doesn’t start at all. I see the CoreElec red circle spinning for a second and then I’m back at the titles list.
By the way, I’ll try to downgrade widevine. Maybe this will fix my problem too.

Probably not. To fix this issue you have to reinstall Widevine decryption library.
Take a look at this post

About | FAQ | Terms of Service | Privacy Policy | Legal Notice