Nightly builds (NEW)


Recordings.ts - 38.5 MB

Hi, i have the same problem on same Box. have you found a solution ?

Can you tell me please your SoC revision?
By SSH: cat /proc/cpuinfo | grep Serial
Or in Kodi->Settings->system information (somewhere)

I have a Beelink GT1mini-2 with the 905X3 processor and am currently running the latest
nightly from an SD card. I have booted to the Android OS currently installed on the NAND and
observed the following behavior; the device has a power LED along the edge and as expected,
the LED is illuminated when the device is powered on and extinguished when the device is
powered off. The same LED however, as expected remains illuminated when the device has entered
into a sleep/suspend mode. And by pressing any button on the remote can be awoken from this
state and normal functions resumed.

When the device is booted to CoreELEC from the SD card, the behavior is different. When I use
the “Power Menu” to power off the device the power LED remains illuminated even though the
device is off. When the device is entered into a “Suspend” state from the same menu, the power
LED as expected remains on. But cannot be awoken with any button on the remote except the
power button even though the device is NOT powered off (no boot logos are of course observed
during resume). And when the device is awoken from the suspended state an error message is
observed; “Pulse-Eight CEC adapter connection lost”. Making any navigation with the remote
impossible. So manually disconnecting the power is the only course.

Hope we can get this fixed, am looking forward to installing CoreELEC to the NAND with the
next stable release.

Pulse-Eight connection lost.log

Updated to Corelec-Amlogic-ng.arm-9.2-nightly_200321, didn 't help, wifi and bluetooth don 't work.

CoreELEC (official): nightly_20200321 (Amlogic-ng.arm)
CoreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio* | paste
Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

The latest working version of CoreELEC Is Amlogic-ng.arm-9.2-nightly_20200223.

Already did the “Inject BL301 Blob” in the beginning, and set the “IR Remote Power Code” to “Beelink 2”.
Which matches the code for the remote for my device. And it behaves as I described before.

I have VONTAR X96MAX PLUS 2 (s905x3) 4g/32g/1000M.
The latest working version of CoreELEC Is Amlogic-ng.arm-9.2-nightly_20200223.

No, no solution so far, no reply concerning this issue. May be I succeeded a few times to get the video working after rebooting from the web interface or from SSH, without need to go to Android. Stopped playing with that as no replies and advise were coming.
Today I tried to reproduce the rebooting and I did not succeed - obviously HDMI output does not work after power loss and reboot - no video, no audio, as I started some audio-video files from the web interface and nothing came out from the HDMI. So the only solution for now is boot to Android and reboot update to CoreElec and do not remove power.

Hi @Portisch
My device Soc version
/storage$ cat /proc/cpuinfo | grep Serial
Serial : 290a4000010b10000009393856584d50

@filkint Try the following

mount -o remount,rw /flash
fdtput -tx /flash/dtb.img /sdio@ffe03000/sdio/ f_max 0xa21fe80

fdtput -tx /flash/dtb.img /sdio@ffe03000/sdio/ f_max 0xa21fe80
Do I need to enter this command every time I restart (update)? And what does this command do?

At the moment yes, you have a poorly manufactured device that requires the sdio clock to be lowered by 30mhz.

Buy a better device next time.

It is difficult to determine the quality of a device in an online store based on the image and description… :frowning:

New nightly won’t boot. Error in mount_flash is the error message after initial CoreElec boot screen. Odroid N2 from SD.
Also tried extracting KERNEL and SYSTEM from image and replacing.

No good. Will need to start from scratch and restore the backup.

nightly_20200325 has broken /dev/i2c-2 on my Odroid N2, it no longer exists :frowning:

Replace with dtb.img from previous build and you should be okay, will look into this.

@sammutd88 @roidy was both of you booting from SD or eMMC?

Yes SD. Have already restored with a new install of previous nightly.

There has been a lot of device tree updates recently and we only tested changes with eMMC so apologies, will be fixed tomorrow.