Nightly builds (NEW)

some clips are flickering. switching from a refresh rate of the source to other refresh rate ( from 24,97 to 50 for example ). I had to add resolutions and refresh rates to the white list. in the stable version it went well with the blank white list.

Nightly_20191213 on an Odroid N2 - very occasionally when stopping a video the resolution switches back to this:-

This only happen probably 1 in 10 times and playing a video again and stopping to force a resolution change fixes it.

Please collect log after this issue
And check if you have correct default resolution in settings at this time or not?

As well as having the aforementioned colour issue, easily resolved as posted before, I also noted that my previous manual Ip address had been reset to DHCP, again easily resolved from within the CE configuration section, but worthy of note for others that might find initial ssh issues.

Live OTA TV no longer works. Selecting any TV channel results in a No free adapter available error.

I note that there are no TV adapters listed in TVH config, so I’m going to add the module drivers again to see if that fixes it.

Box is A95X Max S905X2 with Microsoft official tuners.


Tried all 3 again (Default drivers, TBS and From latest kernel (which was the one that worked before)) but no adapters show up in TVH config.

Let me know what kind of info.and logs are required.


Updated to 20191214 but still no Xbox One tuners being detected.

Virtually the same here as @Compent regarding IP address and tuners being used. My difference is that I’m running on H96 Max s905x2 and I can’t get TV Headend server to work at all. Logs show that the client cannot connect to the server and the server web page is unavailable.

Watching breakfast telly from BBC iplayer as I write this and it looks good, so I have positive first impressions.

Media modules will be updated again tomorrow which may potentially resolve the issue posted by @roidy.


dmesg -
dispinfo -
CoreELEC logs -

When the problem occurs Kodi’s resolution setting is correct 3840x2160p 60Hz disable GUI scaling set to On.

Mostly seems OK on m y N2 apart from PCM audio seems to be broken.
It worked initially after the upgrade, but after a hard power cycle it was gone.


Switch audio output to hdmi multi ch pcm again once(or some other output)

@anon88919003 next days test build for 905x3? Thank

Does this also mean even better video/picture quality? I wonder what this means for the end user? I am glad that I can test new builds now. I appreciate your hard work. :grinning:

No other option brings back PCM, HDMI works fine though. Its a bug that needs fixing.
Rolled back to 9.2.1 until its resolved.


That means that if you had problematic videos before then you can try it on this kernel and check. It should work (99%)

@anon88919003, /dev/amvideocap0 is now missing, is there a media modules alternative?

I’ve used the “sm1_s905d3_khadas_vim3l.dtb” with the device tree (NG generic build) on my x96 Air (s905x3, 4gb ram, dual band WiFi and gigabit ethernet).

Everything seems to work fine, both WiFi bands, ethernet (I can’t check the speed is gigabit though) and 4k playback on YouTube seems to work OK with hardware acceleration.

Glitchy video on BBC iplayer using am-h264 (hw), get random patches of distorted pixels. I’ll try some proper samples like jellyfish in a bit.

Just wanted to say, that I also installed the nightly build on my Beelink GT1 mini (S905X2).

Mad a fresh install and also had to edit the config.txt to get the correct screen colors. Besides that, I didn’t had any issues.

Only big issue (for me) is, that multichannel PCM isn’t working, like I described here:

Happy to provide logs and other information not only for this, but other issues as well.

I have the same device (the amlogic dt id is “sm1_ac213_4g”). I have the 4GB/64GB S905X3, X96 Air dual band wifi, gigabit eth from aliexpress. When I try that dtb (renamed it to dtb.img), I get just a black screen. Initially, the X96 Air blue logo appears for a couple of seconds and then just a black screen with no response. I’ve tried booting by using a toothpick and also without using it. Same each time - X96 Air logo for a few seconds then nothing.

It boots to android just fine.

Strange?? I can’t think of anything I’ve missed. Is there an extra step apart from renaming the “sm1_s905d3_khadas_vim3l.dtb” to “dtb.img” and placing it in the root of sd card? My sd card is Sandisk Ultra 32GB Class 10.

I used rufus v3.8 to load the generic ng img.gz file to the sd card (used this many times before).


EDIT: Maybe the ram chips are different? DDR3 vs DDR4 etc. Do you know how I can find out the type of ram I have?

EDIT2: According to the aliexpress website for my order, the ram is 4GB DDR3, the CPU-Z app lists device as X96Air_P1 (franklin), and everything appears ok (correct amount of ram, type of cpu etc)

EDIT3: Tried a Samsung sd card and same result.

On Odroid-N2:

Installed new nightly 20191213 freshly on uSD, restored backup tar-file from 9.2.1.
Have to modify wakeup-code in /flash/config.ini (I use an own programmed Harmony).
Everything works for me as with 9.2.1 (AC3 and DTS-sound, 3D, 4K, resolution switching, I don’t use TVH).

One little difference to 9.2.1:
After booting, the first CE-splash screen appears (no version info in the top left corner) with a resolution of 1080p60. Then the TV-screen goes black (in 9.2.1 the CE logo with version info on top left corner is shown), that means I cannot see potential update or restore notes on the screen as with 9.2.1. My TV reports a resolution of 1080p60 during the black screen. Update/restore is done nevertheless, but with black screen. After a few seconds my Confluence-GUI with resolution 2160p30 appears.

I want to see the update or restore messages as with 9.2.1, what can I do?

my dispinfo:

Same situation test ssd and SD different port USB no boot test 2 dtb khadas. TV x96 905x3 4-16b

Cpu-z identifies mine as a X96Air_P2 (Franklin). From what I’ve found (on 4pda) the P1 is the none gigabit ethernet version. The Device Info HW app should tell you under Ethernet, mine has a RTL8211F_Gigabit_Ethernet.

  • There are several options for performance and revisions for X96Air:

A: 2 GB + 16 GB + 2.4 GB Wifi + 100 m (without Bluetooth)

B: 4 GB + 32 GB + 2.4G and 5 GHz dual Wifi + BT4.1 + 100 m
C: 4 GB + 64 GB + 2.4G and 5 GHz dual Wifi + BT4.1 + 100 m

D: 4GB + 32GB + 2.4G and 5GHz dual Wifi + BT4.1 + 1000m
E: 4GB + 64GB + 2.4G and 5GHz dual Wifi + BT4.1 + 1000m