Nightly builds (NEW)

@team Any suggestions? What i’m doing wrong?

@cub0
What is your hdmi setting on the tv set to? I’ve a hisense tv in the bedroom and have to take it off ‘auto’ to get anytype of hdr working.

Matt

I’ve verified the dolittle file is indeed HDR10+ and plays as such on my Hisense H8G using the Odroid N2+.

That at least takes the video file out of the equation of being the issue.

Doing a search on your TV I don’t believe it supports HDR10+, only HLG and HDR10.

Do you have an AVR between box and TV?
HLG and HDR10+ are most definitely work on CE.
I’m not sure what the problem is with your setup, but it’s most likely an issue with configuration/connections.

For my TV I have just options of Standart and Extended HDMI formats. I chosed Extended one.

Definetely supports as I see that when playing the file directly via USB flash.

No, my box directly connected to TV. Could be the prioblem with the box? I heard there are different revisions of 905x3. Or could be HDMI cable an issue? (I think not as HDR is ok and HDR10+ just dynamic version of HDR10)?

You need to make sure that HDR10+ is even supported over HDMI on the TV.
It’s unlikely to be the cable. Very likely to be some settings in the TV, or maybe it doesn’t support HDR10+ over HDMI.

no new nightlies? the ones i found are dated 1.8.
from the relkai url - did that change?

URL is still the same, just nightly builds have been turned off.

Normally we stop the nightly build for a few days, and have the update system move users back to the stable build, so that users that were only using the nightly builds while they waited for hardware support for their device, or for some important fix to end up in stable, didn’t end up missing their exit to the new stable.

However this release cycle has gotten messed up because of a couple of major bugs, which is why the extended time without nightly builds.

1 Like

thanks for clarification!

Tried to reboot to the Box’ Android TV and play the file with MX Player. Everything seems ok, TV detects it as HDR10+ source. The same box, the same cable. So could be any incompatibilities between box and CE?

No.
Try to enable the 4:2:2 chroma option in CoreELEC settings.

Affter enabling this option TV detects signal as YUV422 12bit (previously was YUV444 10bit) but still simple HDR. Neverless the picture looks great, bright and colorful.

What type of signal does the TV detect in Android, when HDR10+ works?

YUV444 8bit

Hi, I’m trying to build CE-ng for my device. Can anybody tell me in which package the dtb files are built in the NG version? There is a device-trees-amlogic package in the Amlogic project which I used to do the customization for the non-ng version but not in the Amlogic-ng project.

In kernel. Either fork the kernel or make a patch for the kernel.

All right. Thanks!

Hi @Ray, I’m going back to the resolution issue we’d roughly a month ago. I’m on the latest nightly from last night, however I noticed on latest stable again. It is the issue of N2 going into 840i mainly after exiting a playback or starting a playback (video). To fix it I need to select a resolution via the GUI.
I tried to open logs however can’t really reproduce as happens once in a while. Maybe it is something related to the GetCurrentResolution / ‘hdmimode=’ you fixed back in 12 July?
N2 connected to TV directly with a good official HDMI and TV HDMI settings on Extended (Sony ADV)
It is not a massive issue as rarely happens and easy to fix, though I thought to drop a note maybe there is a fix.

Many thanks!!