Nightly builds (NEW)

A daily build or nightly build is the practice of completing a software build of the latest version of a program, on a daily basis. This is so it can first be compiled to ensure that all required dependencies are present, and possibly tested to show no bugs have been introduced. The daily build is also often publicly available allowing access to the latest features for feedback. In this context, a build is the result of compiling and linking all the files that make up a program. The use of such disciplined procedures as daily builds is particularly necessary in large organizations where many programmers are working on a single piece of software. Performing daily builds helps ensure that developers can work knowing with reasonable certainty that any new bugs that show up are a result of their own work done within the last day.

Daily builds typically include a set of tests, sometimes called a “smoke test.” These tests are included to assist in determining what may have been broken by the changes included in the latest build. The critical piece of this process is to include new and revised tests as the project progresses.

Source: wikipedia.

Just flagging up an issue with the latest nightly build, updated this morning but since then my soundbar connected on HDMI Arc has been making a horrible whining sound for about 2-3 seconds after stopping a video.

I know what nightlies are and understand the software development process. Just misunderstood the question. All good.

Updated to 20210820 from 20210818, A95 Max, S905X2

Bluetooth is showing as being disabled, despite in being turned on in services.

Turning it off and on again in services enables it again but on the next reboot it defaults to disabled.

http://ix.io/3wvs

Subsequent builds made no difference.

But then, by accident I discovered something.

I had switched the box on at some point and because I was busy with something else, had not switched on my headphones. Came back a little later to turn bluetooth on and off an discovered that it was on.

After a little trial and error I discovered that Bluetooth was now taking just shy of 3 minutes to auto enable and just before it did, there was an error generated in the log.

ERROR : ## CoreELEC Addon ## bluetooth::adapter_powered ## ERROR: (DBusException(’’))

I then added systemctl restart bluetooth.service to the end of autostart.sh and bluetooth now starts immediately again as was normal.

Bluetooth is a kind of bitch. Some works, most not.
Like CE is the server, but the client have to send a active “i am here” to get connected and paired. If your client get a timeout it differs what server hardware you have assembled how it handles active client polling. Maybe it just ignore it or it just disconnect the client when it timeout. But then the software is not in sync anymore and do not know to pair again if the client come back. So both, hw and sw need to be in sync what is the problem as Linux can’t cover any hw handling.

Luckily, the fix in this case scenario is easy.

Thanks for update. Widevine content now works on my S912. But now I have problems with sound when starting playback, which appeared when switching from 9.2.5 to 9.2.6.
Found its description in discussion 9.2.6 but didn’t see a solution.
Is there any way to solve it?

You say your issue appeared “9.2.5 to 9.2.6”
so not related to this update (9.2.7 to 9.2.7)

You found the description in 9.2.6 but did you see any logs provided by the user that raised the problem? Did you raise the problem anywhere and provided logs? I run a S912 with 9.2.7 and never had audio problems.
Bottom line, no logs no problem.

This has obviously nothing to do with @matthuisman update, so your only solution is to make a complete new/fresh installation of v.9.2.7 and test it without any addon. If it’s not fixed it’s some hardware problem that you have to address…
If all is OK, then do @matthuisman update to v.9.2.8, and test it. If all is OK start installing your addons, test after every one to find which one causes the problem.
Or as @Vasco mentioned, send your logs which may reveal the cause for your problem.

Due to the issue, I was using release 9.2.5. But now I had to upgrade to nightly build.

Since the issue appeared in version 9.2.6, I thought someone has a solution. So I asked here.

Looks like I’m find out the source of the issue. It’s appear when parameters “Adjist display refresh rate” set to “On start/stop” and “Sync playback to display” set to “On”. Setting “Sync playback to display” to “Off” resolve this issue.

Exactly issues like this are the reason 9.2 is EOL:

User password for nightly I tried root coreleec not luck

Did You enable ssh ?

Yes I enable also smb too

Typo? “coreelec”

Probably :wink:

I activated smb user and password and I transfer the files from Windows, still not able to connect also I changed the ip

General query - the bandwidth available on your server hosting the nightlies seems to be terribly lacking, I routinely only get 50-60kb/s downloading them on a gigabit connection. I’d be happy to donate a small amount for faster hosting, as I hope others would. Is the financial side what is limiting this?