No fallback for Dolbyvision on Odroid N2+

I have problems with Dolbyvision video files. Here is a 45 second example:

https://www.swisstransfer.com/d/e61b120b-6010-4a90-a64c-2c84660a1dce

MediaInfo says “Main 10@L4.1@High, HDR10+”.

I know that the Odroid N2+ is not licensed for DV. But same applies to a cheap S905X3 box (Tanix TX3) which is nevertheless able to play those files - obviously using the fallback mode. But on my N2 Kodi shows only a black picture. I have tested with the latest nightly ng and ng 20.3 stable - same result. With amlogic-no it works, but amlogic-no is still not usable (boot error without removing power supply).
I compared the journalctl log (see attached file). There are a few differences in sequence order. The only real difference is “kernel: hdmitx: E: ddc w1b 0x54 0x20 0x00” which comes only on N2.
My TV is a Samsung Full HD from around 2014.
N2-TX3-DV-comparison.ods (16.1 KB)
Any ideas?

Try with Amlogic-no. NG is EOL.

As I already said: It works with amlogic-no, but I can’t boot/reboot until I remove the power supply. Otherwise I get the well described mount error.

Fresh install ?
Reboot/Boot works

It even fails at automatic reboot after resizing the STORAGE partition. Tested with a fresh installation on SD card. Will order a second EMMC card

Try another SD card or emmc module

We told the N2 users to make a fresh clean install with Amlogic-no as there where changes what aren’t fixed by a update.

6 posts were merged into an existing topic: Amlogic-no Discussion