No input/output error connecting to WiFi and not recognizing USB devices in A95X F1

After installing and setting up CoreELEC, I placed my password to WiFi but it sends an error saying “input/output error.” It only says “status:idle.” Restarted but still doesn’t work. Connected a keyboard, but doesn’t work and not recognizing it. No NumPad indication.

I tried using a USB WiFi adapter, but since the USB keyboard doesn’t work, it doesn’t recognize too.

does it mean that i have a crap box, because i have this laying around and had this for free and wanna use it.

More info about China Box


Coreelec version…

Try Hard Boot…
Unplug Power Supply

Try wired ethernet

The processor that this box has is a Amlogic S905W (shouldn’t be hard searching it up ig ?) And I installed it to the latest CoreELEC version.

ofc , i did a cold reboot , unplugging , (whats pause lmao)

Wired connection is working, but still annoying using it with ethernet cuz ion use wired a lot

You might test this?

Some wifi connecting issues happen on LE too: invalid wifi key - General Support - LibreELEC Forum

weirdly, the dtb file gxl_p281_2g_a95xr2.dtb worked and surely the wifi adapter worked and the keyboaRD worked . however , when i try to connect to wifi from the board , still spits out the same error “input/output error”

is the wifi driver for this device actually works ? too lazy to do grep and find the wifi device name for it

I have the same problem. The tv box is a mxq pro s905w 1gb. The microsd with coreelec 19.5 works, while the one with coreelec nexus gives me an input network error.

I used the same microsd to test.
Coreelec 19.5: no wifi problem.
Coreelec 20.0 and 20.1: network input error.
(mxq pro s905w 1gb)

Seems to be a 20.x bug with s905w. 19.5 works fine.

Still no log as requested…

Have very similar problem with a Chinese “X96-mini”,
I run CoreELEC from fresh install on a µ-SD card:

  • SoC: S905W
  • RAM: 2GB
  • DTB: gxl_p281_2g
  • WIFI: SSV6xxx (built-in)

IR-remote works with custom remote. conf.

WiFi works fine with CoreELEC v9.2.8 (legacy) and v19.5.
With v20.1 access points show up, but at an attempt to connect WIFI-status falls back to “idle”.

Trying to connect on command line via ssh (“connmanctl”) does show the following:

connmanctl> connect wifi_[HASH]managed_psk
Agent RequestInput wifi
Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
WPS = [ Type=wpspin, Requirement=alternate ]
Agent ReportError wifi
Agent request cancelled by ConnMan
Error /net/connman/service/wifi
[HASH]_managed_psk: Input/output error

udevadm info /sys/bus/sdio/devices/*

P: /devices/platform/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
M: sdio:0001:1
R: 1
U: sdio
E: DEVPATH=/devices/platform/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
E: SDIO_ID=3030:3030
E: MODALIAS=sdio:c07v3030d3030

I wll share output of “dmesg” in a next message.


Here we go with a v20.1-install:

dmesg | paste

Could spot lots of “IRQRatio___ERR.irq” which are not present in v19.5

I have exactly the same issue,
X96 mini-S905W 2G+16G,using dtb gxl_p281_2g
Wifi works fine on 9.2.8/19.5 nightly and stable
But fails to connect under 20.0/20.1
System reports
Network input/output error
Sadly the box’s wired network is down so I cannot even get the log via ssh…


I will need to take a look as I think I have this device. But it will require some time…

What WiFi settings are used? Encrypted? Free? What encryption?

1 Like

I’m using an openwrt router 22.03.3 stable for wireless
Different combination tried, WPA2-PSK with CCMP/TKIP, N or legacy speed negotiation, u name it…
The same encryption method can be connected by the box when using 9.2.8/19.5 but not 20.0, to avoid interference all connection done by fresh SD installation.
So it should be an issue brought by CE version upgrade.

That’s exactly the same issue I with it. I have that model. 19.5 works perfectly

1 Like

My router is configured for WPA2 (CCMP) encryption.

Thanks for diggin’ into this issue.

Same problem with a Q96max (S905L2, 1G + 8G, gxl_p281_1g.dtb, WiFi SSV6XXX_SDIO).
WiFi works fine on 9.2.8 and 19.5, also on 20.0-alpha2. With all subsequent versions, the connection establishment fails. Error message: Input/Output Error

1 Like

Unfortunately, version 20.2 does not bring any improvement either. It is the same with CE 21.0 Omega alpha 2. Is there still hope for a solution to the problem?


can I get your email i want send email to you please thank s