Odroid-C4 Power/Wake Button Problem

I’ve added a power/wake button to the new C4, the same as I’ve done with my previous N2’s. Using the button it to power down works fine, but wake does not work.

I’ve edited the config.ini, added:
gpiopower=479 # (pin 11)

The same as I’ve always done with my Odroid N2’s. But wake/power-on will not work with the button. I have even held the button down for several seconds, up to 10 seconds, with no luck. HardKernel wiki says that somethimes several seconds is required.

I have no problem waking device with the IR remote.

Has anyone else added a wake button to their C4? If so, do you have the same issue, or does yours work as expected? Have I missed/forgotten a step to get this to work?


Did you try it with last nightly? There was a dtb error with overlapping gpios.

Just tried nightly_20200506. Same results. Button shuts system down, but does not wake device.

FWIW, I tried some other pins on J2.

I randomly picked several available pins that are supposed to work as power button pins, according to the Hardkernel wiki at: https://wiki.odroid.com/odroid-n2/application_note/gpio/gpio_key_wakeup

They all will put the board to sleep (except one), none will wake the device:

gpiopower=476 # (J2 pin 16, to of pin 14 GND)
gpiopower=479 # (J2 pin 11, to pin 9 GND)
gpiopower=490 # (J2 pin 29, to pin 30 GND)
gpiopower=489 # (J2 pin 10, to pin 9 GND)
gpiopower=487 # (J2 pin 23, to pin 25 GND)

This last pin test didn’t work for sleep or wake:
gpiopower=481 # (J2 pin 33, to pin 34 GND) Doesn’t Work on these pins!

I updated the config.ini file accordingly each time and rebooted. So the wake button not working issue I’m experiencing, isn’t just due to the J2 pin I was using initially.

Are there pull up for the gpios?
The bootloader is checking for a change of the logic level. So if it is already low a connection to GND will not trigger a wake up. Did you try to connect a pin to +V instead GND? I will check it tomorrow on the C4.

Yes, there is a working builtin pull-up resistor on the pin 11 that I’m using, I’ve checked with DVM. When the board is in sleep mode, there is 3V on GPIO pin 11. Which gets pulled to ground when button is pushed, and then returns to 3V.

I am sorry, it look like I forgot to adapt a power gpio patch for SoC g12a.
It should be fixed with tomorrows nightly.

No problem. Thanks for finding the issue and fixing it.

This is a great project, and I appreciate the hard work that goes into it. Thank you!

Just to confirm…
I updated to “nightly_20200509” and the power/wake button now works as expected.
Thanks very much!

1 Like