Odroid N2 CoreELEC 9.2.2 not working

Hi,

Unfortunately release 9.2.2 is not working on my Odroid N2.
Update from 9.2.1 ended in something like a kernel panic when rebooting.

New installation of 9.2.2 did the same.
(CoreELEC-Amlogic-ng.arm-9.2.2-Odroid_N2.img.gz)
I used device tree g12b_s922x_odroid_n2_dvb.dtb for the new installation.

Sorry, cannot provide more information, I need the box therefore I
re-installed 9.2.1 from CoreELEC-Amlogic-ng.arm-9.2.1-Odroid_N2.img.gz
(working).

Is there a reason you are using that device tree rather than the default one?

My first try has been just start the update from the running 9.2.1. After ending in the kernel panic on restart I tried a fresh install. From the install guide I selected the device tree odroid-n2 with dvb-t:
g12b_s922x_odroid_n2.dtb
g12b_s922x_odroid_n2_dvb.dtb
That seemed to be the best choice for Odroid N2 with DVB-T2.

Wrong?

I’m seeing problems with my N2 and 9.2.2. In my case, boot loops, but i’m not sure it is related
I will run an image of stable 9.2.1 to see if it persist.

EDIT: Can’t find stable 9.2.1 anymore. Will try a few more tricks to see if it works fine

g12b_s922x_odroid_n2_dvb is only for when you have a DVB adaptor attached via GPIO not when you have one attached via USB.

Do not use the bottom USB port next to the DC jack.

O.k., thank you. I’ll try the other device tree. meanwhile I checked which device tree my 9.2.1 installation uses. It’s the non-DVB variant.

My DVB-T devices are connected to the MicroUSB port using a powered USB3-Hub. I have had many problems with one of the USB3 ports of the N2.

Downloads of rel. 9.2.1:

Thanks a lot.
What i finally did was flash the 0413 nightly, disable updates and block traffic from coreelec to internet. It is working fine. Restored a backup I had, updated with trakt and is all up and running.

I’ll wait a few days (weeks) to see if the 9.2.2 situation gets solved. Meanwhile, will be d/l these images onto my nas, just in case

Sticking to old images is the way to get in trouble in the future. Just sit and wait for some problem to be solved with the help of others is not way we would like our community to work. But everyone is free to do whatever they want.

I already told you how to solve the issue.

I’m very sorry @adamg, but I must have miss your answer on how to solve the issue. Please be sure that if i see you provide a fix, i would try it first thing instead of running an older build.

Going back on your answers, i see you have answers for joche02, but not one for me. Maybe your answer was for both of us?

What is reason for this issue? I am using all usb ports on my device. Any ETA for the solution?

In my installation it’s an issue with connecting DVB-T sticks to the type A USB connectors. Did not really test all 4 jacks in a structured way but will do it soon.
Btw.: Yes, I connected my DVB-T sticks using a powered hub.

The issue are USB 3.0 device on both ports (top & bottom) next to the DC plug.
USB 2.0 or lower are working fine.

I currently searching how to fix this properly.

Tried it again using a fresh installation with the non-dvb device tree. The “oops” appears after showing the Hardkernel logo.

I took a photo and did OCR:
3.941495031 bez0 dcbcbe70 frrerco 09571468 rrre0 00000001 00000000 rrrrr95 00000000
3.949820831 bc40 ffrerr95 00o00000 00000000 00000000 dc5edB08 ffrfrfc0 00000003 00000000
3.958155031 bc60 dcSed800 frffco 09571604 frrrer80 dcbcbd70 frfrtfco 090c3b50 ffrrrreo
3.966468831 bcB0 dc5eca08 frrrfco dc4fa 300 ffrrrtc0 e2767900 ffffffco e2761eß0 fffrefco
3.974771031
3.97627783 1 Process kuorker/3:2 (pid: 1846, stack linit oxffffrfc0dcbc8000
3.982401031 Stack: (oxffffffcodcbcbc20 to 0xfffffcdcbeco00 )
3.988295e3 1 be20: errrtcodcbcbc70 frrrrao9571468 0000000000000001 00000000orrrrfr95
3.996268031 bo40: 00000000ffrerr95 0000000000000000 rrerrfc0dc5ed808 0000000000000003
4.001241031 bc60: frrercodc5ed800 ffrrrrao09571604 frerrfcodcbcbd 70 ffffrr80090c3b50
4.012215e31 bc80: ffrrefcodcSeca08 rrertc0dc4fa300 frrerfcoe2767900 ffffffcoe2761e80
4.020188031 bca0: 00000 000000000 ffffffc0e2?6lea0 0000000000000000 ffffff800a995000
4.028161831 bcco: 0000000000000000 0000000000000000 rrerrfcodc5ec800 ffffffcodc5ecB60
4.036134031 bce0: frersfcodc5ec868 frrerfcodc5ec400 ffffrfcodca87000 fffrffcodc5ec878
4.044108031 bd00: rfrrsfcodc5eta08 ffffffcodca870f8 frerrfcodc5eda f0 ffffffcodc5eca08
4.052081031 bd20: ffrrefcodc5ec430 ffffffcOdca72000 frerrrøooaßa@ed8 ffrfra00aba 0rOB
4.060055031 bd40: ffrertcodc5ed800 0000006400000002 rrerrfcodc5eda f0 fffftfc0dc5ed808
4.068028031 bd60: ffrrefcodcSeca08 ftetftco00000101 frrerfcodcbcbdco fffff8o090c3ebo
1.076001031 bd80: frffrfcodc4fa300 frrrrfc0e2761eb0 fFefcoe2761e80 ffffrfcodc4fa330
4.083974031 bda0: fffrrre00a817980 rrrerfcoe2761ea0 ffrrrao0a8317f0 fffrfcOe2761e80
4.091948031 bdco: frrertcodcbcbe20 ffffrr80090ca 9b8 ffrrrtcodc411 b80 fretfcoddie2a00
4.099921031 bde0: frsrereoo9fe4268 fffftfcodc4 fa300 ffrrrao090c3e60 0000000000000000
4.107895e31 be00: 0000000000000000 0000000000000000 sfrrrra009fe1268 ffffrfcodc4fa300
1.115868031 be20: 0000000000o00000 ffrrreoo908zec0 ffffffBO090caßc0 frffffcodc411b80
4.123841031 be40: 0000000000000000 0000000000000000 0000000000000000 fffrff8oo90da870
4.131814031 be60: frrtftcoddd80e00 0000000000000000 0000000000000000 frfrffcodc4fa300
4.139788031 be80: 0000000000000000 0000o00000000000 ffrrrtcodcbcbe90 ffffffcodcbcbe90
4.147761031 bea0: ffrrsr8o0000o000 ffrttfco00000000 ffrrrtcodcbcbeb0 frrfffcodcbcbebo
4.155735031 beco: 0000000000000000 0000o00000000000 0000000000000000
0000000000000000
4.163707e31 bee0: 0000000000000000 000000000000000 0000000000000000 0000000000000000
4.171681e31 bf00: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
4.179654031 bf20: 0o00000000000000 0000000000000000 0000000000000000 0000000000000000
4.18762803 r40: 000000000000000 000000000000000 0000000000000000 000 00000000
4.195601e31 bf60: 0000000000000000 000000000000000 0000000000000000 000 000
4.203574e31 bf80: 0000000000000000 0000000000000000 0000000000000000
0000000000000000
4.211547031 bfa0: 000000000000000 0000000000000000 0000000000000000 0000000000000000
4.219521e31 bfc0: 0000000000000000 000000000000005 0000000000000000 0000000000000000
4.227494031 bfe0: 0000000000000000 0000000000000000 0000000000000000 0000000000000000
4.235167031 Call trace:
4.238068031 Exception stack (6xfrrrrfcodcbcba50 to 0xffTEtcOdcbcbb80)
4.244655031 ba40 ffffff8o0aa94000 0000007f ffffffff
4.252628e31 ba60: ffffffcodcbcbc20 ffffff80096a2c8c 306566663a6d?26f 6273752e30303039
4.260601e31 ba80: ffffffoo79687032 00000000000000fa ffffffcodcbcbb58 ffffffcodcbcbbec
4.268574e31 baa0: 00000000000003e8 0000000080000200 ffffffcodcbcbaf0 ffffff800957608c
4.276548e31 baco: fsresfcodac313c0 000000000000000 ffffffcodcbcbb70 fferfe80094c3c14
4.284521e31 bae0: ftffsfcodd5b7810 ffffff8o09fe0490 0000000000000059 ffffffcoddiez2a00
4.292495e31 bb00: ffffffc0e275f7a0 0000000000000000 0000000000000000 0000000000000000
4.300468e31 bb20: 000000000ab71c67 ffffff800a9b6000 ffffff800a9b9900 0000000000000001
4.308441e31 bb40: 000000000000037b 0000000000000001 0000000000000000 0000000000000006
4.316414e31 bb60: 676e696e75742029 0000000000000001 000000000000000e 0000000000000007
4.324393e31 I1 set_usb phy_host tuning+0xf4/0x118
4.330804031 [ 1 hub_event+0xab0/0x10d8
4.336176031 [1 process _one_uork+0x228/0x538
4.342068e31 I] worker_thread+0x50/Oxte0
4.347615e31 I 1 kthread 0xf8/0x100
4.352642031 I4.358102031 Code : 9133c012 913ae021 97f884cd d5033e9f (b900033f)
4.366474031 amudec_h264 module init
4.37230903] anudec_h265 module init
4.374036e31 —[ end trace 125270306d457d03 1
4.378509031 Unable to hand le kernel paging request at virtual address ffffffffrrootfd8
4.378511031 pgd = ffffffc0dbe?0000
4.378514031 Iffffffffffffffd8] «pgd=00000 00000000, *pud=00000 00 000000
4.378517031 Internal error: Oops: 96000005 [#21 PREEMPT SMP
4.378532031 Modules linked in: anudec_h265 (0+) amudec h264muc (0) amudech264(0) anudec a (…) ota tree fbcon bitblit softcursor font

If you like to see the original photo, I need to know how to attach a PNG file.

Do not use the USB port at the bottom next to the DC jack.

1 Like

Do not use the USB port at the bottom next to the DC jack.

I don’t know if it’s an answer to my posting of the stack trace. Just to clarify: DVB-T2 sticks do not work reliable connected to the USB3 ports. They are connected using the MicroUSB jack.

I did not change it with the update to 9.2.2.

Ok. Will try this on 9.2.2 and report back

EDIT 20200415: All is working fine now. v9.2.2 up and running

1 Like

Can anyone tell me how to boot another image from SD whilst CE is on emmc? Odroid UK have said this isn’t possible and removing the emmc will void warranty.
I’m sure I read on here you can dual boot 2 images from same emmc but I can’t find where I read it.
Just booting from SD and leaving CE was my aim

My N2 boots from SD if inserted. CE stable is installed on EMMC.
There is nothing special to to if You want to boot from SD.

Another option is using petitboot