Odroid N2+ .mp4 and .mkv not working with CoreELEC 19.4-Matrix_rc2

None of my .mp4 and .mkv video files are working on my Odroid N2+ with the latest version of CoreELEC 19.4-Matrix_rc2 (also tried the Nighly version). Only .avi video files seem to work.

Here is my kodi.log for two files (of many) that I tested: hastebin
Both “Taj Mahal.mp4” and “test.mkv” have the same error:
ERROR : DVDVideoCodecAmlogic: Failed to open Amlogic Codec

When switching to CoreELEC 9.2.8 (Legacy) all these files work perfectly.

Hopefully this can be fixed in a future updates?

1 Like

Please upload 1-2 minutes video files samples somewhere to check.

Sorry, new users can not upload attachments.

But it doesn’t really matter if I upload 1 video file. None of my .mp4 and .mkv video files work and I’ve tried many different video codecses. Downloading any random YouTube video as .mp4 and playing it with CoreELEC 19.4-Matrix_rc2 does not work.

My steps are as follows:

  1. Use Rufus to flash CoreELEC 19.4-Matrix_rc2 on a 2gb SD card.
  2. Start Odroid N2+ with the SD card from step 1 without running any updates or changing any settings.
  3. Go to a .mp4 or .mkv video and it will show a video thumbnail and the codec information.
  4. Start the .mp4 or .mkv video and it will show the loading circle icon in the middle of the screen which will always stay on screen and the video will never start (not even playing the sound)

If no any video works then please update to this image and upload full log after watching some video file.

Also please send an output for your serial
cat /proc/cpuinfo | grep Serial

Also please clarify what is attached in usb ports if you have plugged something

As for samples you can upload it to any fileshare resource like mega or other

These are the steps I followed (again!):

  1. A clean install of “CoreELEC-Amlogic-ng.arm-19.4-Matrix_rc2-Odroid_N2.img.gz”
  2. Updated to the image from the above Mega link “CoreELEC-Amlogic-ng.arm-19.4-Matrix_devel_20220131160135.tar”
  3. Tried to play the “Taj Mahal.mp4” video and it still doesn’t work. Link to the video file 5.13 MB file on MEGA
  4. Made a new debug kodi.log. See here: 199.8 KB file on MEGA
  5. cpuinfo “Serial : 290c4000011d15000007313332583350”

This test was done with a USB 3.0 Stick but I also tested it with a USB HDD and directly from the SD card.

I like to emphasize that when using a clean install of “CoreELEC-Amlogic-ng.arm-9.2.8-Odroid_N2.img.gz” all my video files work just fine. So I don’t think its related to any hardware problem.

@Bitizen you only uploaded kodi.log
We need full, dmesg log is also required from this build

I did a “dmesg | paste” and put that in .txt file. See here: 97.1 KB file on MEGA

I’m a bit reluctant to just copy paste all these logs so I really hope this helps.

1 Like

This command gives you url and you don’t have to do any copy/paste of the actual data. Just URL.

dmesg | paste

in which position do you have boot select switch on N2+?
Left(SPI) or right(MMC)?
https://wiki.coreelec.org/coreelec:odroid#odroid_n2_n2

You should try to update petiboot to latest one 20220204
https://wiki.odroid.com/odroid-n2/os_images/petitboot#upgrade_mode

Petiboot images could be found here:
http://ppa.linuxfactory.or.kr/images/petitboot/odroidn2/

We could repeat the same issue on 20211112 version, so don’t use it.

The URL contain my MAC address and I like to keep that private plus I don’t have the ability to delete the http://ix.io/ URL for when this isn’t needed anymore!

Fair enough.

You know the first 3 bytes are defined by vendor and the other 3 bytes are maybe “random”.
So when I know your device I can easily brute force the other 24bits, but for what?

The MAC does not include any identity as it’s not locked by the vendor where you bought it or by your personal data.

So please use dmesg | paste in future, thx.

BTW:
I tried you uploaded sample on N2+ here and it works without any issue. So please make a clean install (again) and try without install any item on the device!
And follow the solution here:

All my tests where done in “SPI boot mode” on “Petitboot (dev.20211112)”. So this could very well be the problem.

I am trying to install “spiboot-20220204.img” from “Index of /images/petitboot/odroidn2” but I am not able to boot in “MMC boot mode”.

These are the steps I followed:

  1. No eMMC module connected
  2. Flash the image to micro SD card using Etcher (spiboot-20220204.img). This does give the warning message “Missing partition table” but finishes successful.
  3. Power off ODROID-N2
  4. Insert the card to ODROID-N2 (tried two different SD cards)
  5. Toggle the boot mode switch to (right) MMC boot mode
  6. Power on ODROID-N2

In “MMC boot mode” my “ODROID-N2” doesn’t boot from a SD card. Also in this mode the blue led never turns on (only the red power led).

I do really appreciate all the help I’m getting. If there’s something I’ve missed or if there’s another way to get the MMC boot mode working I can give that a try tomorrow. Thanks!

https://wiki.odroid.com/odroid-n2/os_images/petitboot#upgrade_mode

1. Download **Upgrade image** http://ppa.linuxfactory.or.kr/images/petitboot/odroidn2/spiboot-20220204.img
2. Rename the image to **spiboot.img**
3. Paste 'spiboot.img' into the file system of the first partition on a micro SD card, not on eMMC
4. Power off ODROID-N2
5. Insert the card to ODROID-N2
6. Toggle the boot mode switch to **SPI boot mode**
7. Power on ODROID-N2

If Petitboot detects 'spiboot.img' from an SD card, Automatically Upgrade itself. 

Why? Why bring SPI into testing procedure? First thing I do when testing is to keep it as simple as possible. SPI is primally meant for dual/multi boot procedures, not for first installations.
For uSD (burned with Etcher) card first installation, eMMC is always removed, SPI switch is OFF → eMMC/right position. Before applying power I let N2 rest without power for at least 30 seconds and it NEVER failed me. If it does it’s then some hardware problem (uSD or N2).
When the installation is finished, then I play with SPI positions, and use it only when dual boot is needed…

Thanks this worked! I am now on “Petitboot 20220204” and running “CoreELEC-Amlogic-ng.arm-19.4-Matrix_rc2-Odroid_N2.img.gz”. My original problem is solved and .mp4 and .mkv video files work perfectly.

I didnt try the Petitboot upgrade at first because I was under the impression that I had to do a new/clean Petitboot install in MMC boot mode. CoreELEC from SD card still only works in SPI mode which is a bit worrying. MMC boot mode not working might indeed be a hardware problem?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.