Odroid-N2 Playback Problems with x264 4K @ 50 fps Content

Hi,

i have Problems with Playback Mpeg4 UHD @ 50 fps Content.

Every few Seconds the N2 Skip some Seconds and the OSD is popping up.
Tested with 9.2.4.x and nightlys.
Same files plays fine on Kodi @ Windows.

Blockquote
2020-08-25 09:59:44.217 T:3309712256 NOTICE: Opening stream: 1 source: 256
2020-08-25 09:59:44.218 T:3309712256 NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 27
2020-08-25 09:59:44.220 T:3309712256 NOTICE: Creating video thread
2020-08-25 09:59:44.220 T:2984235904 NOTICE: running thread: video_thread
2020-08-25 09:59:44.221 T:3309712256 NOTICE: Opening stream: 0 source: 256
2020-08-25 09:59:44.221 T:3309712256 NOTICE: Finding audio codec for: 86018
2020-08-25 09:59:44.222 T:3309712256 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder aac
2020-08-25 09:59:44.222 T:3309712256 NOTICE: Creating audio thread
2020-08-25 09:59:44.222 T:3028284288 NOTICE: running thread: CVideoPlayerAudio::Process()
2020-08-25 09:59:44.236 T:3028284288 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 44100, no pass-through)
2020-08-25 09:59:44.371 T:4061196304 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 50.000, 3D: false
2020-08-25 09:59:44.372 T:4061196304 NOTICE: Display resolution ADJUST : 3840x2160 @ 50.00 - Full Screen (43) (weight: 0.000)
2020-08-25 09:59:44.372 T:4061196304 NOTICE: VideoPlayer: OnLostDisplay received
2020-08-25 09:59:44.654 T:4061196304 NOTICE: VideoPlayer: OnResetDisplay received
2020-08-25 10:00:00.661 T:3028284288 NOTICE: CVideoPlayerAudio::Process - stream stalled
2020-08-25 10:00:26.654 T:3028284288 NOTICE: CVideoPlayerAudio::Process - stream stalled
Blockquote

Blockquote
Vollständiger Name : Hidden.mp4
Format : MPEG-4
Format-Profil : Base Media
Codec-ID : isom (isom/iso2/avc1/mp41)
Dateigröße : 14,2 GiB
Dauer : 1 h 2 min
Gesamte Bitrate : 32,6 Mb/s
Kodierendes Programm : Lavf56.40.101

Video
ID : 2
Format : AVC
Format/Info : Advanced Video Codec
Format-Profil : High@L5.2
Format-Einstellungen : CABAC / 4 Ref Frames
Format-Einstellungen für CABAC : Ja
Format-Einstellungen für RefFrames : 4 frames
Codec-ID : avc1
Codec-ID/Info : Advanced Video Coding
Dauer : 1 h 2 min
Bitrate : 32,0 Mb/s
Breite : 3 840 Pixel
Höhe : 2 160 Pixel
Bildseitenverhältnis : 16:9
Modus der Bildwiederholungsrate : konstant
Bildwiederholungsrate : 50,000 FPS
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0
BitDepth/String : 8 bits
Scantyp : progressiv
Bits/(Pixel*Frame) : 0.077
Stream-Größe : 14,1 GiB (99%)
verwendete Encoder-Bibliothek : x264 core 148 r2643 5c65704
Kodierungseinstellungen : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=16 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=abr / mbtree=1 / bitrate=32000 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Codec configuration box : avcC

Audio
ID : 1
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec-ID : mp4a-40-2
Dauer : 1 h 2 min
Duration_LastFrame : -20 ms
Bitraten-Modus : konstant
Bitrate : 265 kb/s
Kanäle : 2 Kanäle
ChannelLayout : L R
Samplingrate : 44,1 kHz
Bildwiederholungsrate : 43,066 FPS (1024 SPF)
Stream-Größe : 118 MiB (1%)
Default : Ja
AlternateGroup/String : 1

Blockquote

it helps the devs when you provide a small part of the file, so that it plays a couple of seconds to reproduce that behaviour
you could use dd to generate that

i also have some problems with such a file, see Playback: some 4k content is unwatchable (stutters, freezes, cracks)

Here is a Test Clip (Stripped down to 30sek, because its Adult Content)

https://www.file-upload.net/download-14266045/TestClip.mp4.html

File plays fine
(Odroid N2 running CE stable 9.2.4.2, file stored on NAS)

No it dont plays fine because skipping some seconds an osd ist popping up at 18 Seconds.

I can only tell You what I see playing the file with my N2 from my NAS using my TV, my AVR, my network.
Why do you call me a liar ?

I´m out here :-1:

I’am not call you are liar.

I’am only write what is not working. Look at your kodi log and you will see the errors like my log.

You have not supplied logs.
You supplied a snippet of whatever you think will identify your issue.

Tim Taylor made an effort to download and test your file.
You have been advised he played your file with no issues.

If you really want to supply logs
Please do so in the correct way.

Log is in Post 1, there is no other Log.

That is not a NEEDED complete log; follow the guidance in “How to post debug logs” and post a complete log.
Btw, the file you uploaded plays OK, without any error in logs on my N2 with CE.9.2.4.2 from local connected hard disk.
Btw1, test file has Nominal bit rate 32.0 Mb/s and Bit rate is rather high 54.0 Mb/s, so maybe your transfer chain is not adequate…

It make no difference if the file is located localy via usb oder via net.

http://ix.io/2vGp

Your short log doesn’t say nothing…
From your full log I see that you have a problem with NFS, as result stream stalled

2020-08-30 12:10:19.833 T:3561821056  NOTICE: CVideoPlayerAudio::Process - stream stalled
2020-08-30 12:10:45.549 T:4065929056  NOTICE: Previous line repeats 1 times.
2020-08-30 12:10:45.549 T:4065929056  NOTICE: NFS is idle. Closing the remaining connections.
2020-08-30 12:10:54.701 T:3532792704   ERROR: CBitstreamConverter::Convert: error converting.
2020-08-30 12:10:57.537 T:3524400000   ERROR: Read - Error( -1, 110, Connection timed out )

I’am not using NFS.

yep, I see that source is smb… so you have some network issue. may be on RASPBERRY-PI-4- side
ERROR: CGUIMediaWindow::GetDirectory(smb://RASPBERRY-PI-4-/Virtual-Storage/...) failed
Try to play from local source as was recommended before. And if error will occur locally than upload your new log again to check

Same file from locally emmc, same error.

http://ix.io/2vLp

when i watch that video i have some stutters, the log shows nothing
i only noticed that because i watched that clip on my workstation with VLC and on the n2
but i did not have any OSD popping up

i get more and more problems with watching movies on coreelec and the n2… unfortunately, the old reported problems are still not fixed so not sure if this is somehow related

About | FAQ | Terms of Service | Privacy Policy | Legal Notice