One more, can't setup remote wakup

I swear I’ve read all the other threads about it but I can’t get this going.
Using 9.2.3.

I use a usb adapter for an IR remote - I know I can pair it with the Odroid N2 alone but everything works inside Kodi out of the box.
So this remote that blasts IR:

Set remote to HardKernel on GUI
Now SSH and:

$ systemctl stop kodi
$ systemctl stop eventlircd
$ ir-keytable -u

Receive:

Received IRMP code: remotewakeup=‘0xe31cba04’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’

Now:

$ mount -o rw,remount /flash
$ nano /flash/config.ini

add:

remotewakeup=‘0xe31cba04’
decode_type=‘0x0’
remotewakeupmask=‘0xffffffff’

write, close
$ sync && reboot

Test: shutdown
doesn’t power on at all.
Suspend doesn’t come back.

Something is wrong and after reading everything I can’t figure out what.

If you have petitboot setup this can interfere with the bootloader which can prevent this feature working.

Shoog

Yes, I do have petitboot to boot from a usb3 ssd.

Is there any workaround?

I haven’t dug into it myself as when it happened to me I just decided to leave it running 24/7.
Whats I think is happening is petitboot is loading its own bootloader and bypassing the settings that you make in the Config.ini file for CE. As such I suppose the solution would be to set the wakeup code in the config.ini that the petitboot bootloader uses (where ever that is).

Shoog

I have also had this problem.
The only solution I found was setting the remotewakeup value in the boot.ini.
However i am running from emmc.

I also noticed the boot.ini has the remotewakeup value in double quotes, while config.ini has all the values in single quotes.
May be you could try using double quotes in config.ini?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice