Problem instal CoreElec scishion v88 pro

if problem TV is 4k than try to use “force 422 mode” in CE settings

Yes, my tv is a LG 4K, where is this setting? I have stva add-on, where can I change to make it work?

Settings -> System -> CoreELEC (make sure you’re in “Expert” mode)

1 Like

Hi, i enabled the ‘use 4:2:2 colour subsampling’ and it not work in the TV 4K…:cry:

connect via ssh and execute dispinfo on problem TV and send a link for us

I connect with PuTTY y write this:

CoreELEC:~ # dispinfo
http://ix.io/1LgR

CoreELEC Display Information...

------------ /etc/os-release ------------
NAME="CoreELEC"
VERSION="9.0.2"
ID="coreelec"
VERSION_ID="9.0"
PRETTY_NAME="CoreELEC (official): 9.0.2"
HOME_URL="https://coreelec.org"
BUG_REPORT_URL="https://github.com/CoreELEC/CoreELEC"
BUILD_ID="dd51c3e0809464aa9ad81cd8e49df3c660761f26"
COREELEC_ARCH="Amlogic.arm"
COREELEC_BUILD="official"
COREELEC_PROJECT="Amlogic"
------------ /proc/device-tree/coreelec-dt-id ------------ Missing!
------------ /proc/device-tree/le-dt-id ------------
gxl_p212_1g
------------ /proc/cmdline ------------
rootfstype=ramfs init=/init console=ttyS0,115200 no_console_suspend earlyprintk=aml-uart,0xc81004c0 ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000 androidboot.selinux=enforcing logo=osd1,loaded,0x3d800000,576cvbs maxcpus=4 vout=576cvbs,enable hdmimode=1080p60hz cvbsmode=576cvbs hdmitx= cvbsdrv=0 androidboot.firstboot=0 jtag=apee androidboot.hardware=amlogic console=tty0 systemd.show_status=auto BOOT_IMAGE=/dev/boot boot=/dev/system disk=/dev/data
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/edid ------------
Rx Brand Name: 
Rx Product Name: 
Manufacture Week: 0
Manufacture Year: 1990
Physical size(cm): 0 x 0
EDID Version: 0.0
EDID block number: 0x0
blk0 chksum: 0x00
Source Physical Address[a.b.c.d]: 0.0.0.0
YCC support 0x00, VIC (native 0):
ColorDeepSupport 0x00 10/12/16/Y444 0/0/0/0

Audio {format, channel, freq, cce}
Speaker Allocation: 0x00
Vendor: 0x000000
MaxTMDSClock1 0 MHz
SCDC: 0
RR_Cap: 0
LTE_340M_Scramble: 0

checkvalue: 0x00000000
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/edid_parsing ------------
ng
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/rawedid ------------
0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/config ------------
cur_VIC: 0
VIC: 0 invalid
Colour depth: 8-bit
Colourspace: RGB
Colour range: default
EOTF: SDR
YCC colour range: limited
Colourimetry: default
PLL clock: 0xc000027b, Vid clock div 0x000c0000
audio config: on
3D config: off
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/dc_cap ------------
rgb,8bit
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/attr ------------
422

------------ /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap ------------
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/preferred_mode ------------
(null)
------------ /sys/devices/virtual/amhdmitx/amhdmitx0/hdr_cap ------------
Supported EOTF:
    Traditional SDR: 0
    Traditional HDR: 0
    SMPTE ST 2084: 0
    Future EOTF: 0
Supported SMD type1: 0
Luminance Data
    Max: 0
    Avg: 0
    Min: 0
------------ /sys/module/am_vecm/parameters/hdr_mode ------------
2
------------ /sys/module/am_vecm/parameters/sdr_mode ------------
0
------------ /sys/class/display/vinfo ------------
current vinfo:
    name:                  576cvbs
    mode:                  7
    width:                 720
    height:                576
    field_height:          288
    aspect_ratio_num:      4
    aspect_ratio_den:      3
    sync_duration_num:     50
    sync_duration_den:     1
    screen_real_width:     4
    screen_real_height:    3
    video_clk:             27000000
    viu_color_fmt:         2

hdr info:
    hdr_support           0x00000000
    lumi_max              0
    lumi_avg              0
    lumi_min              0
    sink_flag             hdmi out

hdr master display info:
    present_flag          0
    features              0x0
    primaries             0x0, 0x0
                          0x0, 0x0
                          0x0, 0x0
    white_point           0x0, 0x0
    luminance             0, 0

------------ kodi display settings ------------
coreelec.amlogic.limit8bit: false
coreelec.amlogic.force422: true
coreelec.amlogic.deinterlacing: false
coreelec.amlogic.noisereduction: false
coreelec.amlogic.hdr2sdr: 
coreelec.amlogic.sdr2hdr: 
videoplayer.adjustrefreshrate: 2
videoplayer.useamcodec: true
videoplayer.useamcodech264: 0
videoplayer.useamcodecmpeg2: 0
videoplayer.useamcodecmpeg4: 800
videoplayer.usedisplayasclock: false
videoscreen.whitelist: 
lookandfeel.skin: skin.arctic.zephyr.2
------------ /storage/.kodi/userdata/disp_cap ------------ Unset by user!
------------ /flash/boot.ini ------------ Missing!
------------ /flash/config.ini ------------ Missing!
------------ /storage/.config/autostart.sh ------------ Unset by user!

is correct?

It possible that you have just an issue with connection to your TV
Try different port on TV, try different cable.

Yes, I tried with diferent port and diferent cable and the maximum I’ve got is that it works once and I turn it off and on again and it stops working… On the other hand, I try on another TV, which is not 4K and it always works

Make sure the GUI resolution is 1080p, use default skin and post dispinfo when connected to the TV where everything is fine.

Then disable ultra HD deep colour for the HDMI port on your LG and reconnect your box to your LG TV. Make sure your TV is updated to the latest firmware. Which model is the LG TV?

If it still doesn’t work, enable “force 8-bit” and try to see if that helps. Have you tried all the HDMI ports?

Hi, this are the photos of configuration to my tv box:


and the dispinfo:

http://ix.io/1Liu

My TV is LG49UB830V-ZG , Software Version: 04.12.36 (the last)

Where can I disable ultra HD deep colour for the HDMI port on my TV? I dont see…
Where can I enable force 8-bit? on my TV or on the CE?
I have tried with 4 different cable HDMI and I have tried with the 3 HDMI ports on the TV LG and the most I’ve got is that it worked a couple of times and when I tried to watch a movie I stopped working,

thx

PD: the photos are made on the tv no 4k that works

It should be something like “Setup > General > HDMI Ultra HD Deep Colour”. You enable “Force 8-bit” on your device (CE). Regarding your setup, is your device (CE) connected directly to both TVs or through an AVR (receiver)?

I dont see this, I think that my TV havent HDMI Ultra HD Deep Colour.
My CE is connected directly to TV.
I enable Force 8-bit on CE:

and the dispinfo:

http://ix.io/1LiA

PD the photo is made on a tv no 4K, where it works

Okey, so enabling “Force 8-bit” fixed the issue given the picture?

If not, have you tried to connect any other device to your LG TV?

Try to connect to HDMI port 3, disable “Use 4:2:2 colour subsampling” and enable “Limit display colour depth to 8-bit”. Then try to enable “Use 4:2:2 colour subsampling” to see if that helped.

No, thiis photo is on other tv, LG too, but not 4K.
Yes, I try with other device to LG 4k (PS4 or satellite decoder) and they works perfectly.
If a try this configuration, the tv does not show that there is no signal as before, but the image is completely black and yo dont see anything…
Does this happen with the nightly version of CE9? I’m giving up …

Then it’s likely that there is something wrong with your device running CE. I do recommend buying a new one, or stay at an earlier version of CE/LE if that works. You could try the nightly version, yet I doubt that will solve this. Since we don’t have the box, we can’t look into this any further I’m afraid :confused:

ok, thanks for you time :cold_sweat:

You can also try to force resolutions


execute this command
cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap
on working display and after try to connect to non-working tv to check if you receive a picture.

I don’t believe it, now don’t work any device that connects to the port hdmi of my tv lg 4k …
And if I leave some device connected to any HDMI port, the TV is constantly rebooting…

Looks like TV issue.
May be you need to reset it to default settings or left without power for some time… Just assumption
OK contact LG support…

yes, I tried this and nothing, dont work…:sob: I have to change the mainboard of my TV…