Report about Amlogic S905X4 HK1 RBOX X4

Where did I post about Dolby Vision??
I don’t have any DV files to test. However, my Vizio TV DOES support Dolby Vision.
My prior Samsung 4k TV did NOT support DV, and if I had a device that did NOT have a setting to disable DV, then the colors would be all washed out. Most of my Google Certified Android boxes at that time were useless to me, example the TiVo Stream 4k. I could not use that media player, with my Samsung TV, so I tossed it into my “junk” box, until I got the Vizio.

So, I have not tested any DV files under CoreELEC.

Here Report about Amlogic S905X4 HK1 RBOX X4 - #139 by clarkss12 it you certainly implied that it works.

Hummm. I guess you see something that I don’t see. All I was saying, was that out of all my Android devices, only my TiVo supports Dolby Vision.
Not sure where I “implied” that CE on any of my devices supported DV. But, writing is not one of my better skill sets…

I was replying to this statement by you “From the Android side it is definitely inferior to cheap Android TV devices that have Widevine L1 and support Dolby audio.”
To clarify, I have NEVER tested any DV files under CoreELEC on any of my devices.

Sorry for the confusion.

My confusion was when you called it a “Holy Grail” I assumed you meant you found this devices overcame those deficiencies you wrote about.

Unfortunately, there can NEVER be a holy grail for me, because my expectations keep changing.
With the ability to dual boot, this device is not only an excellent media player under CE, but under Android, it is more versatile than any other media player that I have.
Because of my addiction, I have dozens of these boxes/sticks that I have purchased in the last 8 or 10 years. I guess I am always looking for the “Holy Grail”, knowing that there will never be such a thing.

For the ultimate media playback, CoreELEC can’t be beat. It is my goto for serious media watching. For casual use, I prefer Android, that is why dual booting is the ultimate solution for me.

Now there is a Linux desktop app for this device.

Edit: to clarify, dual booting is not available yet for the X4 devices…

If I’m not mistaken, Kodi cannot play DV files yet or never. Only in Android with Android players some DV rips worked.

Not quite correct to refer generally to DV, as there are several DV layers in use . Kodi can handle several, but (yet?) not all DV files, as explained in this Android thread:

Still a mess and no hope for official status in Kodi 20… Maybe Kodi 21 could bring it?

Those samples do play on Android Kodi Matrix on a Xiaomi 4K (that doesn’t support) CE using OmxComponent: OMX.amlogic.dolby-vision.dvhe.decoder.awesome2

So I went ahead and bought one. Mine is HK1 128gb version with 1gb lan.
Tried both

LAN switch in settings menu doesn’t work with 1gbit dtb, using the dtb without 1gbit the settings switch turns on but there is no connection found whatsoever.
LAN worked on the android OS, I made sure to check.

Spdif works as it should with CE.

With power down options, the device reboots on both dtb.

Lastly, Im in Australia and wanted to use 4K 50hz and 2160p 50hz setting my Sony Bravia screen works only with 60hz, 50Hz the screen goes blank and I revert back. The TV is native 50Hz 4K so not sure what the issue is here.

CE runs very well, minus the LAN and display issue I’m very impressed.

1 Like

I suspect if you run dmesg | grep PHY you will see the same chip I have linux-5.15.y/jl2xxx-core.h at main · unifreq/linux-5.15.y · GitHub

[    0.613620@2]- eth%d: PHY ID 937c4032 at 0 IRQ POLL (stmmac-0:00) active
[    0.613624@2]- eth%d: PHY ID 937c4032 at 7 IRQ POLL (stmmac-0:07)

Based on the other working reports I bought a new spdif cable and I do get audio out of CE. I was also able to get analog out, but I need to restart for it to work.

There is a new firmware posted for this HK1 Rbox X4 dated March 5, 2022. I have not tried it yet. Doubt if it changes anything about the hardware drivers.
This is the name of the firmware >> “ah212.HK1RBOX-X4_1000M_11.2022.” <<

1 Like

I’m not game to mess with that until someone else has, thanks for sharing though clarks.

Updated to latest nightly and the device now powers off without rebooting, nice! Still no 50Hz 4K display but I can switch to Android OS for that when needed. Still no LAN support, I assume mine is the same as emveepee, will confirm it when I find time.

Can the following be resolved?
I’ve just noticed that when CE is powered on with wifi disabled, powering down goes into boot and turns back on. When I tried booting, turning wifi on, then off, powering down works.

Thanks that is good information. I was wondering why the shutdown worked sometimes and not all times. I disabled my Wi-Fi, I was not using it, and my device would power back up.

Thanks as well for this report. I use this device wired with WIFI disabled and wondered why it didn’t shutdown properly most of the times. Just tested on Android with WIFI enabled and it actually shutdown.

BTW, I’ve been using using CE and honestly nothing new to report, it works pretty well exept what I reported before with some resolutions frequencies not working on CE that works on Android.

Thanks devs & contributors!

There is no issue on Ugoos AM7 SC2. Please make a SSH connection and enter:
ls -al /sys/fs/pstore
Is there any result like console-ramoops-0?

If yes, please make cat /sys/fs/pstore/console-ramoops-0 | paste and post the received URL.

@emveepee please update with this image:

Drop the tar into the update folder or update easy by SSH:

cd /storage/.update
megadl https://.....

I included the jl2xxx driver but I have no idea if it works. You will need than the generic S905X4 1gbit dtb. Please update and test if eth is working. If yes, please run dmesg | paste, thx.