Report about Amlogic S905X4 HK1 RBOX X4

@Portisch that doesn’t work but it is better than my self built version. It still fails to load the MAC but now I can control the light on the switch with eth0 up/down. I was using 19 before and will try my own build again with 20. I typically get a 169… IP but manually setting an IP doesn’t work either. Once I got a valid IP but my router got the bogus MAC 02:0e:00:00:00:00

Note you don’t include the generic 1gb anymore so I used the 4G version.

When you use the 4G version it will be set to internal PHY, not external.
The generic dtbs are attached here:

I was using the included sc2_s905x4_4g_1gbit I thought you meant the original one before the split, but I will try the linked one.

This is the correct one if you have 4g RAM, yes. Please make a dmesg | paste log.

Here you go http://ix.io/40Ej this one did register the bad MAC on the router.

Here is the Android dmesg if that helps at all HK1 Android dmesg - Pastebin.com

If this is directed to the issue of the device rebooting when the WiFi is disabled, here is what I found. See photo.

Than there is no kernel oops when wifi is disabled. No real idea yet without the hardware. I am not sure if the bootloader is locked. If not and if connect UART to the device the bootloader should normally tell why he restart.

I have another s905x4 tv-box, named x96_x4_pro, which has 4GB RAM, 64GB EMMC, and 1Gb-LAN.
It also has 2x2 WLAN (2 internal Antennas + PCB Antenna for Bluetooth).
These are the dmsg and dtb files i extracted from android11, but now i not want to flash coreelec, instead i hope, i can dual-boot it in future from USB-Stick or SD-Card.
It is the box, described there:

I am sorry but I can not backport the Android dts to 4.9 kernel. You can ask your vendor if they provide the dts in source for your device, maybe it’s possible than. Or you wait for the new 5.4 kernel.
It does use the driver amlogic,g12a-mdio-mux what is not available in 4.9 kernel.

I booted from sdcard with latest ce20 nightly generic and sc2_s905x4_4g_1gbit.dtb as dtb.img with “reboot update” in console from android11.
It came up to boot from sdcard and said dtb is outdated, but later it started up.
GBit LAN controller is not working (also same driver missing as others above), but i can connect with WLAN. Also a shutdown via CE did reboot the device, maybe also same issue as by others above.

The version 20 builds aren’t current with 19 so the dtb files haven’t been split yet. You you have to hit a key on the remote to get by one long delay. There is another delay if the network card isn’t support.

For testing purposes, I installed the Nexus nightly onto a micro SD card, running on an Amlogic S905x4 box.

So far, from my limited testing, everything is working just like the matrix version. Even the Netflix add-on is working perfectly, but only in 1080p with Dolby digital plus audio. The automatic frame rate and resolution switching works perfectly with Netflix.

Live TV plays perfectly with a 480i or 1080i video.

Have not tested the av1 codec yet.

I just love these inexpensive Chinese boxes for tinkering. They are almost indestructible.

More testing to be done tomorrow.

I can access the device using Putty, but can’t access the device using Windows explorer. Even my explorer apps running under Android can’t access this Nexus build.

This has always been my experience with nexus builds on all my boxes so not a S905X4 issue only.

I have a HK1 RBOX X4S (4G/32G) which has lan only 100Mbps. When I use sc2_s905x4_4g.dtb with 19.5-Matrix_nightly_20220621, the network is functional, but a strange MAC address is presented - 02: 13: 00: 00: 00: 00. I’m surprised that the file manager can’t connect to some repositories with the error “Couldn’t connect to network server”. Some repo connect, some not. What can be the cause?

I can connect via Putty, via Windows Explorer, and I also like to use the Secure FTP plugin in Total Commander. In addition, you can install the Amlogic VNC (Team CoreELEC) service in Kodi and connect to the Kodi desktop from Windows via the VNC-Viewer. I have HK1 rbox X4S.

Thanks for the confirmation, Billv.

Thank you guys, the last nightly build 19.5-Matrix_nightly_20220702-Generic fixed the problem with the unavailability of some repository-urls in file manager.
The final limitation of my HK1 RBox X4S is the unavailability of 3840x2160 50fps and 60fps display modes.

Here are photos of my HK1-Rbox-X4S. The set-up is very similar to the box that Titomane has.

https://www.imgup.cz/images/2022/07/02/01.jpg
https://www.imgup.cz/images/2022/07/02/02.jpg
https://www.imgup.cz/images/2022/07/02/03.jpg
https://www.imgup.cz/images/2022/07/02/05.jpg

You have new settings in system/video. Please try them because now 4k 50 and 60 fps works