S905X 1GB Generic - No DTB Working


#1

Hi everyone!

I tried all the P212 1gb dtb images and none worked, my box displays the A905X boot logo then a black screen.

This box is finicky, as I cant get other roms to work either. I can only get the stock image and a stripped version of it to work.

I did a cat /proc/device-tree/amlogic-dt-id and the result was:

gxl_p212_1g

But the corresponding included dtb file doesnt work.

Update: I dumped my dtb.img using dd if=/dev/dtb | gzip > /storage/downloads/dtb.img.gz and tested the extracted dtb.img file, but it doesn’t work either. Now I don’t even get a black screen, it freezes on the A905X blue logo.

The resulting file has 256kb instead of the 40kb ish of the included ones, tho.

Update 2: I tried splitting the dtb with the script found here:

It resulted in 3 files, I tested all 3 and same result, it freezes on the A905X Screen.

Thanks!


#2

I’ve already replied to your post in LE .
More info to identify your chip.
You’ve extracted the Android device tree. That will not work with CE or LE
Upload it here so as the DEVS MIGHT look at it.
Meanwhile look at ❓ Which DTB do I use?


#3

Thanks! I tried both LE and CE and I’m having the same problem. My box is a S905x 1gb/8gb. Here’s the dtb I extracted.dtb.zip (132.3 KB)


#4

Are you connecting the box by HDMI?
Can you SSH into it after the “black screen”?


#5

Yes, I’m using the HDMI port to connect to the TV.

I can’t SSH to the box, it won’t appear on the network. I just get the black screen and thats it…


#6

Did you try one of the device trees from the thread, which @kostaman posted before?


#7

Yeah I tried all 212 dtb’s, including the t3 one and none worked. All show the boot logo then a black screen.

The one I extracted from the box doesn’t even get past the boot logo.


#8

Is there any way to log to a file whats happening on boot? So I can see what fails at the black screen?


#9

If you can connect to the UART connector on the inner PCB (the “motherboard”) of your box, then you can connect it to a PC via a UART to USB adapter and get kernel output and diagnose what’s going wrong.


#10

Are you copying gxl_p212_1g to ROOT and renaming it to dtb.img ?

Are you sure your device is a S905X device? as some A95X devices came with the S905 SoC.


#11

Yep, always replacing the dtb.img on the root partition.

Yes, 100% sure, it’s even printed on the motherboard its a S905X p212 device, the boot logo is S905X and a couple roms for S905X run on it like a slim versions etc.


#12

Hard to say what is going on here without a log dump of the bootloader.

Try pressing down the reset button inside the AV port on the rear of the device as you insert the power cable, don’t release it until you see the S905X logo, if that still fails then try a different USB flash drive or memory card.


#13

Done that, it boots then the S905X logo vanishes and the screen is black forever, no SSH access, nothing.

With the DTB I dumped, it stays on the S905X logo forever.

I tried flashing other images, like this one:

T95X Amlogic S905X 4K KODI 16.1 Preinstaled Android 6.0 TV BOX Firmware 20160921

The firmware works perfectly on the box, but still cant boot to LibreElec or any variants, using any p202 or p212 dtb.


#14

Some good news. ARMBian boots normally!

Used Armbian_5.37_S9xxx_Debian_stretch_3.14.29_icewm_20171226.img


#15

Tried all DTBs that come with ARMBian, no luck.

I’m attaching the DMESG from ARMBIAN boot for reference.log.txt (100.3 KB)


#16

you have “crypt and tee” partitions, typical sign of “secure board”. As with a Xiaomi Mi box, the Armbian kernel starts with the original DTB.

Dtb.img files that you have tried are not loaded by the bootloader due to a lack of signature.
In your case, it’s just a guess.
Accurate secure information is provided by the SEC_AO_SEC_SD_CFG10 register where its value is extracted. Make a TTL log.


#17

I just tried and found out my UART cable is dead.

Any other way to find out whats wrong?


#18

Yes.
This register value can be taken from the burn log. 1. Make a full backup copy of your Android system. 2. Try to install any suitable (in terms of RAM memory type) S905X Android FW on the box via AML-BT. If the board is encrypted, the burning process will fail. Post the log from the AML Burning Tool.


#19

I did, multiple times. Restored the stock one multiple times, including doing the pin shorting on the nand chip to restore from hard bricks. Currently i’m using a modded one intended for the MXQ Pro. It burns ok.


#20

Please show the installation log, the section with “…erase bootloader…”

--Upload encrypt at 0xc8100228 --ulValue = 0x........
ulValue is of interest.