[S922X] Bee-link GT King

on the GT ultimate . dual boot can be done.

Do you mean that there is no Reboot from NAND option in the Power menu?

1 Like

Yes, right.

Ok, we will look into adding the menu back.

1 Like

for images and audio, it’s very good. thank you to all the teams who have worked hard. you guys are great. now i can play dolby atmos and dts hd master. and also 4K films.

@jza, you can try to use this file to fix power button and start from remote
remote.conf (1.5 KB)
Should be placed in \storage\.config\

yes I tried it and now it works. how long is the stable version for the GT K launched? and I hope that later there will be no annoying bugs. thanks

There are no stable versions for GTK yet, only nightlies. 1st public version was one week ago.
But it should work stable already.

It’s important to report all the “bugs” you find. That’s the only way to have a stable image. But I can tell you that it’s pretty stable right now. I’m using it as daily driver mainly for tvheadend client, Netflix and HBO addon.

Netflix work on 720p and no 4K possible, right? Thanks

NF works on 1080p I think.

Yes, Netflix works at 1080p but not all content. Mainly own productions work at 1080p.

The last nightly is rock solid !
The maximum temperature reached while using NF in fHD was around 56°C in a 26°C room.

I do encounter some minor issues, from time to time, as video frames not being refreshed (think of a badly encoded divx where parts of a frame would not be updated and full of pink or green).

Also, I wasn’t able to install inputstream.adaptive from the CoreELEC add-on repo (I add to donwload it manually and install).

I have the problem with emby server, anybody know if the problem is caused by coreelec version, the GT king or emby ?

I found a weird bug, if android resolution is 4K and coreelec kodi is in full hd, CE doesn’t boot.

I don’t know why but if first boot logo is displayed in 4K which is determined by android resolution setting and if CE is in full hd its not working.

I need to have same resolution in both systems to get it working.

Its an annoying problem especially for emuelec the retrogaming fork based on CE because its running in full hd for performance reasons and it limits android side to full hd in order to boot properly. I confirm same issue with standard CE.

Could you please have a look into this ?


I hope the remote and dual boot problems can be fixed immediately before launch. thanks

Thanks for the file it has resolved the power button issues.

Great work being done here as this is now stable enough to use as my daily driver even though it was only released a week ago.:+1:

right, and I just changed to the 201190713 generic version … and I started to feel the stability. I believe the team’s hard work will soon be realized. and GTK users must be impatiently waiting. … :+1::+1:

Let me start with thanking the CoreElec team for their fantastic work.

However I have some serious boot problems.

I received my BeeLink GT King device (with S/N 992X) a couple of days ago. I started with playing around with Android and installed a couple of apps.
After reading all of the info I could find about CoreElec and the BeeLink GT King, I installed the nightly build (20190710-Generic) of CoreElec with a USB stick (64 GB SanDisk Extreme USB 3.1, ExFat) on my BeeLink GT King device. I followed the instructions as given on this site and I encountered no problems what so ever. I installed Oscam and TVHeadEnd42, added a USB disk (WD Green, 2 GB, NTFS) and tested the speed of the wired Ethernet. The speed look promising at first, but after a couple of seconds the speed dropped down from ~60 Mbytes to less then 20 MBytes for the rest of the session. I installed nightly build 20190713 (manually as I do not know how to set the update channel for the nightly builds in CoreElec) without problems and I was able to (re)boot CoreElec at will.
Then I decided to do some tests under Android. At that moment I did not know that you should switch to Android by the “reboot to internal” Power Option Menu option (BTW, I cannot remember seeing such a option in the Power Option Menu). Anyhow, I just removed the USB stick before booting the device. As expected, Android came up and I was able to do some network testing and further (re)booting of Android posed no problems. To do the same network tests with CoreElec, I put back the CoreElec USB stick into the device and rebooted it. To my surprise, the device booted not into CoreElec, but into Android again. Whatever I tried, nothing helped. I even tried as remedy to do the whole installation process again. That resulted not in the installation of CoreElec, but only in the showing of the recovery screen.
Accidentally, I found a workaround. As long as the connected USB disk is accessible for the device during boot, it will boot into Android. When I switch off the USB disk before (re)boot the device will boot into CoreElec. This behaviour was not the case after the initial installation of CoreElec. Only after I booted into Android by removing the CoreElec USB stick before (re)booting, this unwanted behaviour became manifest. Furthermore, the speed of the Ethernet connection is now even lower then before and has become unbearable (only orange led shows, no green led visible).

Question is: what data is stored on the BeeLink GT King device by running Android without the CoreElec stick available for the boot process and where is that data stored that frustrates the boot process. Removing the Android folder from the USB disk is not the solution. I removed this folder already many times in vain.

Please let me know if extra data is needed for solving this boot problem.

TIA Baderks.

Try to put the CE pen to the rear USB 3.0.