[S922X] Bee-link GT King

I am no longer able to power on the GT King from the remote control since using the test/nightly images. I have to pull the power and reset it again to power on.

I am guessing its something to do with the remote working off a USB dongle as opposed to an internal infrared reader.

Has anyone else seen this issue?

This happens when the box turned off via IR power. Are you use remote.conf or meson-ir? The reset procedure it’s strange, enough to pull the power.

I have not added a remote.conf as the device just seemed to work so must be using the meson-ir. I am also unable to power off using the remote button. I have to select poweroff from the main kodi menu.

Sorry . My bad english

This is a english forum!

Make sure you are using the ‘CoreELEC-Amlogic-ng.arm-9.1-nightly_20190711-Generic.img.gz’.image.

Copy this device tree ‘g12b_a311d_beelink_gt_king.dtb’ to the root of the sd card and rename it to ‘dtb.img’

OK I did it already. but the remote doesn’t work. Why ?

The remote if RF, you need to connect the small USB dongle to the GT-K. I’ve noticed it’s range is really short, and it’s having problems even from a 2m distance.
Only the power button on the remote is IR.

I had to turn off the GT K first and remove the memory card, the remote is now functioning … but it can’t be dual booted yet.

I don’t understand what your problem is, sorry.

1 Like

on the GT ultimate . dual boot can be done.

Do you mean that there is no Reboot from NAND option in the Power menu?

1 Like

Yes, right.

Ok, we will look into adding the menu back.

1 Like

for images and audio, it’s very good. thank you to all the teams who have worked hard. you guys are great. now i can play dolby atmos and dts hd master. and also 4K films.

@jza, you can try to use this file to fix power button and start from remote
remote.conf (1.5 KB)
Should be placed in \storage\.config\

yes I tried it and now it works. how long is the stable version for the GT K launched? and I hope that later there will be no annoying bugs. thanks

There are no stable versions for GTK yet, only nightlies. 1st public version was one week ago.
But it should work stable already.

It’s important to report all the “bugs” you find. That’s the only way to have a stable image. But I can tell you that it’s pretty stable right now. I’m using it as daily driver mainly for tvheadend client, Netflix and HBO addon.

Netflix work on 720p and no 4K possible, right? Thanks