[S922X] Bee-link GT King

that’s why the update will be fixed soon. I have been waiting … thanks

@suryo2908 it’s this post.
This can be done using windows. Just open windows explorer and put in the address bar:


Then choose folder “configfiles” and copy the provided file to that location.
Reboot and try the button after this is done.

okay tomorrow I will try. btw, will this upcoming update include this problem? including dual boot?

As promised. Unfortunately, finding a working Samba Server for Android that supports SMB v2 was not as simple as I hoped. But today I found one that can be used in Win 10 explorer. For each transfer I have a screenshot at the start of the transfer, and one after over 70% of the transfer
I also added screen images from transfers to and from my Zotag box to contrast with the BeeLink box…

1 from PC to BeeLink Android EMMC
Copy%20from%20PC%20to%20BeeLink%20Android%20EMMC%20start .

2 from PC to BeeLink Android USBdisk

3 from PC to BeeLink CoreElec USBdisk

4 from PC to Zotac LibreElec USBdisk

5 from BeeLink Android EMMC to PC
Copy%20from%20BeeLink%20Android%20EMMC%20to%20PC%20start Copy%20from%20BeeLink%20Android%20EMMC%20to%20PC%20during

6 from BeeLink Android USBdisk to PC

7 from BeeLink CoreElec USBdisk to PC

8 from Zotac LibreElec USBdisk to PC

Hope this was useful for you. If you need more information, please let me know.



Thank you for taking the time to do the tests.
Your results are similar to what I obtained. The note that was put in the release was because some team members had devices that had problems that made them almost unusable with ethernet. Beelink is addressing them. I (as you) obtain similar results in Android and CoreELEC so there’s only so much anything can be done. Obviously, the results with your Zotac are way better and that’s a question of hardware quality.
If the situation gets worse or changes in any way please feel free to post again.

1 Like

With Support added for S905X2, S922X and A311D! posted, is the support for GTK considered equal to the N2?

I plan on buying a GTK, as far as I read here temps are no problem any more, but most important for me is the wifi. Is it working stable and fast enough for the advertised speed?
I want to exclusively run coreelec on it so I don’t care about dual boot, which seems to be the only thing not working currently. Are there any other known issues that I might have missed?

Thanks for the continued work on this project I really enjoy using it on my current Mini MXII III :+1:

BTK? If you meant the GT King, then it has not the same support as the N2 got.

Wifi and ethernet speed is far from stable, we have to send back some boxes to Beelink to investigate the issues.

Yes of course I meant the GT-King, sorry for the confusion.

I was under the impression that only Ethernet was having problems with stable speeds. Thanks for clarification that also wifi is currently affected.
I hope that Beelink is willing to debug/fix the issues.

I have downloaded version 722 and everything is running smoothly on my GT K. I hope dual boot will be available soon in the next version. thanks again to all the teams who have worked hard.

Hello team, i’ve tried all the night builds, 18, 20, 22, there is issue for each of the version with ethernet,
17/18 - speed 100 works only, lan and internet reachable
20 - speed 100 works only, lan reachable only
22 - speed 1000 works, but lan reachable only
Wifi ok for all nightly versions
Any idea how to fix ethernet communication?


But you said that it works on 22 nightly?
No ideas, we sent a few boxes back to Beelink which had Ethernet and other issues. It will take a while for the boxes to reach Beelink, and for them to be tested.

1 Like

Hi, any feedbackfrom bee-link on the ethernet issue ?

Nothing concrete yet. They told me they didn’t have any issues with Ethernet with the devices they got back from us. I sent them the model of the switch I’m using. Maybe it’s some sort of hardware compatibility issue, where it works with their specific network gear, but doesn’t work with some of the gear we have outside of China.

OK, anything to do with automatic negotiation of the Ethernet link ?

Automatic negotiation works fine.

finally the latest dual boot version is available … everything works normally and smoothly. thanks

I know how these chinese manufacturer works. Do not believe they go through any accurate testing, most probably for them it is enough that the link goes up and there is some traffic through it

1 Like

I don’t know if this helps but I had similar problem with my pc and router. Although both supports gigabit, they were working in 100mbps mode.
I used cat5, cat6 and cat7 cables but the result was same.
Then I read that in order to get gigabit speed, I needed to use Cat5e cable.
Before that, I was assuming that Cat6 or Cat7 is superior and they should have worked fine with gigabit.
Only Cat5e cable worked fine.
With cat6 and cat7, I had to switch “Auto Negotiation” to “1.0 Gbps Full Duplex”
Have you guys tried that?

It negotiates 1Gbps fine, but in my case there’s no traffic, and in my case I can’t even get an IP address from DHCP.

So the problem is on the RGMII connection between PHY and MAC. I have always suspected issue with track rounting and clock screw, but the experiments made by boot2k3 did not came at any good result.
I had a similar problem with my S912 box, T95zmax plus, where in Android gigabit connection worked and failed in linux. The solution was to remove the setting of cali_val (now committed in CE 3.9 kernel).
And this is strange, because unless they run some special kernel, this value should be applied in Android…