[S922X] Bee-link GT King

Thanks for shearing.
For now I just keep the u9
and for speed maybe I buy the minix u22-xj if it is possible to use Coreelec.

First I bleamed minix for making bad android os.
But if I read reviews of other boxes, I think Android our kodi on android is the problem.
So indead thanks to Coreelec.

On android my u9 biggest issue is when streaming 4k movies the minix restart after +/- 1 hour of streaming
with CoreElec no problem

Concerning to your 3rd paragraph: it never happened to me, at least until now, it always worked well in 1080 or 4K 60fps, but there was always hiccups in the sound in 70% of the files and the HDR did not always work well, which was overcome with CoreElec. I only use the box to play HDD video files via USB, Box, Amp, TV with HDMI 2.1 cables and I want a good image without artifacts and sound from the original source, any one from ACC to TrueHD or Atmos, without fail, and at this moment only with CoreElec it works well.
PS: Did your U9 only with android ver.6 have no sound flaws?
Txs in advance

The restart of the box happens only when streaming and only on android( v6 our 7…) not when playing from USB hdd our streaming with CoreElec

My sound issues on android:

First audio drops in Dtshd and truehd
After update to kodi 17 no support anymore for Dtshd an truehd this option is just gone in settings.
At least no passtrought it work but onkyo received it like Pcm 5.1
I buy a newer version of my onkyo reciver for 4k support.
Audio passthrough (included Dtshd and truehd) are working fine.
But now have the restart issue.

On Coreelec everything woks fine with the old and new onkyo reciver from the start.
So now I bearly use the android os only if I need something that’s not available on a kodi addon

Read what Portisch said. Don’t get a U22-XJ if you want to run CoreELEC on it.
At least not yet.

I have a rev.a too:
CoreGT:~ # cat /proc/cpuinfo | grep Serial
Serial : 290a4000010e0a000017383856584d50
but emmc says:
# ceemmc
Starting CoreELEC eMMC installation tool v0.1…
System is not supported: g12b_s922x_beelink_gt_king_rev_a!
so how did you manage to install CE to eMMC ?


If you read instruction until the end then you will find a hint for unsupported devices :wink:

@ boot2k3 Thanks! you can be pretty sure I read this (and more).
and that got me puzzled… how could @umbala have succeeded.
So I ask 1:1 @umbala: (or anyone else) are you sure you installed to eMMC on a rev A ?
Maybe by using -x ?

Yep, with -x you could install on internal on almost any not supported -ng device…

1 Like

And so I did … (I used -v too) Thanks!

I’m running on internal on my gt-king rev a.

Works just fine, but it went sideways when I rebooted to internal from an EmuElec sdcard and the bootloader seemed to get corrupted. Had to re-flash android to get the bootloader back to stock and then redo the ceemmc -x command all over again!

Hi @Portisch
My device Soc version
/storage$ cat /proc/cpuinfo | grep Serial
Serial : 290a4000010b10000009393856584d50

Just my 50c to Bee-Link GT King (Rev.A)

  • for the few bucks runs as smooth as my big htpc build (>500€, Intel i3 GB SSD) at an insane power cconsumption and passively cooled. The CPU performance of the 922x is more than enough for Core Elec even at 1800 MHz. In comparison was my 905x box choppy on GUI
  • 4K HDR on my OLED TV and bitstream audio o my AVR leave no wishes unfulfilled (my HTPC cannot do that!)
  • ceemmc tool worked like a charm, installed dual boot to the mcc without any problems in a few secs
  • the remote is to forget… mainly haptically
1 Like

I agree, my previous s905x could not handle hts HD channels given by my x86 tvheadend server (via dvb-c) but this 922x does it well.

Hi,
I have continuous audio drop outs when playing this YouTube video in 4K@24 on my GT King Pro:

The device is GT King Pro S922X rev. B running CE 9.2.1 stable.

My TV is Sony KD-43XE7096 (2017 model, 4K LCD, HDR10) connected to HDMI2 with “Enhanced mode” enabled (should support up to 18 Gbps HDMI link). I’ve tried to disable the “Enhanced HDMI mode” but it does not have any effect.

Display Info: http://ix.io/2hbx

YouTube add-on is set to 4K, 60 fps and HDR disabled.

Display info during playing this video shows:
3840x2160p24Hz
YUV444, 10-bit
SDR

The image is nice and smooth but the audio drops for a while every second.

When I use the whitelist option to disable the 4K@24 mode, then the video mode is switched to 4K@60 and YUV420 10-bit and the audio plays fine (but the video is not so smooth as in 4K@24 mode).

Playing my other local videos in the 4K@24 and 10-bit YUV444 mode but in HDR10 HEVC works fine. Both with decoded multi-cahnnel PCM audio and in the passthrough mode.

Also other 4K videos from YouTube in 25,30,60 fps play without problems.

Any ideas? Can you guys play this video on your GT King (Pro) in 4K@24 mode?

Thank you.

Hi if you are playing this video directly from the YouTube app it won’t work since it needs to be software decoded. There is only enough processing power to decide @ 1080P using the S922x.

Hardware decoding will be used for local 4K video files

You can play 4K video from youtube no problem, and it’s going to be hardware decoded.

@KOPRajs try in latest nightly build.

I’ve found out that it depends on the stereo vs. multi-channel audio. There are other 4K@24 HDR videos on YouTube (mostly movie trailers) but with multi-channel audio and these play fine. They are using exactly the same video mode with the multi-channel audio being the only difference.

So the problem only affects 4K@24, 10-bit, YUV444 display mode with stereo AAC audio.
The same 4K@24 video mode with multi-channel AAC audio works fine.
Other 4K display modes with the same stereo AAC audio works fine as well.

Everything is hardware decoded. The problem is dropping audio, video plays fine.

You need to select the Multi-Ch PCM audio device in settings, not HDMI, and set the correct number of channels.

Thanks for the tip.

It turned out I needed to do exactly the opposite! :slight_smile:

I only have a stereo audio system and the number of channels was correctly set to 2.0. The output device was set to Multi-Ch PCM by default. In this configuration there is the problem with dropping audio when playing YouTube video in 4K at 24 fps and with stereo audio.

So I tried to change the output device to HDMI and it solved the problem for me.

The volume on my box is very low, especially when compared to other sources I have on the tv (Blu-ray) also plugged in an hdmi port.

I tried to increase the volume amplication and the volume level, but I need to reach the max values to have something with a “correct” level.

Any idea how this could be explained/debugged ? It has always been the case with 9.2.1 and 9.2.2 too. And it happens when using passthrough or not.