[S922X] Bee-link GT King

Thank you very much for the suggestion … I encountered this problem since I clean install ce matrix but before when using ce leia I do not have this problem when install ce leia … you update me clean install, is my problem here ??? … but besides that i have x96 air device and i also clean install ce matrix but my x96air is working normally and my gt King is like that :fearful: :sweat: :sweat: :anguished: :anguished:
my gt king run CE matrix on sandisk extreme pro 64gb u3 A2 V30 not from eMMC

there is a lot of differences

  • CoreELEC dt-id: g12b_s922x_beelink_gt_king in dmesg
  • run from SSD versus eMMC
  • upgrade clean versus from Leia

I would suggest, try run Leia from (test) SSD and look at dt-id in dmesg
Upgrade that test Leia to Matrix and see what gives.

Also, eventually moving to eMMC may also help.

But, perhaps issue is rev b versus rev a, then, testimonials from other rev b users is much more relevant than suggestions from rev a users.

Note that booting major different systems major different ways may perhaps need ‘toothpick’ or other special tricks on some devices.

1 Like

I have tried clean install CE leia and then updated the tar file to the CE matrix like you but the result is still not much different … maybe now I only have the last way to try it is to install the ce matrix nightly :joy::joy:

:joy: :joy:

Seems like rev_a versus rev_b may be your main difference?
Did Leia dmesg show rev_b ?
If so, similar rev_b testimonials could confirm matrix issue …
Thanks for your personal experience, I was about to buy a gt-king for someone but now I hesitate,

Most of the sample GT-Kings the team got were rwvB and the problem isn’t happening in our side. Can you check what’s the android firmware you have currently?


Thanks @Vasco to confirm rev_b does not have problem on team side. So I may again decide to buy one for a friend.

1 Like

i use android tv version 9 and before when i installed the ce i don’t have the above situation … i have also factory android firmware but the problem still hasn’t been solved with ce matrix :disappointed:

I tried to clean install or update from leia … even use another micro sd high speed… i tried everything. only since installing ce matrix i have been like that and in leia everything is good

Does anybody have video stutter problems with the GT King? I wrote about it here: Video stutter when active subtitles

No problems after reboot, the box stays on 24/7; it happens immediately if I play a movie after turning on the TV.

Hi! I would like to ask that when scrolling or scrolling, the bottom of the screen is banded for me, there is the middle of the screen. 9.2.6 is the last where you haven’t done this ever since, I’ve tried all the settings already. gt king, revb. So if you wind up for 10s or 30s, the greenish, whitish bar is most often confusing. It has been since 9.2.7 and is on a matrix as well. If I put version 9.2.6 clearly, the wrapping is smooth there. Thank you and otherwise nice work.

I have been looking everywhere, but I cannot find any info regarding my Beelink GT King box. It is a B992x, NOT S922x.

Can I run CoreELEC? Which one do I use?

I’m an absolute n00b in regard to CoreELEC, though have some experience with custom roms on android, some Linux background, and am a regular tinkerer.

Any help?

Use the download page:

Do not mix up serial number with SoC type.

I change name dtb.img but no boot coreelec?

Hi All,

I’ve been using CoreELEC with Mecool KI Pro for few years and recently have bought the Beelink GT King box (revision 6B9X).
With Beelink I have two issues that I was not able to resolve:

  1. TV (LG OLEDC8) remove control is not controlling Kodi using CEC. At the same CEC functionality is partially working, for example when I switch source input on TV the playback is paused in Kodi and resumed when I switch back.
  2. Micro freezes while watching IPTV streams. Video pauses for a second and then quickly catches up on fast forward. This happens using both IPTV PVR simple and TVHeadend, probably more often with IPTV simple. There are no freezes if I watch a high bitrate movie server over Samba share.

Using CoreELEC 19.2 RC2, freshly installed to Beelink internal storage and then a backup configuration from Meecool restored on it.

Any help or ideas how I can resolve these issues would be greatly appreciated.

Thanks in advance,

I would first try with fresh install from SD card without restoring backup.

Just tested running from SD card with clean CoreELEC (only installed IPTV Simple plugin).

With this setup micro freezes seem to be gone, but CEC still not working. Symptoms are same: none of remote control buttons control Kodi but when source is switched, playback is paused/resumed correctly.

Between clean install and my existing backup the only major differences that I can think of are:

  1. Running from eMMC instead of SD Card
  2. Using MySQL as storage for movie information.
  3. Samba enabled

CEC is for sure working on the CE device but the LG C8(9) series are known as bit “bitch” with CEC. Simplink needs to be enabled for each port and device on the TV. Also maybe it start working when choose another HDMI port. Also the cable can be the reason.

Sorry I did not put that in my original post but I have already tried switching ports and cables and that did not help. Also I have zero issues with CEC using same TV but with Mecool KI pro.
You’ve mentioned that I need to enable Simplink for each port but I am not aware of such option on my TV. There is only global option enable Simplink, with the only other option to synchronize power state across devices (already tried turning that off/on)

Cannot add another reply to this thread yet, so posting logs to this message:
cat ~/.kodi/temp/kodi.log | paste

This is on clean install CoreELEC running from SD card. I enabled logging for libCEC and pressed few keys on TV remote before uploading the log.

Than a more detailed setup description is needed. What device is where connected?

Create debug log:
Enable kodi debug logging and additional enable libCEC component for logging. Then reproduce the error and share your kodi.log.

Has anyone tested the wifi6 SMB speed?
Is it good for 80Gb 4K bd remux @ wifi6 from local NAS?
Try to see some review on youtube but only saw AC 5Ghz wifi test (wifi5), I didn’t see any wifi6 AX test.

My AV cabinet didn’t have RJ45 jack. I used two redmi AX6 to wireless bridge via wifi 6. AX6 didn’t have client mode so it will broadcast wifi signal. I only got about 600Mbps and it was lag when playing 80Gb 4K bd remux on X96 max+ thru RJ45 to AX6.

X96 max±----(RJ45 cable)-----AX6-----(wifi 6)-----AX6-----(RJ45 cable)-----Router

Laptop is easy to achieve 1000Mbps wifi 6 speed by AX200 or RTL8852AE wifi 6 pci-e chip. If GT King wifi6 edition can run up to 1000Mbps via wifi. I would change X96 to GT King.

I am sorry for the late report, but ever since upgrading from the old 9.2.6 version to the later 19.x versions, I am experiencing an issue with SPDIF/Optical Out. Essentially, after starting the file playback, I have a random long delay before getting any audio. It is very noticeable when transcoding is needed (sometimes it takes minutes before having audio), such as files with AAC audio recorded from a live broadcast. Once the audio starts working, it stays working (even if the file is rewound to its beginning). However, stopping the file or queuing a new file may trigger the issue once again. It is pretty much unnoticeable (i.e., it just works) if my aging home-theater supports the audio, that is, all ok with AC3 or DTS (but not EAC3).

I was shying away from reporting the issue, mostly because I do not have more useful information to help debug the issue. I know everything works well if I connect the optical to the TV and send the audio through HDMI (passthrough with AC3 transcoding). However, I would prefer getting it straight from the box (my TV makes switching between the home-theater and the internal speakers quite cumbersome; furthermore, my TV no longer supports DTS passthrough).

Has anyone else experienced something like this? My GT-King is of the B922 variant, which is essentially the original S922X only with DDR4 RAM instead of LPDDR4. I have also tried the latest nightly to see if the issue was fixed, but it still remains.

(Edit: it’s just B922 not B922X)